Design & Build

Data Center Solution-Design Guide: Configure Brocade VDX in 'Standalone Mode' with Cisco STP

by on ‎07-25-2013 09:40 AM - edited on ‎04-09-2014 03:57 PM by pmadduru (6,976 Views)

Synopsis: This publication provides design guidance for various types of STP used in connections between VDX Switches and Catalyst 6500 switches.Brocade VDX Switches are often deployed in the Access layer at the Top-of-Rack in Standalone mode using STP. In many data centers, they connect to existing Cisco Catalyst 6500 switches in the Aggregation layer.

 

Contents

Preface

Overview

This document provides design guidance to how to connect up Brocade VDX Switches on 'Standalone Mode' to existing Cisco’s Catalyst Switches' infrastructure running STP (Spanning Tree Protocol).

 

When VDX Switches are connected up to existing customer's infrastructure running STP, NOS 3.0.x VDX Switches on 'Standalone Mode' support active participation in STP by sending STP BPDUs' (Bridge Packet Data Units) frames and processing received STP BPDUs' frames. However, NOS 3.0.x VCS Fabric does not support STP (which means NOS 3.0.x VCS Fabric does not send STP BPDUs frames, nor does it process received STP BPDUs frames), but it floods received STP BPDU frames into ports in the same VLAN, and therefore, the VCS fabric is seen as a wire connection from existing customer infrastructure’s point of view. There are use cases for NOS 3.0.x VCS Fabric to be connected up to existing customer infrastructure running STP, so please use the following reference.

 

References

 

NOS 4.0.x VCS Fabric supports active participation in STP by sending STP BPDUs' frames and process received STP BPDU's frames while preserving full benefit of Brocade Ether Fabrics, and future publication about this is planned.

 

The document is not intended for the deployment scenarios connecting up NOS 4.0.x VCS Fabric to existing customer's infrastructure running STP, but it is intended for the deployment scenarios connecting up VDX Switches on 'Standalone Mode' running NOS 3.0.x or onward to existing customer's infrastructure running STP.

 

Purpose of This Document

This design guide describes to how to design and configure Brocade’s VDX Switches’ STP for interoperability when deployed into the existing datacenter network with Cisco Catalyst 6500 Switches using STP.

 

The following Brocade and Cisco platforms are used in this design guide.

  • Brocade VDX 6730 Switch
  • Cisco Catalyst 6500 Switch

Audience

This document is intended for network design and operation staffs who want to add a Brocade VDX switches with STP to an existing data center network with Cisco Catalyst 6500 Switches.

 

Objectives

This design guide provides guidance and recommendations for Brocade VDX Switches’ STP Interoperability with Cisco Catalyst 6500 Switches.

 

Related Documents

The following documents are valuable resources for the designer. In addition, any Brocade release notes that have been published for Brocade VDX Switches should be reviewed.

 

References

 

About Brocade

Brocade® (NASDAQ: BRCD) networking solutions help the world’s leading organizations transition smoothly to a world where applications and information reside anywhere. This vision is designed to deliver key business benefits such as unmatched simplicity, non-stop networking, application optimization, and investment protection.Innovative Ethernet and storage networking solutions for data center, campus, and service provider networks help reduce complexity and cost while enabling virtualization and cloud computing to increase business agility.To help ensure a complete solution, Brocade partners with world-class IT companies and provides comprehensive education, support, and professional services offerings. (www.brocade.com).

 

Key Contributors

The content in this guide was developed by the following key contributors.

  • Lead Architect:          Chris Yoon, Strategic Solutions Lab
  • Technical Author:     Brook Reams, Strategic Solutions Lab

Document History

Date                  Version        Description

2013-07-25         1.0                 Initial Release

2013-08-08         1.1                 STP Root Election Section was Added and LAGs were Added to the Interoperability Test Bed Network 

2013-08-09         1.2                 LAG Design Section was Added

2013-09-30         1.3                 Overview Section was Updated

 

 

Technical Description of STP

It is worthwhile to briefly review the mechanics of the IEEE Spanning Tree Protocol before reviewing the implementation of STP in the VDX Switch family. STP, the IEEE 802.1D bridge protocol, is a Layer 2 link-management protocol that provides path redundancy while preventing undesirable loops in the network. For a Layer 2 Ethernet network to function properly, only one active path can exist between any two stations. STP operation is transparent to end stations that cannot detect whether they are connected to a single LAN segment or a switched LAN of multiple segments. When you create fault-tolerant internetworks, you must have a loop-free path between all nodes in a network. The STP algorithm calculates the best loop-free path throughout a switched Layer 2 network. Layer 2 LAN ports send and receive STP frames at regular intervals. Network devices do not forward these frames, but use the frames to construct a loop-free path. Multiple active paths between end stations cause loops in the network. If a loop exists in the network, end stations might receive duplicate messages and network devices might learn end station MAC addresses on multiple Layer 2 LAN ports. These conditions result in an unstable network. STP defines a tree with a Root Bridge and a loop-free path from the root to all network devices in the Layer 2 network. STP forces redundant data paths into a Standby (Blocked) state. If a network segment in the spanning tree fails and a standby (but not active) path exists, the STP algorithm recalculates the spanning tree topology and activates the standby path. When two Layer 2 LAN ports on a network device are part of a loop, the STP port priority and port path cost setting determine which port is put in the forwarding state and which port is put in the blocking state. The STP port priority value represents the location of a port in the network topology and how efficiently that location allows the port to pass traffic. The STP port path cost value represents media speed.

 

BPDU

The bridges have to determine the Root Bridge and compute the port roles (root, designated, or blocked) with only the information that they have. To ensure that each bridge has enough information, the bridges use special data frames called Bridge Protocol Data Units (BPDUs) to exchange information about bridge IDs and root path costs. A bridge sends a BPDU frame using the unique MAC address of the port itself as a source address, and a destination address of the STP multicast address 01:80:C2:00:00:00. There are three types of BPDUs:

  • Configuration BPDU (CBPDU), used for Spanning Tree computation
  • Topology Change Notification (TCN) BPDU, used to announce changes in the network topology
  • Topology Change Notification Acknowledgment (TCA)

BPDUs are exchanged regularly (every 2 seconds by default) and enable switches to keep track of network changes and to start and stop forwarding at ports as required. When a device is first attached to a switch port, it will not immediately start to forward data. It will instead go through a number of states while it processes BPDUs and determines the topology of the network.

 

STP Interface State Change

When STP is enabled, every switch port that participates in STP starts in the blocking state, and data traffic is allowed only on those ports that are the part of the active spanning tree topology, that is, on those active ports that have transitioned to the forwarding state. The ports that are not participating in the active spanning tree topology are in stand-by mode and are alternate ports that are in the blocking state. These standby ports in blocking state take over when an active port in the spanning tree goes down. The possible states of a Layer 2 running STP are:

  • Blocking: The interface does not forward frames.
  • Listening: The interface is identified by the spanning tree as one that should participate in frame forwarding. This is a transitional state after the blocking state.
  • Learning: The interface prepares to participate in frame forwarding.
  • Forwarding: The interface forwards frames.
  • Disabled: The interface is not participating in spanning tree because of a shutdown port, no link on the port, or no spanning tree instance running on the port.

A port participating in spanning tree moves through these states:

  • From initialization to blocking.
  • From blocking to listening or to disabled.
  • From listening to learning or to disabled.
  • From learning to forwarding, blocking, or disabled.
  • From forwarding to disabled.

 

STP on Brocade VDX Switches

 

Standalone Mode

In Brocade Network Operating System (NOS) version 3.0.x, several STP protocols are supported when the VDX Switch is operating in the Standalone mode, and include:

    • 802.1D Spanning Tree Protocol (STP)
    • 802.1w Rapid Spanning Tree Protocol (RSTP)
    • Multiple Spanning Tree Protocol (MSTP)
    • Per-VLAN Spanning Tree Plus (PVST+)
    • 802.1w Rapid Per-VLAN Spanning Tree Plus (RPVST+)

Note:

The Brocade VDX 8770 running NOS version 3.0.x does not support STP.

For on VDX Switches, LAGs are treated as normal links, and by default is enabled for STP, LAGs should not affect STP interoperability with Cisco Catalyst 6500 Switches.

 

VCS Fabric Mode

On NOS version 3.0.x, in Brocade VCS Fabric mode, all Spanning Tree Protocols are disabled, and are not supported. In Brocade VCS Fabric mode, a VCS cluster does not send BPDUs, but received BPDUs are tunneled through the VCS cluster and are flooded on the all the switch ports instead of VCS cluster processing as shown below.

 

BPDUTunnelingInVCSFabricMode.jpg

   BPDU tunneling in the VCS Fabric mode

 

In Brocade VCS Fabric mode, a network administrator does not want the received BPDUs forwarded out edge ports directly connected to host devices. The “bpdu-drop enable” command is used to drop the received BPDUs on those edge ports, and therefore, BPDUs won’t be forwarded.

 

Root Bridge Election

 

Bridge ID

Each switch has a unique bridge identifier (bridge ID), that determines the selection of the root bridge. The bridge ID is an 8-byte field that is composed of two sub fields:

 

Bridge ID.jpg

Bride ID

 

The value for the bridge priority ranges from 0 to 61440 in steps of 4096. The default value for the bridge priority is 32768. All the switches in the layer 2 network, participating in STP, gather information on other switches in the network through an exchange of BPDUs. As the result of exchange of the BPDUs messages, the switch with the lowest bridge ID is elected as the Root Bridge.

 

Bridge Priority

If all the switches are configured with the default bridge priority of 32769, the switch with the lowest MAC address becomes the Root Bridge. When all the 4 switches are configured with default bridge priority as shown below, VDX6730-A with the lowest MAC address becomes the Root Bridge.

 

  Spanning Tree Topology with All the Switches Configured with Default Bridge Priority.jpg

Spanning Tree Topology with All the Switches Configured with Default Bridge Priority

 

For the bridge priority value occupies the most significant bits of the bridge ID, if a switch is configured with lower bridge priority that other switches, then the switch becomes the Root Bridge. When Cat6500-B is configured with ‘Bridge-priority 0’ and other switches are configured with default bridge priority as shown below, Cat6500-B becomes the Root Bridge.

 

 

Spanning Tree Topology with a Switch Configured with Lower Bridge Priority.jpg

Spanning Tree Topology with a Switch Configured with Lower Bridge Priority

 

STP Interoperability Design

The following sections review how to configure various types of STP on Brocade VDX Switches providing interoperability with Cisco 6500 series switches.

 

 

802.1D STP

 

Overview

IEEE standard 802.1D STP assumes one Spanning Tree instance for the entire bridged network, regardless of the number of VLANs. This implementation reduces CPU load since only one Spanning Tree instance is maintained for the entire network. However, this implementation can be used when only one Layer 2 topology is needed in the network. Since there is one Spanning Tree instance for the entire network, it does not have the ability to load balance Layer 2 traffic by forwarding some VLANs on one 802.1Q (dot1q) trunk and other VLANs on another 802.1Q (dot1q) trunk without causing a Spanning Tree loop.

 

Configurations

The following are IEEE standard 802.1D STP configuration and a sample output from its show command on VDX:

-------------------

A-VDX6730# show running-config protocol spanning-tree

protocol spanning-tree stp

!

A-VDX6730# show spanning-tree brief

Spanning-tree Mode: Spanning Tree Protocol

      Root ID      Priority 24576

                   Address 0017.0fec.f800

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS   20000000   128 P2P               No 

Te 0/17       RTPT FWD  20000      128 P2P               No 

Te 0/18       ALT BLK   20000      128 P2P               No 

-------------------

 

802.1D STP Interoperability

 

Natively, Cisco Switches run a separate STP instance for each configured and active VLAN which is called Per-VLAN Spanning Tree (PVST), they do not have configuration to enable 802.1D STP directly. However, using Multiple Spanning Tree Protocol (MSTP), VLANs can be grouped into a single instance on Cisco Switches. It uses BPDU version 3 which is backward compatible with the 802.1D STP which uses BPDU version 0.

By default, all the VLANs in a Cisco Catalyst Switch on MSTP mode are grouped into IST0, which is called an Internal Spanning Tree (IST) and MST instance 0. 802.1D STP is interoperable with Cisco Catalyst Switches using MST0.  Below shows how MSTP is configured on Cisco Catalyst Switches, and once MSTP is enabled, by default, all the VLANs are grouped into IST0, that is, MST instance 0 as shown below:

-------------------

Cat6500-A#sh run

Building configuration...

!      

spanning-tree mode mst

Cat6500-A#sh spanning-tree mst

##### MST0    vlans mapped:   1-4094

Bridge        address 0017.0fec.f800  priority      32768 (32768 sysid 0)

Root          address 0005.33d3.e2ce  priority      32768 (32768 sysid 0)

              port    Gi1/15          path cost     20000

Regional Root this switch

Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6

Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/13           Desg FWD 20000     128.13 P2p

Gi1/14           Desg FWD 20000     128.14 P2p

Gi1/15           Root FWD 20000     128.15 P2p <-Bound(STP)

Gi1/16           Desg FWD 20000     128.16 P2p <-Bound(STP)

-------------------

 

802.1w RSTP

 

Overview

The IEEE standard 802.1w RSTP can be seen as an evolution of the 802.1D standard. It provides rapid convergence following the failure of a switch, a switch port, or a LAN. It provides rapid convergence of edge ports, new root ports, and ports connected through point-to-point links.

 

The 802.1D STP terminology remains primarily the same. Most parameters have been left unchanged, so network administrators familiar with 802.1D STP can rapidly configure the new protocol comfortably. 802.1w RSTP can also revert back to 802.1D STP in order to interoperate with legacy bridges on a per-port basis. This drops the benefits it introduces.

 

The interface states for every Layer 2 interface running RSTP are as below:

  • Learning: The interface prepares to participate in frame forwarding.
  • Forwarding: The interface forwards frames.
  • Discarding: The interface discards frames. Note that the 802.1D disabled, blocking, and listening states are merged into the RSTP discarding state. Ports in the discarding state do not take part in the active topology and do not learn MAC addresses.

Configurations

 

The following are IEEE 802.1w RSTP configurations and a sample output from its show command on VDX:

-------------------

A-VDX6730# show running-config protocol spanning-tree

protocol spanning-tree rstp

A-VDX6730#show spanning-tree brief

Spanning-tree Mode: Rapid Spanning Tree Protocol

      Root ID      Priority 32768

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Te 0/17       DES FWD  20000      128 P2P               No 

Te 0/18       DES FWD  20000      128 P2P               No 

-------------------

 

801.w RSTP Interoperability

 

Natively, Cisco Catalyst Switches run a separate STP instance for each configured and active VLAN which is called Rapid Per-VLAN Spanning Tree (RPVST), they do not configuration option to enable 802.1w RSTP in a direct manner. However, using MSTP, VLANs can be grouped into a single instance on Cisco Catalyst Switches, and MSTP is fully compatible with RSTP bridges, in that MSTP BPDUs can be interpreted by an RSTP bridge as an RSTP BPDUs.

 

By default, all the VLANs in a Cisco Catalyst switch in MSTP mode are grouped into IST0, which is called an Internal Spanning Tree (IST) and MST instance 0. 802.1w STP is interoperable with Cisco Switches using MST0.  The following shows how MSTP is configured on Cisco switches, and once MSTP is enabled, by default, all the VLANs are grouped into IST0 and MST instance 0 as shown below:

 

-------------------

Cat6500-A#sh run

Building configuration...

!      

spanning-tree mode mst

Cat6500-A#sh spanning-tree

MST0

  Spanning tree enabled protocol mstp

  Root ID    Priority 32768

             Address     0005.33d3.e2ce

             Cost        20000

             Port        15 (GigabitEthernet1/15)

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768  (priority 32768 sys-id-ext 0)

             Address     0017.0fec.f800

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/13              Desg FWD 20000     128.13   P2p

Gi1/14              Desg FWD 20000     128.14   P2p

Gi1/15              Root FWD 20000     128.15   P2p <-Bound(RSTP)

Gi1/16              Desg FWD 20000     128.16   P2p

-------------------

 

PVST+

 

Overview

Per-VLAN Spanning Tree+ (PVST+) maintains a Spanning Tree instance for each VLAN configured in the network. It uses 802.1Q (dot1q) trucking and allows a VLAN trunk to be forwarding for some VLANs while blocking for other VLANs. Since PVST treats each VLAN as a separate network, it has the ability to load balance Layer 2 traffic by forwarding some VLANs on one trunk and other VLANs on another trunk without causing a forwarding loop.

 

PVST+ is not a scalable model when there are many VLANs in the network as it consumes a lot of CPU cycles. By default, Cisco Catalyst switches enable PVST+ instead of 802.1D STP.

 

Configurations

The following are PVST+ configurations and a sample output from its show command on VDX:

 

-------------------

A-VDX6730# show running-config protocol spanning-tree

protocol spanning-tree pvst

!

A-VDX6730# show spanning-tree brief

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Te 0/17       DES FWD  20000      128 P2P               No

Te 0/18       BKUP BLK  20000     128 P2P               No 

VLAN 502     

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol     

      Root ID      Priority 33270

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Te 0/17       DES FWD  20000      128 P2P               No 

Te 0/18       BKUP BLK  20000     128 P2P               No   

-------------------

 

PVST+ Interoperability

 

Brocade VDX Switches support PVST+, but PVST is proprietary to Cisco and is not supported. To interoperate with Cisco Switches in PVST+ mode, the following spanning-tree bpdu-mac command should be configured in the interfaces that are connected to those Cisco Switches. Otherwise, VDX and Cisco Switches will have two different Root Bridges as shown below which indicates PVST+ does not operate correctly.

 

-------------------

switch(config)#interface tengigabitethernet x/x

switch(conf-if-te-0/12)#spanning-tree bpdu-mac 0100.0ccc.cccd

-------------------

-------------------

A-VDX6730# show spanning-tree brief

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Te 0/17       DES FWD  20000      128 P2P               No 

Te 0/18       BKUP BLK  20000      128 P2P               No 

Cat6500-A#sh spanning-tree

VLAN0501 

  Spanning tree enabled protocol ieee

  Root ID    Priority    32768

             Address 0017.0fec.f9f5

             This bridge is the root

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec        

  Bridge ID  Priority 32768

             Address     0017.0fec.f9f5

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/13              Desg FWD 4         128.13   P2p

Gi1/14              Desg FWD 4         128.14   P2p

Gi1/15              Desg FWD 4         128.15   P2p

Gi1/16              Desg FWD 4         128.16   P2p 

-------------------

 

MSTP

 

Overview

 

The IEEE 802.1s MSTP standard creates multiple loop-free active spanning tree topologies on a single physical topology. MSTP allows multiple VLANs to be mapped to the same spanning tree instance (forwarding path) reducing the number of spanning tree instances needed to support a large number of VLANs.

 

Each MSTP instance has a Spanning Tree topology independent of other Spanning Tree instances. With MSTP you can have multiple forwarding paths for data traffic. A failure in one instance does not affect other instances. With MSTP, you are able to more effectively utilize the physical resources present in the network and achieve better load balancing of VLAN traffic.

 

The following diagram shows a common design. Switch A with 1000 VLANs is redundantly connected to two distribution Switches, D1 and D2. In this topology, when users are connected to access Switch A, the network administrator is able to achieve load balancing on the access switch uplinks by mapping half of the 1000 VLANs to a different MSTP instance. In MSTP mode, RSTP is automatically enabled to provide rapid convergence.

Load balancing using MSTP Instances.jpg

 

   Load balancing using MSTP Instances

 

 

Configurations

Multiple switches must be configured consistently with the same MSTP configuration to participate in multiple spanning tree instances. A group of interconnected switches that have the same MSTP configuration is called an MSTP region.

 

Brocade supports 32 MSTP instances and one MSTP region. MSTP introduces a hierarchical way of managing switch domains using regions. Switches that share common MSTP configuration attributes belong to a region.

 

The MSTP configuration determines the MSTP region where each switch resides. The common MSTP configuration attributes are as follows:

  • Alphanumeric configuration name (32 bytes)
  • Configuration revision number (2 bytes)

-------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree mstp

instance 1 vlan 501,503

instance 1 priority 0

instance 2 vlan 502,504

instance 2 priority 4096

region VDX

revision 10

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree mstp

instance 1 vlan 501,503

instance 1 priority 4096

instance 2 vlan 502,504

instance 2 priority 0

region VDX

revision 10

VDX6730-A# show spanning-tree mst brief

Spanning-tree Mode: Multiple Spanning Tree Protocol

CIST Root ID            Priority 32768

                         Address  0005.33d3.e2ce

CIST Bridge ID          Priority 32768

                         Address  0005.33d3.e2ce

CIST Regional Root ID   Priority 32768

                         Address  0005.33d3.e2ce

Configured Hello Time 2, Max Age 20, Forward Delay 15

Max Hops 20, Tx-HoldCount 6

CIST Root  Hello Time 2, Max Age 20, Forward Delay 15, Max Hops 20

CIST Root path cost 0

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

-------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Te 0/17       DES FWD  20000      128 P2P               No       No

Te 0/18       DES FWD  20000      128 P2P               No       No

Instance: 1; Vlans: 501, 503

MSTI Root       Address  0005.33d3.e2ce   Priority 1

MSTI Bridge     Address  0005.33d3.e2ce   Priority 1

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Te 0/17       DES FWD  20000      128 P2P               No       No

Te 0/18       DES FWD  20000      128 P2P               No       No

Instance: 2; Vlans: 502, 504

MSTI Root       Address  0005.33f3.dcc7   Priority 2

MSTI Bridge     Address  0005.33d3.e2ce   Priority 4098

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Te 0/17       RTPT FWD  20000     128 P2P               No       No

Te 0/18       ALT DSC  20000      128 P2P               No       No

-------------------

 

MSTP Interoperability

 

Brocade VDX Switches support IEEE standard 802.1s MSTP as do Cisco Catalyst switches allowing Brocade VDX Switches in MSTP mode to interoperate with Cisco Switches in MSTP mode.

 

To interoperate with certain legacy Cisco Switches not conforming to standard IEEE 802.1s MSTP that support pre-standard MSTP, the cisco-interoperability command is required. The default is Cisco interoperability is disabled. This command is necessary because the “version 3 length” field in the MSTP BPDU on certain legacy Cisco switches does not conform to the current standard IEEE 802.1s MSTP. It shouldn’t be used to interoperate with Cisco Switches conforming to standard IEEE 802.1s MSTP:

 

-------------------

switch(config)#protocol spanning-tree mstp

switch(config-mstp)#cisco-interoperability enable 

-------------------

 

RPVST+

 

Overview

RPVST+ protocol is IEEE standard 802.1w RSTP implementation on a per VLAN basis. RPVST+ protocol uses the RSTP state machine, and has one instance of spanning tree for each VLAN on the switch. PVST+ is not a scalable model when there are many VLANs in the network, as it consumes a lot of CPU cycles. A reasonable compromise between the two extremes of RSTP and R-PVST+ is MSTP.

 

Configurations

The following are IEEE standard 802.1w RSTP configurations and an sample output from its show command on VDX:

-------------------

A-VDX6730# show running-config protocol spanning-tree

protocol spanning-tree rpvst

!

A-VDX6730# show spanning-tree brief

VLAN 501

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 32768

                   Address 0017.0fec.f9f5

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT DSC  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No 

VLAN 502      

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol     

      Root ID      Priority 32768

                   Address 0017.0fec.f9f6

                   Hello Time 2, Max Age 20, Forward Delay 15      

      Bridge ID    Priority 33270

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000      128 P2P               No 

Te 0/6        ALT DSC  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No 

-------------------

 

RPVST+ Interoperability

 

Brocade VDX Switches support RPVST+, but RPVST is proprietary to Cisco and is not supported. To interoperate with Cisco Switches in RPVST+ mode, the following spanning-tree bpdu-mac command should be enabled in the interfaces that are connected to those Cisco Switches. Otherwise, VDX and Cisco Switches may have two different Root Bridges as shown below which indicates PVST+ does not operate correctly.

 

-------------------

switch(config)#interface Tengigabitethernet x/x

switch(conf-if-te-0/12)#spanning-tree bpdu-mac 0100.0ccc.cccd

-------------------

-------------------

VDX6730-A# show spanning-tree vlan 501 brief

VLAN 501

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        DES FWD  2000       128 P2P               No 

Te 0/6        BKUP DSC  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No

Cat6500-A#sh spanning-tree vlan 501

VLAN0501

  Spanning tree enabled protocol rstp

  Root ID    Priority    32768

             Address 0017.0fec.f9f5

             This bridge is the root

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

             Address     0017.0fec.f9f5

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- -----------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/1               Desg FWD 2         128.129  P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Desg FWD 2         128.131  P2p

-------------------

 

LAG Design

 

LAG Overview

LAG (Link Aggregation Group) allows you to bundle multiple physical Ethernet links to form a single logical trunk providing increased total bandwidth, as well as redundancy. The LAG is viewed as a single link by connected devices, the STP, IEEE 802.1Q VLANs, and so on. When one physical member link in the LAG fails, the other member links stay up and there is no disruption to traffic. Note that when connecting switches in different areas of a building with LAGs, a best design practice is to run the cables over different paths to minimize the chances of both cables getting cut simultaneously.

 

Static LAG

In static LAG, member links are added into a LAG without exchanging LACP PDUs between the partner systems. The distribution and collection of frames on static LAG is determined by the operational status and administrative state of the local member links, and therefore, static LAG does not detect misconfigurations on the local end or the remote end of the link. Further, if a switch is used as a media converter between the LAG partner systems, it can happen that the local end is up, but the remote end is down. In this case, the local end still sends data via this connection, but the data transfer is interrupted.

 

Dynamic LAG

In dynamic LAG, LACP, an IEEE 802.3ad standards-based protocol, is used to negotiate which links can be added and removed from a LAG. Typically, two partner systems sharing multiple physical Ethernet links can aggregate a number of those physical links using LACP. LACP creates a LAG on both partner systems, identifies the LAG by the LAG ID, and negotiates LACP timeout value. All links with the same administrative key and all links that are connected to the same partner switch become members of the LAG. LACP continuously exchanges LACP PDUs to monitor the health of each member link.

 

LACP negotiating state operates in two modes:

 

  • Passive mode: LACP responds to LACP PDUs initiated by its partner system, but does not initiate the LACP PDU exchange.
  • Active mode: LACP initiates the LACP PDU exchange regardless of whether the partner system sends LACPDUs.

The LACP timeout setting is used to specify the number of seconds that the system waits before sending control packets to the peer system. If LACP sends three consecutive control packets without receiving a response from the partner system, LACP removes that member link from the LAG. Whenever  the LACP timeout value is changed on a LAG, LACP renegotiates the links that it uses for aggregation on that LAG. The two LACP possible timeout values are:

  • Short: When the timeout value is set to Short, the VDX switch sends LACP control packets to the partner system every 1 second. If the timeout value is set to Short and LACP receives no response from the partner after sending 3 consecutive packets, LACP removes the link from LAG in 3 seconds.
  • Long: When the timeout value is set to Long, the VDX switch sends LACP PDU to the partner system every 30 seconds. If the timeout value is set to Long and LACP receives no response from partner after sending 3 consecutive packets, LACP removes the link from LAG in 90 seconds. The default value for LACP timeout is Long.

LAG Configurations

A LAG with two 10GEs as member ports is configured between the VDX6730-A Switch and the Catalyst 6500-A Switch. The LACP negotiating state is set to Active mode on the both switches, and the LACP timeout is set to Long on both switches:

 

---------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

channel-group 1 mode active type standard

!--- The LAG uses standard LACP, and LACP negotiating state is at active mode.

lacp timeout long

!--- The LACP PDU is sent for every 30 seconds, and the LACP timeout value (when no packet is received from the peer) is 90 seconds.

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/7

interface TenGigabitEthernet 0/7

channel-group 1 mode active type standard

lacp timeout long

no shutdown

Cat6500-A#sh run interface Port-channel 1

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

Cat6500-A#sh run interface TenGigabitEthernet 2/1

interface TenGigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

!--- The LAG uses standard LACP, and LACP negotiating state is at active mode.

end

Cat6500-A#sh run int TenGigabitEthernet 2/4

interface TenGigabitEthernet2/4

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

-------------------------

 

Interoperability Test Results

 

This section offers test results from the Brocade test lab, to provide design guidance on the VDX Switches STP interoperability with Cisco Switches.

 

Interoperability Test Bed Diagram

The figure below shows the STP interoperability test bed network diagram.

 

STP interoperability Test Bed Network.jpg

   STP Interoperability Test Bed Network

 

Interoperability Test Methodology

The STP interoperability test bed consists of two Brocade VDX-6730 and two Cisco Catalyst 6500 Switches. The VDX-6730 Switches are running NOS 3.0.1a in Standalone mode, and the Cisco Catalyst 6500 Switches are running IOS 122-33.SXI. For the traffic sent through the network, flows are established using the Spirent Test Center (STC) tool. The 300 Mbps traffic flows are sent on each STC port and distributed using full mesh and the packet size of the flows is 128 bytes. All interconnections between the VDX-6730 Switches and the Catalyst Switches in the network are 10GE, and all the ports are enabled as Layer 2 trunks using 802.1Q (dot1q) allowing all VLANs.

 

LAG Interoperability Test Result

 

LAG Configurations

 

Two LACP enabled LAGs with two 10GEs as member ports are configured between VDX6730 Switches and Catalyst 6500 Switches, and the following are the LAG configurations used in the interoperability test:

 

---------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

channel-group 1 mode active type standard

!--- The LAG uses standard LACP, and LACP negotiating state is at active mode.

lacp timeout long

!--- The LACP PDU is sent for every 30 seconds, and the LACP timeout value (when no packet is received from the peer) is 90 seconds.

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/7

interface TenGigabitEthernet 0/7

channel-group 1 mode active type standard

lacp timeout long

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/6

interface TenGigabitEthernet 0/6

channel-group 2 mode active type standard

lacp timeout long

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/8

interface TenGigabitEthernet 0/8

channel-group 2 mode active type standard

lacp timeout long

no shutdown

Cat6500-A#sh run interface Port-channel 1

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

Cat6500-A#sh run interface TenGigabitEthernet 2/1

interface TenGigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

end

Cat6500-A#sh run int TenGigabitEthernet 2/4

interface TenGigabitEthernet2/4

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

Cat6500-B#sh run interface Port-channel 2

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

Cat6500-B#sh run interface TenGigabitEthernet 2/1

interface TenGigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 2 mode active

Cat6500-B#sh run interface TenGigabitEthernet 2/4

interface TenGigabitEthernet2/4

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 2 mode active

-------------------------

 

LAG Interoperability Verification

 

The following verifies the two LACP enabled LAGs interoperate between VDX6730 Switches and Cisco 6500 Switches:

 

-------------------------

A-VDX6730# show port-channel detail

LACP Aggregator: Po 1

Aggregator type: Standard

  Actor System ID - 0x8000,00-05-33-d3-e2-ae

  Admin Key: 0001 - Oper Key 0001

  Receive link count: 2 - Transmit link count: 2

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-17-0f-ec-f8-00

  Partner Oper Key 0001

Member ports:

   Link: Te 0/5 (0x18028004) sync: 1  

   Link: Te 0/7 (0x18038006) sync: 1   *

LACP Aggregator: Po 2

Aggregator type: Standard

  Actor System ID - 0x8000,00-05-33-d3-e2-ae

  Admin Key: 0002 - Oper Key 0002

  Receive link count: 2 - Transmit link count: 2

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-19-07-62-98-00

  Partner Oper Key 0002

Member ports:

   Link: Te 0/6 (0x18030005) sync: 1  

   Link: Te 0/8 (0x18040007) sync: 1   *

Cat6500-A#sh etherchannel 1 detail                  

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

                Ports in the group:

                -------------------

                 Port: Te2/1

               ------------

Port state    = Up Mstr In-Bndl

Channel group = 1               Mode = Active        Gcchange = -

Port-channel  = Po1             GC   =   -           Pseudo port-channel = Po1

Port index    = 1               Load = 0x55          Protocol = LACP

Flags:  S - Device is sending Slow LACPDUs.    F - Device is sending fast LACPDUs.

        A - Device is in active mode.                   P - Device is in passive mode.

Local information:

                          LACP port     Admin     Oper    Port    Port

Port      Flags   State   Priority      Key       Key     Number  State

Te2/1     SA      bndl    32768         0x1       0x1     0x202   0x3D 

! --- SA indicates the Port-channel's LACP timeout is long, and its LACP negotiating state is at active mode. 

Partner's information:

          Partner Partner LACP Partner   Partner    Partner   Partner      Partner

Port      Flags   State   Port Priority  Admin Key  Oper Key  Port Number  Port State

Te2/1     SA      bndl   32768           0x0        0x1       0x5           0x3D 

Age of the port in the current state: 3d:06h:37m:51s

Port: Te2/4

------------

Port state    = Up Mstr In-Bndl

Channel group = 1          Mode = Active        Gcchange = -

Port-channel  = Po1        GC   =   -           Pseudo port-channel = Po1

Port index    = 0          Load = 0xAA          Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs          F - Device is sending fast LACPDUs.

        A - Device is in active mode.               P - Device is in passive mode.

Local information:

                         LACP port     Admin     Oper  Port        Port

Port      Flags   State  Priority      Key       Key   Number      State

Te2/4     SA      bndl   32768         0x1       0x1   0x205       0x3D

! --- SA indicates the Port-channel's LACP timeout is long, and its LACP negotiating state is at active mode. 

Partner's information:

          Partner Partner  LACP Partner  Partner     Partner    Partner       Partner

Port      Flags   State    Port Priority Admin Key   Oper Key   Port Number   Port State

Te2/4     SA     bndl      32768          0x0          0x1       0x7            0x3D 

Age of the port in the current state: 3d:06h:37m:51s

                Port-channels in the group:

----------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 47d:21h:57m:59s

Logical slot/port   = 14/1          Number of ports = 2

HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol            = LACP

Fast-switchover     = disabled

Ports in the Port-channel:

Index   Load   Port EC state        No of bits

------+------+------+------------------+-----------

  1     55 Te2/1    Active    4

  0     AA Te2/4    Active    4

Time since last port bundled: 3d:06h:37m:53s    Te2/4

Time since last port Un-bundled: 4d:23h:16m:14s    Te2/4

Last applied Hash Distribution Algorithm: Fixed

----------------

 

Test Result Summary

 

Based the LAGs’ operational state, the test result shows the LACP enabled LAGs interoperate between VDX6730 Switches and Cisco 6500 Switches.

 

802.1D STP Interoperability Test Result

 

Configurations

 

The following is the configuration used in the 802.1D STP interoperability test. 'protocol spanning-tree stp' is configured on VDX6730-A and VDX6730-B each to enable the 802.1.D STP, and 'spanning-tree mode mst' is configured on Cat6500-A and Cat6500-B each to enable MSTP instance 0 which is default instance for the MSTP mode. 'spanning-tree mst 0 priority 0' on Cat6500-A is set in an effort to secure the Root Bridge position:

 

-------------------

VDX6730-A# show running-config protocol spanning-tree 

protocol spanning-tree stp

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree stp

Cat6500-A#sh running-config | in spanning-tree

spanning-tree mode mst

spanning-tree mst 0 priority 0

Cat6500-B#sh running-config | in spanning-tree

spanning-tree mode mst

-------------------

 

Verification for Spanning Tree Topology

In the 802.1D STP interoperability test, for the Cat6500-A has lower bridge priority than other switches, it is elected as the Root Bridge, and therefore, the Port-channel 2 of  the VDX6730-A and the TenGig 0/6 of the VDX6730-B are in the Blocked state as shown below:

 

 

802.1D STP topology.jpg

   802.1D STP Topology

 

-------------------

VDX6730-A#show spanning-tree brief

Spanning-tree Mode: Spanning Tree Protocol

      Root ID      Priority 0

                   Address    0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                    Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Po 1          RTPT FWD 2000       128 P2P               No 

Po 2          ALT BLK  2000       128 P2P               No

VDX6730-B#show spanning-tree brief

Spanning-tree Mode: Spanning Tree Protocol

      Root ID       Priority 0

                    Address  0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                    Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address 0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT BLK   2000       128 P2P               No 

Te 0/9        DES FWD   2000       128 P2P               No 

Cat6500-A#sh spanning-tree  

MST0

  Spanning tree enabled protocol mstp

  Root ID         Priority 0

                  Address 0017.0fec.f800

                  This bridge is the root

                  Hello Time 2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID       Priority 0      (priority 0 sys-id-ext 0)

                  Address     0017.0fec.f800

                  Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/14              Desg FWD 20000     128.14   P2p

Te2/2               Desg FWD 2000      128.130  P2p Bound(STP)

Te2/3               Desg FWD 2000      128.131  P2p

  Po1                Desg FWD 1000      128.1665 P2p Bound(STP)

-------------------

 

Spanning Tree Convergence Time

 

In the 802.1D STP interoperability test, convergence time for a link or a LAG failure is of around 30 seconds, and convergence time for the recovery from the link or the LAG failure is of around 30 seconds.

 

Test Result Summary

Based on verification of Spanning Tree topology and convergence time, the test result shows the 802.1D STP of Brocade VDX interoperates with MSTP instance 0 of Cisco Catalyst 6500 which is the default instance for MSTP, and that LAGs are treated as normal links in the 802.1D STP.

 

802.1w RSTP Interoperability Test Result

 

Configurations

The following is the configurations used in the 802.1w RSTP interoperability test.  'protocol spanning-tree rstp' is configured on VDX6730-A and VDX6730-B each to enable the 802.1.D STP, and 'spanning-tree mode mst' is configured on Cat6500-A and Cat6500-B each to enable MSTP instance 0 which is default instance for the MSTP mode. 'spanning-tree mst 0 priority 0' on Cat6500-A is set in an effort to secure the Root Bridge position:

 

-------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree rstp

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree rstp

Catalyst-A#sh running-config | in spanning-tree

spanning-tree mode mst

spanning-tree mst 0 priority 0

Catalyst-B#sh running-config | in spanning-tree

spanning-tree mode mst

-------------------

 

Verification of Spanning Tree Topology

In the 802.1w RSTP interoperability test, for the Cat6500-A has lower bridge priority than other switches, it is elected as the Root Bridge, and therefore, the Port-channel 2 of the VDX6730-A and the TenGig 0/6 of the VDX6730-B are in the Discarding (Blocked) state as shown below.

 

802.1w RSTP topology.jpg

   802.1w RSTP Topology

 

 

-------------------

VDX6730-A# show spanning-tree brief

Spanning-tree Mode: Rapid Spanning Tree Protocol

      Root ID      Priority 0

                   Address   0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address    0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role  Sts Cost       Prio  Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000     128   P2P               No 

Po 1          RTPT FWD  2000     128   P2P              No

Po 2          ALT DSC  2000       128   P2P               No 

VDX6730-B# show spanning-tree brief

Spanning-tree Mode: Rapid Spanning Tree Protocol

      Root ID      Priority 0

                   Address   0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32768

                   Address    0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128   P2P               No 

Te 0/6        ALT DSC  2000          128  P2P               No 

Te 0/9        DES FWD  2000         128  P2P               No 

Cat6500-A#sh spanning-tree

MST0

  Spanning tree enabled protocol mstp

  Root ID         Priority 0

                  Address 0017.0fec.f800

                  This bridge is the root

                  Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID       Priority 0      (priority 0 sys-id-ext 0)

                  Address     0017.0fec.f800

                  Hello Time   2 sec  Max Age 20 sec Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------

Gi1/14              Desg FWD 20000     128.14   P2p

Te2/2               Desg FWD 2000      128.130  P2p

Te2/3               Desg FWD 2000      128.131  P2p

Po1                 Desg FWD 1000      128.1665 P2p

-------------------

 

 

Spanning Tree Convergence Time

In the 802.1w RSTP interoperability test, convergence time for a link failure or a LAG failure is of around 80 msec, and convergence time for the recovery from the link failure or the LAG failure is of around 4 seconds.

 

Test Result Summary

Based on verification for Spanning Tree topology and convergence time, the test result shows the 802.1w RSTP of Brocade VDX interoperates with that of Cisco Catalyst 6500, and that LAGs are treated as a normal link in the 802.1w RSTP.

 

 

PVST+ Interoperability Test Result

 

Configurations

 

The following is the configuration used in the PVST+ interoperability test. Bridge priority is set to 0 for VLAN 501, 503 on the VDX6730-A, and bridge priority is set to 0 for VLAN 502, 504 on the Cat6500-A. 'protocol spanning-tree pvst' is configured on VDX6730-A and VDX6730-B each to enable PVST+, and 'spanning-tree mode pvst' is configured on Cat6500-A and Cat6500-B each to enable PVST+. 'vlan 501 priority 0'  and 'vlan 503 priority' are set on VDX6730-

A in an effort to secure the Root Bridge position for VLAN 501 and 503. 'spanning-tree vlan 502,504 priority 0' is set on Cat6500-A in an effort to secure the Root Bridge position for VLAN 502 and 504.  After 'protocol spanning-tree pvst' is configured on the VDX6730 Switches, 'spanning-tree bpdu-mac 0100.0ccc.cccd' should be configured on the VDX6730 Switches' interfaces that are connected to Catalyst 6500 Switches:

 

-------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree pvst

vlan 501 priority 0

vlan 503 priority 0

 

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

 

!--- To interoperate with Cisco Switches in PVST+ mode, this should be configured in the interfaces that are connected to those Cisco Switches.

 

 

 

no shutdown

 

 

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

 

spanning-tree bpdu-mac 0100.0ccc.cccd

 

no shutdown

 

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree pvst

VDX6730-B# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

 

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

 

 

VDX6730-B# show running-config interface TenGigabitEthernet 0/6

interface TenGigabitEthernet 0/6

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

 

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

 

 

Catalyst-A#sh running-config | in spanning-tree

spanning-tree mode pvst

 

spanning-tree vlan 502,504 priority 0

 

Catalyst-B#sh running-config | in spanning-tree

spanning-tree mode pvst

-------------------

 

 

Verification of Spanning Tree Topology

VLAN 501, 503

For the VDX6730-A has a bridge priority that is lower than all the other switches, it is elected as the Root Bridge. Therefore, the TenGi 0/6 of the VDX6730-B and the TenGi 2/3 of the Cat6500-B is in the Blocked state as shown in Figure 5-3.

 

PVST+ topology for VLAN 501,503.jpg

PVST+ Topology for VLAN 501, 503

 

 

-------------------

VDX6730-A# show spanning-tree vlan 501 brief

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 501

                   Address   0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 501

      Address      0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Po 1          DES FWD  2000       128 P2P               No 

Po 2          DES FWD  2000       128 P2P               No 

VDX6730-B# show spanning-tree vlan 501 brief

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 501

                   Address   0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT BLK  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No

Cat6500-A#sh spanning-tree vlan 501

VLAN0501

  Spanning tree enabled protocol ieee

  Root ID         Priority 501

                  Address   0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

                   Cost        1

                   Port        1665 (Port-channel1)

                   Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

                  Address     0017.0fec.f9f5

                  Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

                  Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Desg FWD 2         128.131  P2p

Po1                 Root FWD 1         128.1665 P2p

Cat6500-B#sh spanning-tree vlan 501

VLAN0501

  Spanning tree enabled protocol ieee

  Root ID    Priority 501

             Address 0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

              Cost        1

              Port        1665 (Port-channel2)

              Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID   Priority 32768

              Address     0019.0762.99f5

              Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

              Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Altn BLK 2         128.131  P2p

Po2                 Root FWD 1         128.1665 P2p

-------------------

 

VLAN 502, 504

For the Cat6500-A has a bridge priority that is lower than all the other switches, it is elected as the Root Bridge. Therefore, the Port-channel 2 of the VDX6730-A and the TenGig 0/6 of the VDX6730-B are in Blocked state as shown below.

 

PVST+ topology for VLAN 502,504.jpg

   PVST+ Topology for VLAN 502,504

 

 

-------------------

VDX6730-A# show spanning-tree vlan 502 brief

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                   Address   0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

      Address      0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Po 1          RTPT FWD  2000      128 P2P               No 

Po 2          ALT BLK  2000       128 P2P               No 

VDX6730-B# show spanning-tree vlan 502 brief

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                   Address  0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

      Address      0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT BLK  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No 

Cat6500-A#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

             Address 0017.0fec.f9f6

                              This bridge is the root

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 0   

             Address     0017.0fec.f9f6

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- -----------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/1               Desg FWD 2         128.129  P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Desg FWD 2         128.131  P2p

Cat6500-B#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

             Address 0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

             Cost        2

             Port        131 (TenGigabitEthernet2/3)

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

             Address     0019.0762.99f6

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- -----------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Root FWD 2         128.131  P2p

Te6/4               Desg FWD 2         128.644  P2p

Po2                 Desg FWD 1         128.1665 P2p

-------------------

 

 

Spanning Tree Convergence Time

 

In the PVST+ interoperability test, convergence time for a link failure or a LAG failure is of around 47 seconds, and convergence time for the recovery from the link failure or the LAG failure is of around 30 seconds.

 

Test Result Summary

Based on verification for Spanning Tree topology and convergence time, the test result shows the PVST+ of Brocade VDX interoperates with that of Cisco Catalyst 6500, and that that LAGs are treated as normal links in the PVST+.

 

 

MSTP Interoperability Test Result

 

Configurations

The following is the configurations used in the MSTP interoperability test, and 3 MSTP instances, including default instance 0, are enabled on the VDX and Cisco Cat6500 Switches.'protocol spanning-tree mstp' is configured on VDX6730-A and VDX6730-B each to enable MSTP, and instance 1, 2 for VLAN  501,503 and VLAN 502,504, region of VDX, and revision of 10 are set under 'protocol spanning-tree mstp' mode. 'spanning-tree mst 0-1 priority 0' is configured on the Cat6500-A in an effort to secure the Root Bridge for MSTP instance 0 and 1, and 'instance 2 priority 0' on the VDX6730-A is configured in an effort to secure the Root Bridge position for MSTP instance 2:

 

-------------------

VDX6730-A#show running-config protocol spanning-tree

protocol spanning-tree mstp

instance 1 vlan 501,503

instance 2 vlan 502,504

instance 2 priority 0

!--- This is configured in an effort to secure the Root Bridge position for MSTP instance 2.

region VDX

revision 10

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree mstp

instance 1 vlan 501,503

instance 2 vlan 502,504

region VDX

revision 10

Cat6500-A#sh run | be spanning-tree

spanning-tree mode mst

!

spanning-tree mst configuration

name VDX

revision 10

instance 1 vlan 501, 503

instance 2 vlan 502, 504

!

spanning-tree mst 0-1 priority 0

!--- This is configured in an effort to secure the Root Bridge for MSTP instance 0 and 1.

Cat6500-B#sh run | be spanning-tree

spanning-tree mode mst

!

spanning-tree mst configuration

name VDX

revision 10

instance 1 vlan 501, 503

instance 2 vlan 502, 504

-------------------

 

Verification of Spanning Tree Topology

MSTP instance 0, 1

For the Catalyst-A has a bridge priority that is lower than all the other switches, it is elected as the Root Bridge. Therefore, the Port-channel 2 and the Tengig 2/2 of the Catalyst-B are in the Blocked state as shown below.

 

MSTP instance 0,1 topology.jpg

MSTP Instance 0,1 Topology

 

 

-------------------

VDX6730-A# show spanning-tree mst brief

Spanning-tree Mode: Multiple Spanning Tree Protocol

CIST Root ID            Priority 0

                        Address  0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

CIST Bridge ID          Priority 0

                        Address  0005.33d3.e2ce

CIST Regional Root ID   Priority 0

                        Address  0017.0fec.f800

Configured Hello Time 2, Max Age 20, Forward Delay 15

Max Hops 20, Tx-HoldCount 6

CIST Root  Hello Time 2, Max Age 20, Forward Delay 15, Max Hops 19

CIST Root path cost 0

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

-------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Po 1          RTPT FWD  2000       128 P2P               No       No

Po 2          DES FWD  2000       128 P2P               No       No

Instance: 1; Vlans: 501, 503

MSTI Root       Address 0017.0fec.f800   Priority  1

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

MSTI Bridge     Address 0005.33d3.e2ce   Priority  32769

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Po 1          RTPT FWD  2000       128 P2P               No       No

Po 2          DES FWD  2000       128 P2P               No       No

VDX6730-B# show spanning-tree mst brief

Spanning-tree Mode: Multiple Spanning Tree Protocol

CIST Root ID            Priority 0

                        Address  0017.0fec.f800

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

CIST Bridge ID          Priority 0

                        Address  0005.33f3.dcc7

CIST Regional Root ID   Priority 0

                        Address  0017.0fec.f800

Configured Hello Time 2, Max Age 20, Forward Delay 15

Max Hops 20, Tx-HoldCount 6

CIST Root  Hello Time 2, Max Age 20, Forward Delay 15, Max Hops 19

CIST Root path cost 0

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

-------------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No       No

Te 0/6        DES FWD  2000       128 P2P               No       No

Te 0/9        DES FWD  2000       128 P2P               Yes No

Instance: 1; Vlans: 501, 503

MSTI Root       Address 0017.0fec.f800   Priority  1

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

MSTI Bridge     Address 0005.33f3.dcc7   Priority  32769

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No       No

Te 0/6        DES FWD  2000       128 P2P               No No

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Cat6500-A#sh spanning-tree mst 0-1

##### MST0    vlans mapped:   1-500,505-4094

Bridge        address 0017.0fec.f800  priority 0     (0 sysid 0)

Root          this switch for the CIST

Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6

Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Desg FWD 2000      128.130 P2p

Te2/3            Desg FWD 2000      128.131 P2p

Po1              Desg FWD 1000      128.1665 P2p

##### MST1    vlans mapped:   501,503

Bridge        address 0017.0fec.f800  priority 1     (0 sysid 1)

Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Desg FWD 2000      128.130 P2p

Te2/3            Desg FWD 2000      128.131 P2p

Po1              Desg FWD 1000      128.1665 P2p

Cat6500-B#sh spanning-tree mst 0-1

##### MST0    vlans mapped:   1-500,505-4094

Bridge        address 0019.0762.9800  priority      32768 (32768 sysid 0)

Root          address 0017.0fec.f800  priority 0     (0 sysid 0)

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

              port Te2/3           path cost     0

Regional Root address 0017.0fec.f800 priority      0     (0 sysid 0)

internal cost 2000      rem hops 19

Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6

Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Altn BLK 2000      128.130 P2p

Te2/3            Root FWD 2000      128.131 P2p

Po2              Altn BLK 1000      128.1665 P2p

##### MST1    vlans mapped:   501,503

Bridge        address 0019.0762.9800  priority      32769 (32768 sysid 1)

Root          address 0017.0fec.f800  priority 1     (0 sysid 1)

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

            port    Te2/3           cost      2000                 rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Altn BLK 2000      128.130 P2p

Te2/3            Root FWD 2000      128.131 P2p

Po2              Altn BLK 1000      128.1665 P2p

-------------------

 

MSTP instance 2

For the VDX6730-A has lower bridge priority than other switches, it is elected as the Root Bridge, and therefore, the TenGig 0/6 of the VDX6730-B and the TenGig 2/3 of the Cat6500-B are in the Blocked state as shown below.

 

 

MSTP instance 2 topology.jpg

MSTP Instance 2 Topology

 

 

-------------------

VDX6730-A# show spanning-tree mst instance 2 brief

Instance: 2; Vlans: 502, 504

MSTI Root       Address  0005.33d3.e2ce   Priority 2

MSTI Bridge     Address  0005.33d3.e2ce   Priority 2

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               Yes      No

Po 1          DES FWD  2000       128 P2P               No       No

Po 2          DES FWD  2000       128 P2P

VDX6730-B# show spanning-tree mst instance 2 br

Instance: 2; Vlans: 502, 504

MSTI Root       Address  0005.33d3.e2ce   Priority 2

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

MSTI Bridge     Address 0005.33f3.dcc7   Priority  32770

Interface     Role Sts  Cost       Prio Link-type        Boundary  Edge

--------------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No       No

Te 0/6        ALT DSC  2000       128 P2P               No       No

Te 0/9        DES FWD  2000       128 P2P               Yes No

Cat6500-A# sh spanning-tree mst 2

##### MST2    vlans mapped:   502,504

Bridge        address 0017.0fec.f800  priority      32770 (32768 sysid 2)

Root          address0005.33d3.e2ce  priority 2     (0 sysid 2)

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

            port    Po1             cost      1000                 rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Desg FWD 2000      128.130 P2p

Te2/3            Desg FWD 2000      128.131 P2p

Po1              Root FWD 1000      128.1665 P2p

Cat6500-B# sh spanning-tree mst 2

##### MST2    vlans mapped:   502,504

Bridge        address 0019.0762.9800  priority      32770 (32768 sysid 2)

Root          address 0005.33d3.e2ce  priority 2     (0 sysid 2)

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

               port    Po2 cost      1000                 rem hops 19

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/14           Desg FWD 20000     128.14 P2p

Te2/2            Desg FWD 2000      128.130 P2p

Te2/3            Altn BLK 2000      128.131 P2p

Po2              Root FWD 1000      128.1665 P2p

-------------------

 

 

Spanning Tree Convergence Time

In the MSTP interoperability test, convergence time for a link failure or a LAG failure is of around 5 seconds, and convergence time for the recovery from the link failure or the LAG failure is of around 30 seconds.

 

 

Test Result Summary

Based on verification of Spanning Tree and convergence time, the test result shows the MSTP of Brocade VDX interoperates with that of Cisco Catalyst 6500, and that LAGs are treated as normal links in the MSTP.

 

 

RPVST+ Interoperability Test Result

 

Configurations

 

The following is the configuration used in the RPVST+ interoperability test. 'protocol spanning-tree rpvst' is configured on VDX6730-A and VDX6730-B each to enable PVST+, and 'spanning-tree mode rapid-pvst' is configured on Cat6500-A and Cat6500-B each to enable RPVST+. 'vlan 501 priority 0'  and 'vlan 503 priority' are set on VDX6730-A in an effort to secure the Root Bridge position for VLAN 501 and 503. 'spanning-tree vlan 502,504 priority 0' is set on Cat6500-A in an effort to secure the Root Bridge position for VLAN 502 and 504.  After 'protocol spanning-tree pvst' is configured on the VDX6730 Switches, 'spanning-tree bpdu-mac 0100.0ccc.cccd' should be configured on the VDX6730 Switches' interfaces that are connected to Catalyst 6500 Switches:

 

-------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree rpvst

vlan 501 priority 0

vlan 503 priority 0

!--- This is configured in an effort to secure the Root Bridge position for VLAN 501 and 503.

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-B# show running-config protocol spanning-tree

protocol spanning-tree rpvst

VDX6730-B# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-B# show running-config interface TenGigabitEthernet 0/6

interface TenGigabitEthernet 0/6

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

Catalyst-A#sh running-config | in spanning-tree

spanning-tree mode rapid-pvst

spanning-tree vlan 502,504 priority 0

!--- This is configured in an effort to secure the Root Bridge position for VLAN 502 and 504.

Catalyst-B#sh running-config | in spanning-tree

spanning-tree mode rapid-pvst

-------------------

 

 

Verification of Spanning Tree Topology

 

VLAN 501, 503

 

For the VDX6730-A has lower bridge priority than other switches, it is elected as the Root Bridge. Therefore, the TenGi 0/6 of the VDX6730-B and the TenGi 2/3 of the Cat6500-B is in Discarding (Blocked) state as shown below.

 

 

RPVST+ topology for VLAN 501,503.jpg

RPVST+ Topology for VLAN 501,503

 

 

-------------------

VDX6730-A# show spanning-tree vlan 501 br

VLAN 501

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 501

                                            Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 501

                                             Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role  Sts Cost       Prio  Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Po 1          DES FWD  2000       128 P2P               No 

Po 2          DES FWD  2000       128 P2P               No 

VDX6730-B# show spanning-tree vlan 501 br

VLAN 501

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 501

                                            Address 0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

                   Address 0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT DSC  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No 

Cat6500-A#sh spanning-tree vlan 501

VLAN0501

  Spanning tree enabled protocol rstp

  Root ID    Priority 501

                              Address 0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

             Cost        1

             Port        1665 (Port-channel1)

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

             Address     0017.0fec.f9f5

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

----------------- ---- --- --------- -------- --------------------------------

Gi1/14              Desg FWD 4         128.14 P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Desg FWD 2         128.131  P2p

Po1                 Root FWD 1         128.1665 P2p

Cat6500-B#sh spanning-tree vlan 501

VLAN0501

  Spanning tree enabled protocol rstp

  Root ID    Priority 501

                              Address 0005.33d3.e2ce

!--- This is the MAC address of the VDX6730-A, the Root Bridge.

             Cost        1

             Port        1665 (Port-channel2)

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

             Address     0019.0762.99f5

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

----------------- ---- --- --------- -------- --------------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Altn BLK 2         128.131  P2p

Po2                 Root FWD 1         128.1665 P2p

-------------------

 

 

VLAN 502, 504

For the Cat6500-A has lower bridge priority than other switches, it is elected as the Root Bridge. Therefore, the Port-channel 2 of the VDX6730-A and the Tengig 0/6 of the VDX6730-B are in Discarding (Blocked) state as shown below.

 

RPVST+ topology for VLAN 502,504.jpg

RPVST+ Topology for VLAN 502,504

 

 

-------------------

VDX6730-A# show spanning-tree vlan 502 brief

VLAN 502

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                                            Address 0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

                   Address 0005.33d3.e2ce

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DES FWD  2000       128 P2P               No 

Po 1          RTPT FWD  2000       128 P2P               No 

Po 2          ALT DSC  2000       128 P2P               No 

VDX6730-B# show spanning-tree vlan 502 br

VLAN 502

Spanning-tree Mode: Rapid Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                                            Address 0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

                   Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

                   Address 0005.33f3.dcc7

                   Hello Time 2, Max Age 20, Forward Delay 15, Tx-HoldCount 6

                   Migrate Time 3 sec

Interface     Role Sts  Cost       Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000       128 P2P               No 

Te 0/6        ALT DSC  2000       128 P2P               No 

Te 0/9        DES FWD  2000       128 P2P               No

Cat6500-A#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol rstp

  Root ID    Priority 0

                              Address 0017.0fec.f9f6

             This bridge is the root

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 0   

             Address     0017.0fec.f9f6

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ------------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Desg FWD 2         128.131  P2p

Po1                 Desg FWD 1         128.1665 P2p

Cat6500-B#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol rstp

  Root ID    Priority 0

             Address     0017.0fec.f9f6

!--- This is the MAC address of the Cat6500-A, the Root Bridge.

             Cost        2

             Port        131 (TenGigabitEthernet2/3)

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority 32768

             Address     0019.0762.99f6

             Hello Time   2 sec Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- ----------------------------

Gi1/14              Desg FWD 4         128.14   P2p

Te2/2               Desg FWD 2         128.130  P2p

Te2/3               Root FWD 2         128.131  P2p

Po2                 Desg FWD 1         128.1665 P2p

-------------------

 

Spanning Tree Convergence Time

In the RPVST+ interoperability test, convergence time for a link failure or a LAG failure is of around 4 seconds, and convergence time for the recovery from the link failure or the LAG failure is of around 30 seconds.

 

Test Result Summary

Based on verification for Spanning Tree and convergence time, the test result shows the RPVST+ of Brocade VDX interoperates with that of Cisco Catalyst 6500, and that LAGs are treated as normal links in the RPVST+.

Comments
by SteveMN
on ‎08-10-2013 06:47 AM

Excellent document, provides critical information needed for deploying Brocade VDX technology and solutions into Cisco 6500 Catalyst environments.

by eyoon
on ‎08-12-2013 12:15 AM

Thanks a lot SteveMN for your comment and feedback on the document.

by eyoon
on ‎08-12-2013 12:35 AM

In the latest version 1.2, a LAG design section was added as a high level item, and it describes considerations for LAG design options. Please let me know if you think of anything that can be added to make the document more useful, or if you have any questions about the document.

by dmasyga_1
on ‎08-12-2013 06:27 AM

Great document.  Really like the examples followed by the actual test results.  This doc along with the other nexus interop docs posted in communities is providing an excellent foundation for implementing VDX switches into existing environments.

by eyoon
on ‎08-12-2013 11:02 AM

Thanks a lot dmasyga for your comment and feedback on the document.

by eyoon
on ‎09-17-2013 11:47 PM

The following deployment guide that has been published recently was added to the related documents:

Deployment Guide-Brocade VDX with STP and Cisco Catalyst Switches

Contributors