Application Delivery (ADX)

Reply
Occasional Contributor
Posts: 8
Registered: ‎11-22-2011

Wonder about the ARP request rate

Hi

I'm using ServerIron ADX 1016 with PREM license to load balancer around 40 servers which are both web servers, database servers. We have checked on our servers and found ton of ARP request broadcast from the load balancer (2 units of ADX).

Here is the tcpdump result from just only 1 server.

# tcpdump -i eth0 -nn arp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
10:40:59.806883 arp who-has 192.168.130.11 tell 192.168.130.252
10:40:59.806932 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:40:59.806941 arp who-has 192.168.130.12 tell 192.168.130.252
10:40:59.902864 arp who-has 192.168.130.1 tell 192.168.130.252
10:40:59.903040 arp who-has 192.168.130.2 tell 192.168.130.252
10:41:00.367661 arp who-has 192.168.130.11 tell 192.168.130.251
10:41:00.367669 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:00.567646 arp who-has 192.168.130.1 tell 192.168.130.251
10:41:00.567805 arp who-has 192.168.130.2 tell 192.168.130.251
10:41:01.102610 arp who-has 192.168.130.250 tell 192.168.130.250
10:41:01.502837 arp who-has 192.168.130.11 tell 192.168.130.252
10:41:01.502846 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:01.502902 arp who-has 192.168.130.12 tell 192.168.130.252
10:41:01.503160 arp who-has 192.168.130.1 tell 192.168.130.252
10:41:01.503169 arp who-has 192.168.130.2 tell 192.168.130.252
10:41:01.867132 arp who-has 192.168.130.11 tell 192.168.130.251
10:41:01.867140 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:02.066945 arp who-has 192.168.130.1 tell 192.168.130.251
10:41:02.267039 arp who-has 192.168.130.2 tell 192.168.130.251
10:41:02.703434 arp who-has 192.168.130.11 tell 192.168.130.252
10:41:02.703442 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:02.703446 arp who-has 192.168.130.12 tell 192.168.130.252
10:41:02.801500 arp who-has 192.168.130.1 tell 192.168.130.252
10:41:02.903263 arp who-has 192.168.130.2 tell 192.168.130.252
10:41:03.204002 arp who-has 192.168.130.250 tell 192.168.130.250
10:41:03.367325 arp who-has 192.168.130.11 tell 192.168.130.251
10:41:03.367333 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:03.567323 arp who-has 192.168.130.1 tell 192.168.130.251
10:41:03.567332 arp who-has 192.168.130.2 tell 192.168.130.251
10:41:04.203078 arp who-has 192.168.130.11 tell 192.168.130.252
10:41:04.203086 arp reply 192.168.130.11 is-at 78:2b:cb:5d:41:60
10:41:04.203091 arp who-has 192.168.130.12 tell 192.168.130.252
10:41:04.303180 arp who-has 192.168.130.1 tell 192.168.130.252
10:41:04.303191 arp who-has 192.168.130.2 tell 192.168.130.252
Note: the ip address was modified to hide the system confidential.
Some servers have more frequent of ARP request because of they are the real servers but bind to several virtual ip address. I believe that this behavior occur because the healthchk setting.
I have tried several settings to reduce the amount of ARP request from ADX but none of them are work. For example
  • "server no-periodic-arp" or         "server periodic-arp-interval 120" ==> both commands cannot change the rate of ARP broadcast
  • set static mac or arp entry are still cannot solve the problem
  • changed the healthcheck of port 80 from "tcp keepalive 3 2" to         "tcp keepalive 10 2" is still the same

Here are the server port profile settings.

server port 80                                                   

session-sync

tcp

tcp 2

tcp keepalive 10 2


server port 3306

session-sync

tcp

tcp keepalive 10 2

All of our servers are real server (no remote).

So my question is, is there anyway to tell the healthcheck (server port profile) to use privious cached ARP entry instead of sending ARP request all the time.

Occasional Contributor
Posts: 8
Registered: ‎11-22-2011

Re: Wonder about the ARP request rate

The problem is solved.

This  issue is only seen when we globally disable L3 healthchecks.  So for  the workaround we can use “no server no-real-l3-check” or enable L3  healthchecks.

Thank Brocade TAC support for this workaround.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

Click to Register
Download FREE NVMe eBook