Application Delivery (ADX)

Reply
Contributor
Posts: 39
Registered: ‎05-04-2009

Web Application Firewall - some HTTP responses do not get through the ServerIron

Hi all,

I am fighting with my first Web Application Firewall installation. The configuration is working fine using simple test requests. Nevertheless it is not woking as soon as I move into production. Some responses to not get through the ServerIron for some reason. The request itself is going to the real server but the real server responses does not go to the client. It is an HTTP application based on ASP... any ideas?

Thanks!

Super Contributor
Posts: 316
Registered: ‎05-01-2009

Re: Web Application Firewall - some HTTP responses do not get through the ServerIron

What is the release you are running at? Is it maybe "chunked" traffic coming back from the real server? Have a look at the "Transfer-Encoding" header of the real server reply.

Contributor
Posts: 39
Registered: ‎05-04-2009

Re: Web Application Firewall - some HTTP responses do not get through the ServerIron

It is 10.2.01i and it is indeed chunked traffic - why do you ask? Is there a know problem in that area?

Super Contributor
Posts: 316
Registered: ‎05-01-2009

Re: Web Application Firewall - some HTTP responses do not get through the ServerIron

I would suggest to upgrade to 10.2.01l which is available since last week. The reason I have been asking is the following bug I found in one of my setups a few weeks ago:

Symptom:

A ServerIron configured for Application Firewall Switching (APPFW) drops HTTP responses received from a real server with the header “Transfer-Encoding: chunked”.

Resolution: Fixed in Release 10.2.01l.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook