Application Delivery (ADX)

Reply
Occasional Contributor
Posts: 17
Registered: ‎11-10-2010

Persistent hash problem after configuring max-conn, disable/enable

I deployed ServerIron ADX4000 as cache load balancing using TCS feature. In this environment, I have 3 cache servers (SwiftCache). ServerIron has been done some TCS feature such url hashing, selective cache content base on cache server, spoofing support, http-cache-control etc.

Everything has been alright until I found hashing problem when I disable/enable, configure max-conn or add new cache server. Hashing doesn’t work correctly like result below:

telnet@SI-ADX4000-vbp#show cache-group

############ BP 1/1 output start #############

Cache-group 1 has 3 members Admin-status = Enabled Active = 0

Hash_info: Dest_mask = 255.255.255.0 Src_mask = 0.0.0.0

Cache Server Name                Admin-status Hash-distribution  L7-Hash-Buckets

cs72                             6            0                  256           << - group 20

cs70                             6            0                  386           <<<<<<<<<<<<<<<<<<<<<- group 10 hash problem !!

cs71                             6            0                  -130          <<<<<<<<<<<<<<<<<<<<< - group 10 hash problem !!

..

In this case, I disabled and enabled CS70 traffic was distributed to CS70 instead CS71 even though I waited over 10 minutes but nothing matter even though “csw-force-rehash” is using. Until, I removed and put “default hash-persist”  back. (default hash-persist url search-url "" offset 0 length 80). Everything become alright like result below and traffic is distributed to both cache server (CS70 and CS71).

############ BP 1/1 output start #############

Cache Server Name                Admin-status Hash-distribution  L7-Hash-Buckets

cs72                             6            0                  256           << - group 20

cs70                             6            0                  129           <<<<<<<<<<<<<<<<<<<<< group 10 half and half

cs71                             6            0                  127           <<<<<<<<<<<<<<<<<<<<< group 10 half and half

In another case, I put “max-conn 1000” command into cache servers. The problem like above happened again and couldn’t work around by re-enabling “default hash-persist” anymore until reboot server. Please see testing scenarion in the picture below:

max-conn_issue_resize.jpg

Please give me your suggestion for this case

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Persistent hash problem after configuring max-conn, disable/enable

Ho Tony,

     That to me looks like a bug to me.  Suggest you log a TAC ticket for this one.

     What version of code do you have? Might be best to check the releanse note for the latest version to see if it is a kown bug or not.

Thanks

Michael.

Occasional Contributor
Posts: 17
Registered: ‎11-10-2010

Re: Persistent hash problem after configuring max-conn, disable/enable

Hi Michael,

It's using version 12.2.01T403

Thank you so much!!!

Tony

Occasional Contributor
Posts: 17
Registered: ‎11-10-2010

Re: Persistent hash problem after configuring max-conn, disable/enable

Hi Michael,

Cool!!! I upgraded software to lastest version (Version 12.2.01bT403). The release-note mentions about fixing many bugs (TCS as well). I testes with many scenarios it's working !! The result shows like example below:

2_DisableCS70WithoutClearHashBucket_resize.jpg

Cheers,

Tony

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Persistent hash problem after configuring max-conn, disable/enable

Hi Tony,

     Glad you got a fix to the issue.

Thanks

Michael.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.

vADC is now Pulse Secure
Download FREE NVMe eBook