vADC Forum

Reply
Occasional Contributor
Posts: 8
Registered: ‎01-03-2013
Accepted Solution

HTTP body empty with Stingray

Hello,

We have a problem with our Stingray.

We are exposing a REST web service through Stingray reverse proxy. It seems that Stingray drops some HTTP requests when :

- The HTTP Body is empty (which can occur quite often with REST web services)

AND / OR

- The HTTP response code is 201 (which can also occur with REST services)

My question is therefore simple : How can we ensure that Stingray does not drop our HTTP requests in such situation ?

We have tried different things in the config and had a look at the logs but we were not able to get this working.

Using another reverse proxy worked perfectly fine. Our backend server exposing the REST web service is an IIS Server (WCF).

Thanks in advance for your help.

Adrien.

Contributor
Posts: 74
Registered: ‎10-03-2011

Re: HTTP body empty with Stingray

Hi Adrien,

That shouldn't be happening obviously. Have you opened a support ticket about this issue?

You say Stingray is dropping your requests, but then talk about responses, did you mean to say that Stingray is dropping your responses? You could try enabling verbose logging of server and client connection failures under Services -> Virtual Servers -> _VS_NAME_ -> Connection Management -> Connection Error Settings.

It's hard to suggest what might be happening without more information, eg. A Techinical Support Report and if possible a tcpdump of the failing requests. This may not be the sort of thing you want to post to a public forum, which is why I would urge you to open a support ticket.

Cheers,

Mark

Occasional Contributor
Posts: 8
Registered: ‎01-03-2013

Re: HTTP body empty with Stingray

Thank you very much for your help. We have solved this Stingray issue.


Regards,


Adrien

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.