vADC Forum

Reply
New Contributor
Posts: 3
Registered: ‎03-14-2013
Accepted Solution

HTML login

I'm currently creating a dashboard to allow me to visually monitor multiple clusters.  I currently have some html written as a proof of concept that is using iframes for the cluster status applet.  The issue I am running into is that anytime I refresh my browser cache the iframes pull up the login screens for the load balancers and not the applet status until I log into to every load balancer on the page (about 20).  I've tried injecting the username and password into the html of the iframe using:

https://exampleIP/apps/zxtm/login.cgi/?username=my.usernameSmiley Tongueassword=my.password

This displays the following in the username box:

my.usernameSmiley Tongueassword=my.password

I'm unsure of what I need to use as a separator to get the password into the password field.

Does anyone have any ideas or alternative ways for me to accomplish this?

Frequent Contributor
Posts: 321
Registered: ‎11-29-2012

Re: HTML login

Hi Josh,

The following worked for me:

(obviously, set admin and admin to the correct username and password)

regards

Owen

ps: the separator is '&', as per Query string - Wikipedia, the free encyclopedia.

New Contributor
Posts: 3
Registered: ‎03-14-2013

Re: HTML login

Hey Owen,

Thanks so much this worked perfectly.  I had tried a few separators including the ampersand   It seems that I was using the id, but not the form id for the username and password fields.

Thanks again,

Josh

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.