vADC Forum

Reply
New Contributor
Posts: 3
Registered: ‎11-06-2013
Accepted Solution

Deprecated commands

Hi guys,

I have a little question on deprecated commands.

We are running v9.2 in productive environment and I want to upgrade it to 9.6r1.

I already done that in my test lap and as we know, some commands are deprecated. Like request.getlogenabled oder request.setlogenabled.

My question is: After the upgrade process, are my Traffic Script Rules still working, cause it's "just" a warning and it's normally processed or is my rule invalid and I am not able to handle any requests?

kind regards,

Matthias

Brocadian
Posts: 232
Registered: ‎11-29-2012

Re: Deprecated commands

Matthias,

    deprecated TrafficScript functions will warn you whenever they are saved but will still work - at least for a while. After the command is deprecated, it is no longer supported (ie: you can't raise a support case for problems with the function) and it will be removed at a later date in the future.

It is best practice to replace deprecated calls with their suggested replacements as soon as is possible.

Google Chrome122.png

Hope this helps.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.