Fibre Channel (SAN)

Reply
Contributor
Posts: 34
Registered: ‎03-02-2010

tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hello

tim_txcrd_z_vc  0- 3 & tim_txcrd_z_vc  4- 7 counter not shown when portstatsshow is executed against E-Port

1. VC_Link_init is ON

2. QoS is Enabled

Ideally the counter tim_txcrd_z_vc  0- 3 & tim_txcrd_z_vc  4- 7 should be shown(4Gbps switch) when the portstatsshow x command is run as shown in the below example

stat_mc_to              0           Multicast timeouts
stat_mc_tx              0           Multicast frames transmitted
tim_rdy_pri             3           Time R_RDY high priority
tim_txcrd_z             0           Time BB credit zero (2.5Us ticks)
tim_txcrd_z_vc  0- 3:  0           0           0           2134951  
tim_txcrd_z_vc  4- 7:  2148225     0           0           0        
tim_txcrd_z_vc  8-11:  0           0           0           0        
tim_txcrd_z_vc 12-15:  0           0           0           0

But in our case the tim_txcrd_z_vc  0- 3 & tim_txcrd_z_vc  4- 7 counter not shown when portstatsshow is executed against E-Port

Please advise

Thanks

Chetan

Regular Contributor
Posts: 201
Registered: ‎11-24-2009

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hi Chetan,

My first two guesses would be (1) older firmware version and (2) older hardware that doesn't support this.

Linar

Contributor
Posts: 34
Registered: ‎03-02-2010

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hello Linar

Firmware: FOS v6.3.2b

Hardware: DS-4100B & DS-4900B

Thanks

Chetan R

Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Is it

1- the counters for the VC's aren't displayed

or

2- the counters are displayed but have 0 for each VC?

If its 1 it coiuld be a frimware or platform issue, should it be 2 then your're lucky as it would seem you have enough buffer credits available.

Contributor
Posts: 34
Registered: ‎03-02-2010

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hello

The counters for the VC's aren't displayed

Thanks

Chetan

Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

A, like linar.ziatdinov said, then it's not there because your hardware (probably) doesn't support it.

Regular Contributor
Posts: 201
Registered: ‎11-24-2009

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hi Chetan,

I checked some of the logs I had. It seems that 4G platforms do not offer that level of detail. If my memory serves me well, these extra lines started to show up on 8G platforms.

Hope this helps a bit,

Linar

Regular Contributor
Posts: 178
Registered: ‎04-21-2008

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hi -

To confirm Linar, I've checked on a 48K running 6.3.2b. On a FC8-32 card (8G hardware), counters are available but not on a FC4-32 (4G).

Hope this helps

Regards,

--

david

Contributor
Posts: 34
Registered: ‎03-02-2010

Re: tim_txcrd_z_vc 0- 3 & tim_txcrd_z_vc 4- 7 counter not shown when portstatsshow is executed against E-Port

Hello Linar/David


Many thanks for the confirmation,
Yes you are right

For a 4100 running FOS v6.4.2a ( Or any FOS ) Then I think the portstatsshow output I'm seeing is working as designed ( For F or E port), as this is a 4GB switch.


On a 4GB switch/asic then from portstatsshow there is a value of tim_txcrd_z only.

tim_txcrd_z 0 Time BB credit zero (2.5Us ticks)


The portstatsshow command output shows further information when on a 8GB or 16GB switch. ( Following from an 8GB switch.)

tim_txcrd_z 11340 Time TX Credit Zero (2.5Us ticks)

tim_txcrd_z_vc 0- 3: 11340 0 0 0
tim_txcrd_z_vc 4- 7: 0 0 0 0
tim_txcrd_z_vc 8-11: 0 0 0 0
tim_txcrd_z_vc 12-15: 0 0 0 0

So for a 4100 "pizza box" or other 4GB hardware ( switch/blades) then whatever the FOS version the portstatsshow output will not show a tim_txcrd_z_vc output only tim_txcrd_z .


Please note in the command reference guide and cli help for portstatsshow , the command output is platform dependant.

Thanks

Chetan

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.