Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 6
Registered: ‎07-22-2015

persistentdisable command disabled all the ports of the san switch

Hi,

The persistentdisable -i <port_index> command was used to disable some ports, but surprisingly it has disabled all the ports of the san switch. Is there any known issue or bug of this type.

The Switch details are :- M48 SAN director and the FOS 6.4.3d

Occasional Contributor
Posts: 11
Registered: ‎07-02-2015

Re: persistentdisable command disabled all the ports of the san switch

I dont have the relaese notes for 6.4.3 but I would upgrade the fOS since you are so far behind.... there have ben a lot of fixes and enhancements since 6.4.3....

Valued Contributor
Posts: 539
Registered: ‎03-20-2011

Re: persistentdisable command disabled all the ports of the san switch

It will be interesting to see the actual command used to disable ports from clihistory.

Regarding the upgrade: 48K doesn't support anything higher than 6.4x, so 6.4.3d is not "so far behind". Though, the latest GA is 6.4.3g anyway, so there is a chance for improvement.
Occasional Contributor
Posts: 6
Registered: ‎07-22-2015

Re: persistentdisable command disabled all the ports of the san switch

Hi,

 

The command executed was persistentdisable -i 1 3 5 9 .

this command should disabled only the selected ports but howcome it has disabled all the ports is not understandable.

 

External Moderator
Posts: 4,907
Registered: ‎02-23-2004

Re: persistentdisable command disabled all the ports of the san switch

[ Edited ]

sam429,

 

you use a wrong command !

 

first at all:

 

"persistentdisable" ? what you want to disable persistent ?

 

in order to disable port's in a range persistenmt, you have to use the command "portcfgpersistentdisable"

 

Second:

 

since you have a blade System Switch ( 48K is a Blade Class Directors ) you have to use the command with:

 

slot_number/ ( operands index ) port_number

 

for exact details I suggest to refer the Command Reference Manuals

TechHelp24
Occasional Contributor
Posts: 6
Registered: ‎07-22-2015

Re: persistentdisable command disabled all the ports of the san switch

Antonio

I have used the portcfgpersistentdisable command only. It was a typo in older post.

And for the SAN directors it is not mentioned that only slot_number/ ( operands index ) port_number will work.

We can use the portcfgpersistentdisable -i portindex seprated by space can be used.

Same way I have done for another SAN directory and it worked perfectly, but in one director this issue happened.

External Moderator
Posts: 4,907
Registered: ‎02-23-2004

Re: persistentdisable command disabled all the ports of the san switch

sam,

 

even if they use the right command "portcfgpersistentdisable", of Blade Switch Class Director's the operand /slot or -s must be used in order to disable the correct port range.

 

I'm at the moment in Germany and don't have access to my LAB, but next week I'll test to try to disable the same port with exact same command as you get the the impact. i have 4 Brocade 48K in my LAB all with different FOS release.

 

however:


as Alexey written:

It will be interesting to see the actual command used to disable ports from clihistory.

 

can you please collect the CLI History an post here ? supportsave from the switch in question would be fine :-)

 

I assume follow, in a moment of inattention you use a wrong operands.

 

now, the answer is in the CLI History and supportsave

TechHelp24
Frequent Contributor
Posts: 130
Registered: ‎02-05-2014

Re: persistentdisable command disabled all the ports of the san switch

I would like to see the clihistory on this one as I'm fairly sure a typo was made.

Kind regards,
Erwin van Londen
Brocade Distinguished Architect
http://www.erwinvanlonden.net The Fibre Channel blog


Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.