Fibre Channel (SAN)

Reply
New Contributor
Posts: 3
Registered: ‎02-14-2012

overheating / manually disable fans?

Hello,

I have an older Silkworm 3850 in my office for lab and testing purposes.

Because of the temperatur in the testing rack is very low the device could turn off the fans. The problem is that all four fans are running too loud.

Warrenty is no problem - the device is too old. I can´t pull the fans off the mainboard of the switch because the switch shuts down with the message that all fans has failed and there could be a possible overheating then.

Di Feb 14 2012 15:38:32 GMT+00:00     Critical     Fan faulty warning time expired. System preparing for shutdown.     Chassis     129553     1     HIL-1508     FC1_2G
Di Feb 14 2012 15:38:32 GMT+00:00     Information     First failure data capture (FFDC) event occurred.     Chassis     129554     1     RAS-1001     FC1_2G

How can I configure the fc switch not to shutdown? Or how can I disable the fan warning or change the fanspeed to 0rpm / off? The switch controls the fans via software - maybe this is possible.

Many thanks

Florian

External Moderator
Posts: 4,787
Registered: ‎02-23-2004

Re: overheating / manually disable fans?

with command "switchstatuspolicyset" can activated/deactivated component

command "switchstatuspolicyshow" show the current config.

TechHelp24
New Contributor
Posts: 3
Registered: ‎02-14-2012

Re: overheating / manually disable fans?

Thanks. Great.

But it is not working as expected. The switch still shuts down.

012/02/14-19:37:40, , 129664, FFDC, CRITICAL, DS_16B3, Fan faulty warning time expired. System preparing for shutdown...

2012/02/14-19:40:54, , 129675,, ERROR, DS_16B3, Fan 1 faulted, speed (0 RPM) below threshold.

2012/02/14-19:41:02, , 129676,, ERROR, DS_16B3, Fan 2 faulted, speed (0 RPM) below threshold.

2012/02/14-19:41:04, , 129677,, ERROR, DS_16B3, Fan 3 faulted, speed (0 RPM) below threshold.

2012/02/14-19:41:07, , 129678,, ERROR, DS_16B3, Fan 4 faulted, speed (0 RPM) below threshold.

Configruation at the moment:

The current overall switch status policy parameters:

                   Down    Marginal

----------------------------------

     PowerSupplies    2           1

      Temperatures    0           0

              Fans    0           0

             Flash    0           1

     MarginalPorts    2           1

       FaultyPorts    1           0

       MissingSFPs    0           0

New Contributor
Posts: 3
Registered: ‎02-14-2012

Re: overheating / manually disable fans?

One little update:

If I unplug all four fans the system shuts down after a while. In the GUI I can see that all fans are faulty but in summary the Fan status is marked as green "ok".

Is there maybe a configfile (with root access) where I can edit the threshold for the fans or disable the fan monitoring?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.