Fibre Channel (SAN)

Reply
Contributor
Posts: 24
Registered: ‎02-16-2012

firmware upgrade Brocade 5300

hi guys

I have 2 Brocade 5300 version 6.2.0g pretty old and buggy.....so the recommendation was to upgrade to 6.3.2e -> 6.4.3 -> and 7 as last version.

so is there a document or someone can mention the steps to do it.

I already have the files v6.3.2e.zip.... for my windows machine

thanks a lot

Regular Contributor
Posts: 226
Registered: ‎01-08-2011

Re: firmware upgrade Brocade 5300

Hello Carlos,

The Fabric OS Administrator's Guide is a good place to start, there's a whole chapter about upgrading firmware.

Basically there are a few ways to do it. I'm pretty sure there should be other posts on this forum on this subject.

You could use BNA to do the upgrade - remember if you use DCFM you need BNA to manage FOS 7 switches.

You can do the upgrade via cli, you type 'firmwaredownload' and then enter the details to an ftp- or scp-server where you have unpacked the downloaded firmware. Then the switch downloads. installs the firmware and then reboots the switch.

Contributor
Posts: 24
Registered: ‎02-16-2012

Re: firmware upgrade Brocade 5300

thanks a lot something else

I am upgrading these Switch since I had a problem with another one....one the issues it has was the flash memory was full

any way to clean the filesystem logs or something?

I mean I've read that filesystem needs to have space in order to make the upgrade so any command to clean it up before doing it

thanks a lot

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: firmware upgrade Brocade 5300

--->>>You could use BNA to do the upgrade...

if you are not experienced, i would avoid to use DCFM or BNA for Upgrade.

9 upgrade from 10 failed with BNA if this is not configured correct.

--->>>....one the issues it has was the flash memory was full

is probable you have some dump file, can be removed with the command

supportsave -R

for details refer CLI Manuals.

TechHelp24
Contributor
Posts: 24
Registered: ‎02-16-2012

Re: firmware upgrade Brocade 5300

thanks a lot antonio

I will have to add the command your pointing "supportsave -R"

and this procedure


Need to update Brocade Firmware levels from 5.0.2 --> 6.1.1 - Toolbox for IT Groups

brocade4Gb:USERID> firmwareshow

Primary partition: v5.0.2

Secondary Partition: v5.0.2

brocade4Gb:USERID>

Commands I am contemplating are :-

1) run supportsave

2) run configupload

3) run errclear

4) firmwaredownload

5) firmwareshow

6) firmwaredownloadstatus

7) version

8) nsshow

9) fabricshow

10) firmwareshow

11) configupload

thanks a lot

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: firmware upgrade Brocade 5300

Carlos,

refer Brocade Official FOS Target Path Document for Upgrade level.

from the command are listed I've never used any such procedure for FOS Upgrade, excepted 2), 4), 5), and 6)

I don't see necessity to do such procedure.

TechHelp24
Regular Contributor
Posts: 226
Registered: ‎01-08-2011

Re: firmware upgrade Brocade 5300

For only upgrading FOS some of these commands are indeed not necessary. But some of them might be useful for verifying that your fabric is operating. Why not throw in: 12) confirm from a host that it can access its LUN?

Contributor
Posts: 24
Registered: ‎02-16-2012

Re: firmware upgrade Brocade 5300

thanks a lot guys

done one of the switch yesterday

procedure followed.

Setup FTP Server in my laptop

> supportSave -R

> configupload

> firmwaredownload

> configupload

thanks a lot

N/A
Posts: 1
Registered: ‎03-14-2013

Re: firmware upgrade Brocade 5300

Hi Guys,

May I know when FOS 7.2.0 will release?

Please also let me know the latest FOS version and upgrade path for the below brocade SAN switrches:

1. BROCADE 200E (v6.2.2f)

2. BROCADE 5000  (v6.4.3)
3. BORCADE 5300  (v6.4.3)

Thanks

Regards,

Tariqul Islam

Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: firmware upgrade Brocade 5300

Greetings tariqul.islam.  Brocade has not announced FOS 7.2 as of yet so there is nothing public to share.  Now regarding your 'target path' question, here is the breakdown:

  • For FOS v6.2... it is v6.2.2f
  • For FOS v6.4... it is v6.4.2a

The above is the Brocade recommend firmware level for each of the major releases. 

Notes on FOS v6.2:

  • Should only be used for the Brocade 200E and 4G embedded switch platforms that are not supported with later Brocade FOS major release levels.

Notes on FOS v6.4:

  • Supported for both Open Systems and FICON environments.
  • For units running in Access Gateway mode utilizing F_Port trunking, Brocade FOS v6.3.2d should be used. For more detailed information, refer to the section following this table that describes the F_Port trunking issue.
  • For the Brocade Encryption Switch or Brocade FS8-18 Encryption Blade in a Brocade DCX® chassis, use Brocade FOS v6.4.2b instead of v6.4.2a.
Regards,

Mike Eversole
Brocade Community Manager

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.