Fibre Channel (SAN)

Reply
Contributor
Posts: 56
Registered: ‎08-22-2008
Accepted Solution

error upgrading FOS from 7.4.1e

Hi

   I have just upgraded SW1 of 2, from FW 7.4.1e to 7.4.2a, without issue, But on SW2  I get the following  message

 

"The following item(s) need to be addressed before downloading the specified firmware:
Upgrade of FOS is not possible due to an invalid license key.  Please contact your reseller"

 

I have compared the licence's on both switch's

 

SW1 has ( This upgraded ok to 7.4.2a )

 

8 Gig FC    NA

Second Ports on Demand license - additional 8 port upgrade    NA

First Ports on Demand license - additional 8 port upgrade    NA

Trunking    NA

Fabric    NA

Extended Fabric,Fabric Watch (Fabric Vision capable),Performance Monitor (Fabric Vision capable),Trunking,Adaptive Networking - obsolete,Server Application Optimization - obsolete    NA   

 

SW2 has the following ( not upgraded still on 7.4.1e )

 

Fabric,Fabric Watch (Fabric Vision capable),Performance Monitor (Fabric Vision capable),Trunking,Full Ports on Demand license - additional 16 port upgrade    NA

 

Enhanced Group Management

 

8 Gig FC    NA

 

It seems strange that all previous updates have not been an issue.

Any advice / help please

many thanks

 

Brocade Moderator
Posts: 105
Registered: ‎04-27-2009

Re: error upgrading FOS from 7.4.1e

Hi,

 

assuming both switches are B300s...

 

I am wondering why the failing switch has a Full POD license (16 ports), while the other one has POD1 and POD2 like I would expect it and like it is on the "working" switch.

 

There has been some license security enhancement starting with 7.4.2 if I remember correctly...

 

It could be possible that you really need POD1 and POD2 from your OEM or where you got this switch from.

 

If you give me the WWN or the output of licenseidshow I can at least tell you what was initially setup for this unit. You can send it in private to me if you want.

 

Doubt it but you can also try to remove the EGM license from the failing switch as a test.

 

TL

 

 

If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution".

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers. All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Contributor
Posts: 56
Registered: ‎08-22-2008

Re: error upgrading FOS from 7.4.1e

Hi Thomas

        How / where do I PM you the details ?

Contributor
Posts: 56
Registered: ‎08-22-2008

Re: error upgrading FOS from 7.4.1e

Many thanks to Thomas  for  identifying the issue, I will locate the OEM details to see if they an provide the correct license information

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.