Fibre Channel (SAN)

Reply
Contributor
Posts: 21
Registered: ‎10-09-2008

brcd 300b switch upgrade to v7.0.2c fails

When trying to upgrade to FOS 7.0.2c,  which I believe is possible on this san switch model, it fails with the following error:

"Upgrade to 7.0 is not allowed because the threshold configuration changed alarm is set for class env,   area PS on FID 128.

Similar configuration may exist for other classes and areas and on other FIDs. Please use "fwconfigure" to unset the same."

Fabric Watch is not licensed on this switch and there is no cmd:  "fwconfigure" available.

How can this be resolved?  tks jmm

jmm
Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: brcd 300b switch upgrade to v7.0.2c fails

Greetings Jimm.  Sorry to hear about this headache you are dealing with.  I've heard of this before, though only in the event that Fabric Watch is installed.  Typically the 'cause' for this scenario is the "changed" options in FW.  As FW is deprecated and no longer supported with 7.x and up, the change settings needs to be defaulted prior to the upgrade.

But if you are saying it isn't (or I'm assuming ever have been) installed, the only option I can think of would be to contact support.  If I come up with anything you can try, I'll post back with suggestions.  If you do contact support, may I request you share the resolution once identified so if others are facing this, they'll know what to do? 

Regards,

Mike Eversole
Brocade Community Manager
External Moderator
Posts: 4,907
Registered: ‎02-23-2004

Re: brcd 300b switch upgrade to v7.0.2c fails

Jimm,

the issue sound very strange to me, since as you say no FW license is installed.

You can try to enable Fabric Watch

Please use this Universal Temporarily Fabric Watch License

CTZH7JDP7GK3HZNaRDQGTaTQ47KYf9YJHH7ALSRDrBJCtANDLA

keep in mind, in order to activated the License, reboot is required and this is disruptive.

TechHelp24
Contributor
Posts: 21
Registered: ‎10-09-2008

Re: brcd 300b switch upgrade to v7.0.2c fails

Thanks Mike,  The only other 'trick' i was thinking of is upgrading with the earliest v7 release first then upgrading 'n times until i get to the version i want.  any thots?

jmm
Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: brcd 300b switch upgrade to v7.0.2c fails

It's definitely worth a shot.    If that doesn't pan out, and a disruption is ok, TechHelp24's is recommending to install a free trial of the FW license from there, you can preview and default the 'changed' settings.  If that's the route you pursue, here is what it looks like (gui)...

FW.png

One additional suggestion you might try...

admin> configshow | grep thresh.cust | grep changed

  1. thresh.cust.env.PS.changed:27

If you see anything like the above, change it back to "0".

Regards,

Mike Eversole
Brocade Community Manager
Frequent Contributor
Posts: 104
Registered: ‎07-27-2009

Re: brcd 300b switch upgrade to v7.0.2c fails

There is an alarms filter configure that monitors the PS area in the ENV class. This is no longer supported in FOS 7.x as the gentlemen above already mentioned.

With FOS 7 these have been moved to a separate class config command called "fwfrucfg"

Try fwfrucfg and reset everything to default. Then try the firmwaredownload again.

I can't test this since all my switches have been moved to 7.1.x already

Let me know.

Regards,

Erwin

http://erwinvanlonden.net

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.