Fibre Channel (SAN)

Reply
Frequent Contributor
Posts: 78
Registered: ‎12-23-2005

autoneg / fixed speed

Hi,

Contributor
Posts: 44
Registered: ‎09-30-2004

Re: autoneg / fixed speed

We had similar recommendations in the past from our support - HDS - and locked everything at 10/Half which did resolve the communications problems that we were experiencing. IMHO this comes into the "if it's not broken, don't fix it" category. If you aren't experiencing any problems then resist the change unless your HP support can provide a valid reason for implementing it.

External Moderator
Posts: 4,813
Registered: ‎02-23-2004

Re: autoneg / fixed speed

Disable auto-negotiation is surely not a fix to solve any problem, however the error are most caused by malconfigured HBA / Array Control Processor port Side. I do not know any Brocade Documentation where is described, that Auto-Negotiation must be Disable or Fixed is reccomended. Disable any Option generally is the fast way to resolved in short Time any Problem, but not a Fix.

TechHelp24
Frequent Contributor
Posts: 78
Registered: ‎12-23-2005

Re: autoneg / fixed speed

Thank you for your replies Bernd

Occasional Contributor
Posts: 16
Registered: ‎11-03-2004

Re: autoneg / fixed speed

I asked exactly same question to a Brocade trainer and she said Brocade Engineering told her the only side effect of using autoneg was that certain error counters were incrementing more often than were with the fixed rate. I think it was enc_errors if I remember well. The ideea was: Leave it into autoneg and if you see error counters for a certain port incrementing too fast try to set it fixed. if still continues after that something is broken and needs replacement (cable HBA, SFP, blade, etc). If the error counter stop incrementing, all was caused by autonegotiation problem and is better to set it not to negotiate, but is not necessary to replace hardware.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.