Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 17
Registered: ‎01-21-2011

Upgrade SAS v3.1.0a


Do you know any way I could upgrade SAS version v3.1.0a for a FA4-18 which sits in a ED48000 with FOS 6.0.0c?

I need this upgrade because I have to install a 32-port 8gb blade in that ED48000 and this cannot be done unless I make some FOS&SAS upgrades.

Thank you,

Mugur Stef

External Moderator
Posts: 4,934
Registered: ‎02-23-2004

Re: Upgrade SAS v3.1.0a

I work in the past with Brocade 7600, and  AFAIK and as far as i remember, you need the SAS Firmware Package in order to upgrade SAS 3.1.0c.

I believe SAS is not a part on FOS 6.0.x

upgrade command is firmwaredownload -a sas -t slotnumber

details refer command reference manauls.

SAS 3.1.0c Release Notes is attached.

TechHelp24
Occasional Contributor
Posts: 17
Registered: ‎01-21-2011

Re: Upgrade SAS v3.1.0a

So, if I would upgrade SAS from v3.1.0a to v3.1.0c then I would be allowed to upgrade FOS from 6.0.0c?

I found some docs showing some relations between FOS 6.0.x and SAS v.3.1.x or between FOS 6.1.x (and later) and SAS v3.2.x (and later) but nothing for the upgrade from FOS 6.0.x to 6.1.x and the required upgrade for SAS.

Thank you,

Mugur Stef

Occasional Contributor
Posts: 17
Registered: ‎01-21-2011

Re: Upgrade SAS v3.1.0a

I have to mention I don't use any feature from SAS. I did use it long time ago but for now I only use that blade only because it has 16 ports like other blades I have in that director.

Thank you,

Mugur

External Moderator
Posts: 4,934
Registered: ‎02-23-2004

Re: Upgrade SAS v3.1.0a

--->>> I found some docs showing some relations between FOS 6.0.x and SAS v.3.1.x or between FOS 6.1.x (and later) and SAS v3.2.x (and later).....

what for docs you have found ?

You have to check accurately SAS Compatibility Release with FOS Release before Upgrade. I was worked with the plattform till SAS 3.4.x, but honestly i forgot which SAS release is most Compatible with FOS Release.

And as mentioned you must have to SAS Package Download, because this is not included in FOS Package.

I've diverse SAS Release Notes, I'll see if I cand find more details and post here.

TechHelp24
External Moderator
Posts: 4,934
Registered: ‎02-23-2004

Re: Upgrade SAS v3.1.0a

--->>> I have to mention I don't use any feature from SAS.

if you use the blade just as "Simple" FC Blade, i think "NO WARRANTY" is not necessary to upgrade the SAS Package.

SAS is required only for DMM Featurings.

TechHelp24
Occasional Contributor
Posts: 17
Registered: ‎01-21-2011

Re: Upgrade SAS v3.1.0a

In fact it's an older post from you:

http://community.brocade.com/docs/DOC-1642

The problem is that I tried to do a FOS upgrade from 6.0.0c to 6.1.2b and it failed with:

dir48k0_firmware_upgrade_failed.png

I am not sure if it is readable. I have support for this director so getting a SAS package should be no problem. I am not sure if SAS 3.1.0c would allow me to upgrade FOS beyond 6.0.0c.

Thank you,

Mugur

External Moderator
Posts: 4,934
Registered: ‎02-23-2004

Re: Upgrade SAS v3.1.0a

Mugur,

--->>> The problem is that I tried to do a FOS upgrade from 6.0.0c to 6.1.2b and it failed with:

in such case you need SAS Package 3.2.0g to have compatibility with FOS 6.1.2b

In short form I've created a Compatibility Liste beetwen diverse SAS and FOS release, Info below are absolutely correct.

SAS 3.1.0 and SAS 3.1.0a are supported only with FOS 6.0.0x ( where character "x" is a Letter )

No other Fabric OS releases should be used in combination with this SAS Release

SAS 3.1.0b, SAS 3.1.0c, and SAS 3.1.0d are supported with FOS 6.0.x ( where character "x" is a minor Number Release Upgrade in FOS ) e.g. "6.0.1"

No other Fabric OS releases should be used in combination with this SAS Release

SAS 3.2.0, SAS 3.2.0a, SAS 3.2.0b, SAS 3.2.0c, SAS 3.2.0d and SAS 3.2.0e are supported only with FOS 6.1.0x ( where character "x" is a Letter )

No other Fabric OS releases should be used in combination with this SAS Release

SAS 3.2.0f is supported only with FOS 6.1.2

No other Fabric OS releases should be used in combination with this SAS Release

SAS 3.2.0g is supported only with FOS 6.1.2b

No other Fabric OS releases should be used in combination with this SAS Release

SAS 3.3.0 is supported only with FOS 6.2.0g

No other Fabric OS releases should be used in combination with this SAS Release

TechHelp24
Occasional Contributor
Posts: 17
Registered: ‎01-21-2011

Re: Upgrade SAS v3.1.0a

So I should first have to upgrade SAS 3.1.0a to 3.1.0c and then FOS 6.0.0c to 6.0.1 or do the FOS upgrade first and then the SAS upgrade?

Mugur

External Moderator
Posts: 4,934
Registered: ‎02-23-2004

Re: Upgrade SAS v3.1.0a

First FOS and then SAS as follow reason.

SAS Required a specific FOS level and not viceversa

TechHelp24

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.