Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 7
Registered: ‎03-25-2015
Accepted Solution

Switch FOS version interoperability

Hi there,

 

I have two pairs of Brocade switches running FOS.

 

The original pair is running 7.0.1 and my new pair is running 7.2.1d.

 

I intend to buy a licence to interconnect the two pairs and extend the fabric onto the new switches.  Can anyone advise whether the two FOS versions are compatible/interoperable or whether I would have to downgrade the new switches to 7.0.1?

 

Is there some documentation which confirms compatability?

 

Thanks,

 

James

Occasional Contributor
Posts: 7
Registered: ‎03-25-2015

Re: Switch FOS version interoperability

Found the answer in the release notes for my switch FOS version, page 14 'Supported Products and FOS Interoperability'

 

http://h20565.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c04157184

Valued Contributor
Posts: 541
Registered: ‎03-20-2011

Re: Switch FOS version interoperability

good that you found it Smiley Happy

your fos versions are compatible, but you'd better upgrade your old one as it is really old Smiley Happy
Occasional Contributor
Posts: 7
Registered: ‎03-25-2015

Re: Switch FOS version interoperability

[ Edited ]

hi guys

 

I was going to downgrade the new switches to 7.0.1 to ensure compatability, but found the following document:

 

https://www.brocade.com/content/dam/common/documents/content-types/faq-external/brocade-6520-6510-6505-faq.pdf

 

It transpires that the 6520 can't run a FOS version older than 7.1 so I cannot downgrade it.  But also on page 12 the document states the following about legacy devices only being supported through FC routing:

 


12
Q.
Will Brocade 6520, 6510, and 6505 Switches work with existing firmware versions in current fabrics?
A.
Brocade 6520 Switches require Brocade FOS 7.1 or higher. Brocade 6510 Switches require Brocade FOS 7.0 or higher. Brocade
6505 Switches require Brocade FOS 7.0.1 or higher. Brocade 6520, 6510, and 6505 Switches are compatible with all 8 Gbps
platforms and 4 Gbps platforms operating with the appropriate firmware. All other legacy devices running prior versions of Brocade
FOS are supported only through Fibre Channel routing. For complete support information, please refer to the respective Brocade
FOS release notes.
 
 
Does that mean I couldn't use the two switches together with an interconnect as originally intended? 
 
The release notes bear no mention of the above limitation.  What limitations will this impose?
 
Thanks,
 
James
Valued Contributor
Posts: 541
Registered: ‎03-20-2011

Re: Switch FOS version interoperability

A usual modern FOS version, like 7.2x or 7.3x is perfectly backward compatible with older FOS releases down to 6.3x or something like this. I'm not sure why you say you can't find this in the release notes. You don't have to keep all the switches at the same exact level. In some cases this is even impossible. If FAQ says that 6505 requires 7.0.1 or higher, you don't have to run it at 7.0.1. You can choose a newer GA release.
Occasional Contributor
Posts: 7
Registered: ‎03-25-2015

Re: Switch FOS version interoperability

Hi Alexey,

 

Thank you for your response.  It's not that I am unable to find the information in the release notes.  The release notes state there is compatability between the two versions.  However the PDF document which I linked above states that they may only support FCR between the new and legacy switches.  The PDF document does not specify what is considered to be a legacy device. The release notes make no mention of this caveat.

 

I am unable to update the FOS version on the older switches, so I am wondering will I be limited to FCR only support and if so what are the implications?  Or should I expect both switch pairs to be able to interact via standard E ports as per normal?

 

Many thanks.

Valued Contributor
Posts: 541
Registered: ‎03-20-2011

Re: Switch FOS version interoperability

> ... compatible with all 8 Gbps platforms and 4 Gbps platforms operating with the appropriate firmware. All other legacy devices running prior versions of Brocade FOS are supported only through Fibre Channel routing.

So, legacy devices are:
- either 2Gbps and older platforms
(do you have any?)
- or 4Gbps and newer platforms BUT running NON-appropriate firmware - i.e. versions lower than listed in your most recent / target FOS release notes
(if you have some, why you wouldn't upgrade FOS on them to the "appropriate" level?)
Occasional Contributor
Posts: 7
Registered: ‎03-25-2015

Re: Switch FOS version interoperability

Ok thank you for the clarification. 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.