Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 5
Registered: ‎11-01-2010

Silkworm 3250

Recently i purchased a silkworm 3250 switch for my vmware lab. I just recieved it today and tried to get a console cable connected but i was unable to sent or recieve any data drom the switch.

Right now the attention light is blinking yellow every second or so and all 8 ports have a yellow and a green light on solid.

Is there a way that i can reset this thing to factory defaults, or hard reset it ?

Also what does the flashing yellow attention light mean? It powers on and seems to go through a POST although i cannot be sure because i cant get the console to send or recieve anything ( and as far as i know my serial cable is fine)

Occasional Contributor
Posts: 5
Registered: ‎11-01-2010

Re: Silkworm 3250

I was able to get into the switch and reset all password however port 2 is saying no_Sync i have ran a configdefault and rebooted but no change... any ideas?

`2010/11/02-00:06:08, , 7,, ERROR, Silkworm3250, Switch set to faulty, rc=30033

it says that port 2 is not sync .... and it turns the switch to ...

FCLAB:root> switchshow
switchName:     FCLAB
switchType:     27.2
switchState:    Faulty
switchMode:     Native
switchRole:     Faulty
switchDomain:   1 (unconfirmed)
switchId:       fffc01
switchWwn:      10:00:00:05:1e:35:34:35
zoning:         ON (FABRIC_B)
switchBeacon:   OFF

Area Port Media Speed State
==============================
  0   0   --    N2   No_Module Disabled
  1   1   --    N2   No_Module Disabled
  2   2   --    N2   Port_Flt  Disabled
  3   3   --    N2   No_Module Disabled
  4   4   --    N2   No_Module Disabled
  5   5   --    N2   No_Module Disabled
  6   6   --    N2   No_Module Disabled
  7   7   --    N2   No_Module Disabled

is there anything i can to do disable port 2 and run with just the other ports or is this thing worthless?

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: Silkworm 3250

EM-1034 indicate a defective FRU.

Remove the SFP from Port 2 and reboot the switch

f the error is continued run the systemVerification command, for detals see in a Command Reference Manuals.

about a config, set the switch to disable "switchdisable" and then try now to delete config

Occasional Contributor
Posts: 5
Registered: ‎11-01-2010

Re: Silkworm 3250

ok so i removed all sfp's and rebooted and got the same error, however if i issue a fastboot command and let it reboot it comes up just fine. I tuned on becons and it seems to be looking for stuff now and i can access the web interface etc. I will try that system verification command and let you know what i find out. Since this is just lab equipment is there anyway to disable the POST from running during a normal boot .... basically force a quick boot each time ?         

Occasional Contributor
Posts: 5
Registered: ‎11-01-2010

Re: Silkworm 3250

Here is the output of the system Verification command

FCLAB:root> switchdisable
FCLAB:root> switchshow
switchName:     FCLAB
switchType:     27.2
switchState:    Offline
switchMode:     Native
switchRole:     Disabled
switchDomain:   1 (unconfirmed)
switchId:       fffc01
switchWwn:      10:00:00:05:1e:35:34:35
zoning:         ON (Lab)
switchBeacon:   ON

Area Port Media Speed State
==============================
  0   0   id    N2   No_Light  Disabled
  1   1   --    N2   No_Module Disabled
  2   2   --    N2   No_Module Disabled
  3   3   --    N2   No_Module Disabled
  4   4   id    N2   No_Light  Disabled
  5   5   --    N2   No_Module Disabled
  6   6   --    N2   No_Module Disabled
  7   7   --    N2   No_Module Disabled
FCLAB:root> systemverification
systemverification: burnin parameters.
CURRENT - KEYWORD       : DEFAULT
1      - number_of_runs        : 1
2      - min_lb_mode   : 2
0      - reset_every   : 0
0      - portlogdump_on        : 0
0      - sof   : 0
2      - vib   : 2
10     - thermal       : 10
BURNIN - label : BURNIN
1      - tbr_passes    : 1
1      - prt_on        : 1
1      - cntmem_on     : 1
1      - cmi_on        : 1
1      - retention_on  : 1
1      - cam_on        : 1
50     - flt_passes    : 50
25     - sta_passes    : 25
50     - txd5_nframes  : 50
0      - txd2_nframes  : 0
100    - plb_nframes   : 100
200    - xpt_nframes   : 200
20     - bpt_nframes   : 20
50     - slk_nmegs     : 50
30     - bpt_all_nframes       : 30
50     - slk_all_nmegs : 50

IMPORTANT: Before starting a burnin run:
IMPORTANT: Please insure that the burnin error log
IMPORTANT: is empty by executing "burninerrclear"

systemverification: Arming the burnin run.
systemverification: Starting burnin
systemverification: Monitoring progress of the burnin activity.
burnin: Sending logs to /var/log/burnin.0.log
burnin: number_of_runs="1"
burnin: min_lb_mode="2"
burnin: reset_every="0"
burnin: portlogdump_on="0"
burnin: sof="0"
burnin: vib="2"
burnin: thermal="10"
burnin: label="BURNIN"
burnin: tbr_passes="1"
burnin: prt_on="1"
burnin: cntmem_on="1"
burnin: cmi_on="1"
burnin: retention_on="1"
burnin: cam_on="1"
burnin: flt_passes="50"
burnin: sta_passes="25"
burnin: txd5_nframes="50"
burnin: txd2_nframes="0"
burnin: plb_nframes="100"
burnin: xpt_nframes="200"
burnin: bpt_nframes="20"
burnin: slk_nmegs="50"
burnin: bpt_all_nframes="30"
burnin: slk_all_nmegs="50"
burnin: debug_on="1"
burnin: plb_lb_mode2="2"
burnin: xpt_lb_mode1="1"
burnin: txd_lb_mode2="2"
burnin: slk_lb_mode2="2"
burnin: mnc_lb_mode1="1"
burnin: mnc_lb_mode2="2"
burnin: slk_lb_mode1="1"
burnin: Run diagClearError
INFO: DIAG MANUAL4 " burnin: Starting run v5.1.0a Tue Nov 2 10:27:22 UTC 2010"
Err# 0140045 0000:101:000:001:0:20:

burnin: Starting run Tue Nov  2 10:27:27 UTC 2010
burnin: Label BURNIN
burnin: BEFORE_RUN: Setting bpt_all_nframes system level test to 30
burnin: BEFORE_RUN: Setting slk_all_nmegs system level test to 50
burnin: Begin run 1 of 1 at command 1 Tue Nov  2 10:27:41 UTC 2010 v{1.78 2.48                                                                                                                                 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: BEFORE_RUN: Not setting margin
getPLLStatus: slot 0 NOLOCAL state
burnin: BEFORE_RUN: Limiting lb_mode xpt_lb_mode1 from 1 to 2
burnin: BEFORE_RUN: Limiting lb_mode mnc_lb_mode1 from 1 to 2
burnin: BEFORE_RUN: Limiting lb_mode slk_lb_mode1 from 1 to 2
burnin: Command #1 Run 1 - Run turboramtest -passcnt 1 --gettemp 1 Tue Nov  2 1                                                                                                                                0:27:54 UTC 2010 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #1 Run 1 PASSED turboramtest Tue Nov  2 10:27:59 UTC 2010 v{1.7                                                                                                                                8 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #1 Run 1 Duration: turboramtest took 0 hr 0 min 7 sec (0:0:7)
burnin: Command #2 Run 1 - Run portregtest --gettemp 1 Tue Nov  2 10:28:03 UTC                                                                                                                                 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #2 Run 1 PASSED portregtest Tue Nov  2 10:28:13 UTC 2010 v{1.78                                                                                                                                 2.48 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #2 Run 1 Duration: portregtest took 0 hr 0 min 11 sec (0:0:11)
burnin: Command #3 Run 1 - Run centralmemorytest --gettemp 1 Tue Nov  2 10:28:1                                                                                                                                9 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #3 Run 1 PASSED centralmemorytest Tue Nov  2 10:28:25 UTC 2010                                                                                                                                 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Command #3 Run 1 Duration: centralmemorytest took 0 hr 0 min 8 sec (0:0                                                                                                                                :8)
burnin: Command #4 Run 1 - Run cmitest --gettemp 1 Tue Nov  2 10:28:30 UTC 2010                                                                                                                                 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Command #4 Run 1 PASSED cmitest Tue Nov  2 10:28:34 UTC 2010 v{1.78 2.4                                                                                                                                7 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Command #4 Run 1 Duration: cmitest took 0 hr 0 min 6 sec (0:0:6)
burnin: Command #5 Run 1 - Run sramretentiontest --gettemp 1 Tue Nov  2 10:28:4                                                                                                                                1 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Command #5 Run 1 PASSED sramretentiontest Tue Nov  2 10:31:24 UTC 2010 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #5 Run 1 Duration: sramretentiontest took 0 hr 2 min 45 sec (0:2:45)
burnin: Command #6 Run 1 - Run cmemretentiontest --gettemp 1 Tue Nov  2 10:31:28 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #6 Run 1 PASSED cmemretentiontest Tue Nov  2 10:32:54 UTC 2010 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #6 Run 1 Duration: cmemretentiontest took 0 hr 1 min 28 sec (0:1:28)
burnin: Command #7 Run 1 - Run camtest --gettemp 1 Tue Nov  2 10:33:00 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #7 Run 1 PASSED camtest Tue Nov  2 10:33:13 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Command #7 Run 1 Duration: camtest took 0 hr 0 min 15 sec (0:0:15)
burnin: Command #8 Run 1 - Run filtertest -passcnt 50 -txports 0/0-7 --gettemp 1 Tue Nov  2 10:33:16 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{28 27 26 25 c}
burnin: Found error in filtertest during run 1 showresult 1 testresult 4
burnin: Command #8 Run 1 FAILED filtertest Tue Nov  2 10:33:28 UTC 2010 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Command #8 Run 1 Duration: filtertest took 0 hr 0 min 14 sec (0:0:14)
burnin: Command #9 Run 1 - Run statstest -passcnt 25 -ports 0/0-7 --gettemp 1 Tue Nov  2 10:33:32 UTC 2010 v{1.78 2.48 3.29 11.94 1.18 3.28 },t{29 27 26 25 c}
burnin: Found error in statstest during run 1 showresult 1 testresult 0
burnin: Command #9 Run 1 PASSED statstest Tue Nov  2 10:34:44 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{30 27 26 25 c}
burnin: Command #9 Run 1 Duration: statstest took 0 hr 1 min 15 sec (0:1:15)
burnin: Command #10 Run 1 - Run txdpath -nframes 50 -lb_mode 5 --gettemp 1 Tue Nov  2 10:34:51 UTC 2010 v{1.78 2.47 3.29 11.94 1.18 3.28 },t{30 27 26 25 c}
systemverification: Terminating - Unit has failed.
systemverification: Stopping activity. This may take a while
Stopping burnin activity.
  Terminating burnin script.
Waiting for all slots to stop burnin activity on slots: 0
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
  Waiting for burnin script(PID 3354) to stop.
Disable beaconing.

burninErrShow output:

2010/11/02-10:27:27, , 0,, INFO, Silkworm3250, DIAG-MANUAL4 " burnin: Starting run v5.1.0a Tue Nov 2 10:27:22 UTC 2010"
Err# 0140045 0000:101:000:001:0:20:         , OID:0x43000000, iobuf.c, line: 639
2010/11/02-10:35:07, , 0,, INFO, Silkworm3250, DIAG-MANUAL4 " burnin: ABORT stat FAILED 9 cmds in 1 runs v5.1.0a Therm 0 Vib 0 in 0 hr 7 min 35 sec (0:7:35)"
Err# 0140045 0000:101:000:001:0:20:1?       , OID:0x43000000, iobuf.c, line: 639
systemverification: Stopped activity.
systemverification: Outputting Status
State           Status  Run     Cmd     TotCmds PID     Script
COMPLETE_ABORT  FAIL    1       9       9       3354    burnin
systemverification: Terminating - All slots have failed.
systemverification: Stopping activity. This may take a while
Stopping burnin activity.
  No burnin script to stop on . (Could not find PID 3354)
Waiting for all slots to stop burnin activity on slots: 0
Disable beaconing.

burninErrShow output:

2010/11/02-10:27:27, , 0,, INFO, Silkworm3250, DIAG-MANUAL4 " burnin: Starting run v5.1.0a Tue Nov 2 10:27:22 UTC 2010"
Err# 0140045 0000:101:000:001:0:20:         , OID:0x43000000, iobuf.c, line: 639
2010/11/02-10:35:07, , 0,, INFO, Silkworm3250, DIAG-MANUAL4 " burnin: ABORT stat FAILED 9 cmds in 1 runs v5.1.0a Therm 0 Vib 0 in 0 hr 7 min 35 sec (0:7:35)"
Err# 0140045 0000:101:000:001:0:20:1?       , OID:0x43000000, iobuf.c, line: 639
systemverification: Stopped activity.
systemverification: Outputting Status
State           Status  Run     Cmd     TotCmds PID     Script
COMPLETE_ABORT  FAIL    1       9       9       3354    burnin
FCLAB:root>

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: Silkworm 3250

I assume this is a mismatch with the config. I assume the config is looking and waiting of response for other device/member in the fabric.

execute cfgshow command to verify a acive config.

since this is a Switch in the LAB, remove and delete all config, - for details about cfgxxxx command refer he command reference manuals -

Occasional Contributor
Posts: 5
Registered: ‎11-01-2010

Re: Silkworm 3250

I actually removed the old config and created a "LAB" config in which i just put all ports into a single zone.

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: Silkworm 3250

wath is the result ?

have you try to insert another SFP in Port 2 ?

is the error continued ?

is the switch turned as enable ?

have you check if any dump is available ? 

are you able to upgrade the FOS ?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.