Fibre Channel (SAN)

PreKJP (Kernel jumbo Patch) upgrade data collection

by bond007 on ‎12-18-2005 04:00 PM - edited on ‎10-30-2013 01:32 PM by bcm1 (277 Views)

DETAILED DESCRIPTION  

This Script will help you in collecting the server data from hardware/software/storage perspectives and will help you in deciding whether the HBA driver version is at the latest level or needs to be upgraded as per vendor specified version? in particular events like Kernel jumbo Patch upgrades. 

In KJP upgrade activity server patch level (SUN O.E patches/HBA drivers/veritas patches/storage high availabily software patches) will be updated to the latest version by the corresponding vendor. 
This script assumes that you have an storage environment as mentioned below: 1.Server HardwareSmiley FrustratedUN Ultra Sparc
2.Server O.E.Smiley FrustratedUN solaris 5.8 or 5.9
3.JNI146x HBA
4.QLA2300 HBA
5.Veritas file system
6.Veritas volume manager
7.HP XP 1024 disk array
8.EMC Symmetrix DMX disk array
9.EMC Powerpath for path failover 

Note:
1.Ensure there is space in /tmp filesystem where the script is located and data will be collected.
2.Run this script in any unix Shell (Borne/Korne/C Shell) 

 

REQUIREMENTS 

Operating System Sun Solaris 5.8 or 5.9 

Interface Any UNIX shell (Borne/Korne/C Shell) 

Fabric Operating System Brocade secure fabric OS 

Other 1.Server HardwareSmiley FrustratedUN Ultra Sparc 
2.Server O.E.Smiley FrustratedUN solaris 5.8 or 5.9 
3.JNI146x HBA 
4.QLA2300 HBA 
5.Veritas file system 
6.Veritas volume manager 
7.HP XP 1024 disk array 
8.EMC Symmetrix DMX disk array 
9.EMC Powerpath for path failover 

 

NOTES (INCLUDING LIMITATIONS) 

1.Ensure there is space in /tmp filesystem where the scriptis located and data will be collected.
2.Run this script in any unix Shell (Borne/Korne/C Shell) 

 

NOTE: This contribution was migrated by Brocade from the former Brocade Connect community on March 13, 2008, on behalf of the author.

Contributors