Fibre Channel (SAN)

Reply
New Contributor
Posts: 4
Registered: ‎07-14-2017

Invalid_word problems on both sides of an ISL. Low RX Power on one side

Hi,

 

I've got another invalid_word problem now on an ISL:

 

f1sansw01/12  <->  f1swB1E1/0

 

Port 12 shows really low RX Power:

f1sansw01:FID128:boldts> sfpshow 12 | grep Power
RX Power:    -12.4   dBm (57.1 uW)   0.0    uW  6550.0 uW  49.0   uW   1100.0 uW
TX Power:    -2.7    dBm (538.5 uW)  50.0   uW  800.0  uW  100.0  uW   700.0  uW

On Port 0 the values seem to be ok:

f1swB1E1:boldts> sfpshow 0 | grep Power
RX Power:    -2.6    dBm (546.4uW)   0.0    uW  6550.0 uW  49.0   uW   1100.0 uW
TX Power:    -2.4    dBm (573.5 uW)  50.0   uW  800.0  uW  100.0  uW   700.0  uW

But BOTH sides have a large number of errors, especially invalid_word:

 

 

f1sansw01:FID128:boldts> portshow 12
[..]
Interrupts:        0          Link_failure: 0          Frjt:         0
Unknown:           0          Loss_of_sync: 0          Fbsy:         0
Lli:               0          Loss_of_sig:  0
Proc_rqrd:         422717     Protocol_err: 0
Timed_out:         0          Invalid_word: 10039
Rx_flushed:        0          Invalid_crc:  0
Tx_unavail:        0          Delim_err:    0
Free_buffer:       0          Address_err:  0
Overrun:           0          Lr_in:        0
Suspended:         0          Lr_out:       0
Parity_err:        0          Ols_in:       0
2_parity_err:      0          Ols_out:      0
CMI_bus_err:       0

 

f1swB1E1:boldts> portshow 0
[..]
Interrupts: 0 Link_failure: 2 Frjt: 0 Unknown: 0 Loss_of_sync: 0 Fbsy: 0 Lli: 20 Loss_of_sig: 1 Proc_rqrd: 1753127 Protocol_err: 0 Timed_out: 0 Invalid_word: 27069 Rx_flushed: 0 Invalid_crc: 0 Tx_unavail: 0 Delim_err: 0 Free_buffer: 0 Address_err: 0 Overrun: 0 Lr_in: 2 Suspended: 0 Lr_out: 2 Parity_err: 0 Ols_in: 1 2_parity_err: 0 Ols_out: 1 CMI_bus_err: 0

Any ideas what could be the reason that both sides have so many errors even though only one SFP shows bad RX Power values?

 

Thanks in advance

 

regards,
Stephan

 

Highlighted
Brocade Moderator
Posts: 11
Registered: ‎07-01-2010

Re: Invalid_word problems on both sides of an ISL. Low RX Power on one side

[ Edited ]

Hello,

 

please first check if these errors are "historical" values by checking the counter for a while. If this is a real issue, the counter should increase. If so please clean the cable and SFPs on both ends as well as the patch panels between them with a dry cleaning tool. Afterwards do a statsclear, wait for a while and check again with porterrshow. The invalid words should be gone now. If the high damping value still persists, please go on with replacing the SFPs and or the cable, in this case I would start with SFP on f1swB1E1.

 

AG

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers. All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution"

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.