Fibre Channel (SAN)

Reply
New Contributor
Posts: 3
Registered: ‎07-01-2010

FOS upgrade from 6.2.0e thru 6.3.1a

While Hot Code Load Activation of Firmware from FOS upgrade from 6.2.0e thru 6.3.1a Host lost access for a short time and access to Storage was back.

It was expected to have a Non disruptive firmware upgrade, any knows issues??

Super Contributor
Posts: 425
Registered: ‎03-03-2010

Re: FOS upgrade from 6.2.0e thru 6.3.1a

which kind of host is this? It should not have happened.What ever the bugs are in other FOSs, are cleared in V6.3.0.

What is the HBA driver and FW version.Is multipathing SW installed , check if MP is older version

New Contributor
Posts: 3
Registered: ‎07-01-2010

Re: FOS upgrade from 6.2.0e thru 6.3.1a

Thank you for looking into it Hemanth,

Let us assume a scenario where in I have a fabric of 20 san switches that includes 2 numbers of Two GB San switch (3900) having FOS 5.3.1. 

Four GB San switch and a few Eight GB switch (5300).

Now, I decide to upgrade the FOS of the Eight GB san switch from v6.2.0e  thru  v6.3.1a.

 

If during the hot code firmware upgrade the Clusters loose access temporarily and DR Tunnels of the Storage Sub System face slight FLIP..

Can this be because of a 2 GB san switch in the setup ?? or is there any known issue with this context.

My understanding says, Brocade donot recommend to install firmware of different series in the same fabric.

Eg: - FOS 5.3.1 and FOS 6.3.1

However, there aren't any devolopments being made on 2 GB switch..

Thanks in advance..

Frequent Contributor
Posts: 140
Registered: ‎02-27-2008

Re: FOS upgrade from 6.2.0e thru 6.3.1a

Hi manoj-j.kumar-singh

Fabric OS upgrades are non distruptive if your host lost access during the reboot of your switch then there could be an issue with your pathing software or HBA drivers/BIOs on the host which was affected.

What type of host was this that lost access Windows/Linux ? VMware ?

Regards

David

Super Contributor
Posts: 425
Registered: ‎03-03-2010

Re: FOS upgrade from 6.2.0e thru 6.3.1a

In your Fabric even if 3800 SW can be there. The thing is you have to upgarde the FOS seeing the compatibilty matrix. This is a wrong idea that 2 different FOS can not be there. for 3900 the latest FOS is 5.3.2c. Is the host connected to 3900? Pls find attached 6.3.0 release notes it is mentioned about the which SWs can be participated in the Fabric

Pls make it correct , if you find it helpful

New Contributor
Posts: 3
Registered: ‎08-15-2013

Re: FOS upgrade from 6.2.0e thru 6.3.1a

Hi,

I need to get some information with regard to "Brocade 4Gb 20 Port SAN Switch Module for IBM BladeCenter" firmware upgrade.

Current firmware level ..

Kernel:     2.6.14.2

Fabric OS:  v6.2.0e

BootProm:   4.6.6

Kindly confirm which FW level i should go. Plus any dependencies that i have to meet.

IBM site shows following two related FW level's.

2010 - 6.2.2B

2010 - 6.2.2D

Many Thanks.

Valued Contributor
Posts: 931
Registered: ‎12-30-2009

Re: FOS upgrade from 6.2.0e thru 6.3.1a

Hi

First of;

Please create a separate thread in the future as you are unable to mark this on as answered or assign points.

In general I would go for the latest supported release.

Regarding an upgrade, IBM doesn't necessarily use the same upgrade path as Brocade.

Please consult IBM support on how to approach you're upgrade in a way that won't violate your IBM support.

Also there are some documents from the community on how to go about it

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.