Fibre Channel (SAN)

Reply
N/A
Posts: 1
Registered: ‎05-26-2010

DCX Switches with 1000's of Encoding errors

I have a pair of DCX switches - different fabrics both displaying thousands of encoding errors.

I believe this to be a cabline issue - any thoughts - The errors are increasing....

Cheers

Paul

0:  1.5g 623m   0    0    0    0    0    0    1   85    0    5   10    0    0
  1:  3.1g 2.0g   0    0    0    0    0    0   41k  28    0   13   17    0    0
  2:  2.1g 1.6g   0    0    0    0    0    0  121k   7    0    7   11    0    0
  3:  3.3g 1.1g   0    0    0    0    0    0  1.4m 429    0   16   20    0    0
  4:  3.9g 2.5g   0    2    0    0    0    2  516k  43    0   16   18    0    0
  5:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
  6:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
  7:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
  8:  3.5g 3.8g   0    0    0    0    0    0  3.7k  65    0    7   11    0    0
  9:  2.7g 3.9g   0    0    0    0    0    0  444k  22    0   11   15    0    0
10:  3.8g 2.4g   0    0    0    0    0    0  951k  11    0    8   12    0    0
11:  851m 161m   0    0    0    0    0    0  1.4m  46    0   19   24    0    0
12:  435m 152m   0    0    0    0    0    0  632k  46    0   14   19    0    0
13:  2.8g 2.0g   0    0    0    0    0    0  575k   0    0    9   14    0    0
14:  2.3g 2.0g   0    0    0    0    0    0  149k   0    0   11   18    0    0
15:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
16:  1.1g 2.8g   0    0    0    0    0    0  8.3k 489    0   11   15    0    0
17:   27m 2.6g   0    0    0    0    0    0   27k  14    0   13   17    0    0
18:  1.3g 2.2g   0    0    0    0    0    0  525k   0    0   12   16    0    0
19:  4.1g 2.9g   0    0    0    0    0    0  1.0m 407    0   15   19    0    0
20:  518m 1.6g  13    1    0    0    0    1   21k 430    1   12   16    0    0
21:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
22:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
23:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
24:  3.3g 2.5g   0    0    0    0    0    0  938k  29    0    9   13    0    0
25:  2.9g 2.3g   0    0    0    0    0    0  319k   1    0    9   13    0    0
26:   29m 2.9m   0    0    0    0    0    0  123k   0    0    8   12    0    0
27:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
28:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
29:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
30:  2.9m 586k   0    0    0    0    0    0   67k   0    0    8    9    0    0
31:   13m  43k   0    0    0    0    0    0  1.3m   0    0    8    9    0    0
32:  2.2g 4.1g   0    0    0    0    0    0  163k  34    0   12   16    0    0
33:  428m 415m   0    0    0    0    0    0   77k   3    0    7   11    0    0
34:  817m 631m   0    0    0    0    0    0  985k   2    0   10   13    0    0
35:  428m 354m   0    0    0    0    0    0  1.0m 474    0    9    9    0    0
36:  3.6g 2.6g  41    1    0    0    0    1  205k 687    0    7    9    0    0
37:    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0

Occasional Contributor
Posts: 16
Registered: ‎11-22-2009

Re: DCX Switches with 1000's of Encoding errors

As a start,  I suggest disabling any unused ports,  that includes any ports with hardware connected but not in use or loaded with an OS yet.

Then Run a statsclear and see if it helped.

Super Contributor
Posts: 260
Registered: ‎04-09-2008

Re: DCX Switches with 1000's of Encoding errors

Although its always tricky to judge the source of such errors, I would like to give it a try.

Kindly provide a portshow & portstats64show of 2 ports with the highest number of errors. Appreciate if you can attach the o/p in a txt file rather than pasting it here, easier to read.

Super Contributor
Posts: 425
Registered: ‎03-03-2010

Re: DCX Switches with 1000's of Encoding errors

Pls do a portstatsclear of all the ports and see whether the value is increasing through porterrshow and portstatsshow. the error may be due to  even if when you do a portdisable and enable or even if reboot of the DCX or even if reboot of the devices connected to the port.If the value is increasing on the port then erplace teh media i.e. cable/SFP 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.