Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎11-18-2010

Brocade 825 In Citrix XenServer 5.6q

Hi

I was wondering if anybody could give me a pointer in the right direction. We have installed Citrix XenServer 5.6 and now want to add a Brocade 825 card to the server. I am aware that the 825 is not natively supported by XenServer and think I have installed the NoArch Rpm files as per http://community.brocade.com/message/13471#13471.

A quick overview of what I have done to try and get these up and running

1. Extracted brocade_driver_linux_2.0.0.0.tar.gz to a memory stick

2. Mounted the memory stick to /mnt/tmp

3. Tried the installer with "./brocade_install.sh" This returned the error "ERROR: Install failure: no gcc and kernel-xen-devel-2.6.27.42 rpm"

4. Tried "yum install bfa_driver_linux-2.0.0.0-0.noarch.rpm". This wouldn't install due to the driver not being signed.

5. Tried "yum --gpgcheck install bfa_driver_linux-2.0.0.0-0.noarch". This seemed to work. Used the same command on the "bna_driver_linux-2.0.0.0-0.noarch.rpm" and "bfa_util_linux-2.0.0.0-0.noarch.rpm"

Rebooted the server and the XenServer still doesn't see anything on the otherside of the 825.

I am obviously doing something wrong if anyone can help I would be very much appreciative.

Thanks

Pete

New Contributor
Posts: 2
Registered: ‎11-18-2010

Re: Brocade 825 In Citrix XenServer 5.6q

Further Update - it look (when trying to erase and re install) that the install failed.

Marking bfa_driver_linux-2.3.0.0-0.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package bfa_driver_linux.noarch 0:2.3.0.0-0 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package           Arch    Version    Repository                           Size
================================================================================
Installing:
bfa_driver_linux  noarch  2.3.0.0-0  /bfa_driver_linux-2.3.0.0-0.noarch  4.8 M

Transaction Summary
================================================================================
Install      1 Package(s)        
Update       0 Package(s) 

Remove       0 Package(s)       

Total size: 4.8 M
Is this ok : y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Install failure: no gcc and kernel-xen-devel-2.6.27.42 rpm
error: %pre(bfa_driver_linux-2.3.0.0-0.noarch) scriptlet failed, exit status 5
error:   install: %pre scriptlet failed (2), skipping bfa_driver_linux-2.3.0.0-0

Installed:
  bfa_driver_linux.noarch 0:2.3.0.0-0                                         

Complete!

Hopefully this will give someone some pointers.

Super Contributor
Posts: 644
Registered: ‎03-01-2007

Re: Brocade 825 In Citrix XenServer 5.6q

Brocade HBA / Drivers are not Supported for Citrix XenServer.

If you are satisfied with the responses please mark as 'Answered'.
If not, just let me know I can see to get more info.
I would appreciated if you rate the threads.


Thank you.

Occasional Contributor
Posts: 12
Registered: ‎09-02-2009

Re: Brocade 825 In Citrix XenServer 5.6q

The Brocade HBA drivers are in-box with Citrix XenServer 5.6 FP1.

I hope this helps...

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.