Fibre Channel (SAN)

Reply
New Contributor
Posts: 3
Registered: ‎01-18-2011

Bad zone config

Hi all

I have created a number of new zones on a HP/Brocade switch (more details on SAN below) and added all new zones into a new config.  cfgsave was not a problem and both cghshow and zoneshow shows everything correctly.  However when I try to activate the new configuration I get:

Zone transaction aborted - Bad zone config

Old zoning is maintained and all hosts see their storage as expected.

SAN setup:

2 x HP/Brocade 3900

Single ISL

Firmware: 5.3.2c

Any ideas?

Super Contributor
Posts: 635
Registered: ‎04-12-2010

Re: Bad zone config

Do you have any other meesages in the errdump output?

You should remove and delete your new configured zones/alias from your zoning DB and try to activate the original/old one to verify that the configuration had no issue.

If you can activate your cfg then create the zone and alias once more and try to activate.

If the error still occure you will have a problem. Check all your zones and alias definitions if you have any wrong charaters or typos in.

I hope this helps,

Andreas

Contributor
Posts: 26
Registered: ‎08-12-2008

Re: Bad zone config

This message can also present when you have a alias name with no member, a zone with no or only 1 member

Check these first

New Contributor
Posts: 3
Registered: ‎01-18-2011

Re: Bad zone config

Found it, bad case of zoning typo in the script.  Zone corrected and everything back to normal, thanks all

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.