Fibre Channel (SAN)

Reply
New Contributor
Posts: 2
Registered: ‎04-26-2015

Access gateway mode: ports stay in state G

Hi,

I need to connect an internal blade-chassis brocade switch to a Ccsco nexus 5596, and I need to use BAG; I attached 1 uplink and the N-Port has started working as intended. The problem is that server-facing ports stay in G-Port and they never go up as F-Port.

 

pba-cb1-san-b:admin> switchshow
switchName: pba-cb1-san-b
switchType: 87.2
switchState: Online
switchMode: Access Gateway Mode
switchWwn: 10:00:50:eb:1a:23:d9:64
switchBeacon: OFF

Index Port Address Media Speed State Proto
==================================================
0 0 010000 id N8 Online FC N-Port 20:0a:8c:60:4f:40:0a:01 0x8200a0
1 1 010100 id N8 No_Light FC
2 2 010200 id N8 No_Light FC
3 3 010300 id N8 No_Light FC
4 4 010400 -- N8 No_Module FC (No POD License) Disabled
5 5 010500 -- N8 No_Module FC (No POD License) Disabled
6 6 010600 cu 8G No_Sync FC Disabled (Persistent)
7 7 010700 cu 8G No_Sync FC Disabled (Persistent)
8 8 010800 cu 8G No_Sync FC Disabled (Persistent)
9 9 010900 cu 8G No_Sync FC Disabled (Persistent)
10 10 010a00 cu 8G Online FC G-Port
11 11 010b00 cu 8G No_Sync FC Disabled (Persistent)
12 12 010c00 cu 8G Online FC G-Port
13 13 010d00 cu 8G No_Sync FC Disabled (Persistent)
14 14 010e00 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
15 15 010f00 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
16 16 011000 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
17 17 011100 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
18 18 011200 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
19 19 011300 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
20 20 011400 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
21 21 011500 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
22 22 011600 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
23 23 011700 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
24 24 011800 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
25 25 011900 cu 8G No_Sync FC (No POD License) Disabled (Persistent)
pba-cb1-san-b:admin>

 

Also the portlogdump of port 10 didn't help me to understand the issue (taken after a portlogclear and disable/enable):

 

pba-cb1-san-b:admin> portlogdumpport 10
time task event port cmd args
-------------------------------------------------
Sun Apr 26 17:37:32 2015
17:37:32.939 SPEE sn 10 NC 00000008,00000000,00000000
17:37:32.939 INTR pstate 10 OL1
17:37:32.944 INTR pstate 10 AC
17:37:32.950 PORT scn 10 11 00000000,00000000,00000002
17:37:33.084 PORT scn 10 1 00000000,00000000,00000001
17:37:33.084 PORT debug 10 00000001,00654320,00000001,00000000
17:37:33.084 PORT debug 10 00000001,00654320,00000002,00000000
17:37:33.084 PORT scn 10 22 00000000,00000000,00000010
17:37:33.084 PORT debug 10 00000001,00654320,00000003,00000000 * 13
pba-cb1-san-b:admin>

 

 

What else could I check to understand what's happening?

 

Thank you.

Alberto 

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: Access gateway mode: ports stay in state G

Hi,

 

Check that NPIV is enabled on the Cisco port and also check if the ports 10 and 12 in the Brocade AG are mapped to port 0.

 

Aslo try and disable/enable ports 10 and 12.

 

Rgds,

Felipon

Occasional Contributor
Posts: 18
Registered: ‎11-15-2012

Re: Access gateway mode: ports stay in state G

You may also want to check  "portcfgfillword"

New Contributor
Posts: 2
Registered: ‎04-26-2015

Re: Access gateway mode: ports stay in state G

Hi,

 

all the configuration you suggested are ok.

I opened a service request with the blade chassis hardware vendor: he's saying that access gateway is an unsupported configuration?!?!

Honestly I didn't know that the HBAs would be aware of "access gateway mode"...any clues?

 

Regards,

Alberto

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.