Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 11
Registered: ‎01-23-2008

5.3.1 FOS for switch modules 3014 and 4016

I am needing to upgrade the FOS on our Brocade switch modules 3014 and 4016 that are in our Dell Blade Chassis and am having trouble finding the right code. I've searched through the posts here and have found the IBM and HP sites for downloading the code, which I have. The problem is, there are several directories containing the plist file, and I'm not sure which to choose. They are in directories labled SWBD??, be there doesn't appear to be an option for a 3014 or a 4016.

Does anybody know which plist file I should use? Is there another set of code I need for these modules?

Thanks

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: 5.3.1 FOS for switch modules 3014 and 4016

--->>> Does anybody know which plist file I should use? Is there another set of code I need for these modules?

you dont need any explicity plist.

the upgrade file is "/release.plist" for all 4.x 5.x and 6.x FabOS.

TechHelp24
Occasional Contributor
Posts: 11
Registered: ‎01-23-2008

Re: 5.3.1 FOS for switch modules 3014 and 4016

I realize that, but which one?

There is one in each SWBDXX subdirectory, and they are different.

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: 5.3.1 FOS for switch modules 3014 and 4016

you dont need any Folder by the upgarde.

what kind of error do you get by the upgrade ?

have you start the upgrade trough telenet or from webtools ?

TechHelp24
Occasional Contributor
Posts: 11
Registered: ‎01-23-2008

Re: 5.3.1 FOS for switch modules 3014 and 4016

If i just give it the parent directory, it says it can't find a valid plist file.

That's from either telnet or webtools.

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: 5.3.1 FOS for switch modules 3014 and 4016

is the FTP server correct configured and work ?

TechHelp24
Occasional Contributor
Posts: 11
Registered: ‎01-23-2008

Re: 5.3.1 FOS for switch modules 3014 and 4016

yes, I saved off the config before starting messing with code, so I know the ftp works.

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: 5.3.1 FOS for switch modules 3014 and 4016

if the FTP is correct configured and pointed in the correct Home Diorectory ( example Brocade ), you must start the upgrade from Telnet with the File name:

/v5.3.1/release.plist

this must work.

TechHelp24
Occasional Contributor
Posts: 11
Registered: ‎01-23-2008

Re: 5.3.1 FOS for switch modules 3014 and 4016

That's the problem, there is no release.plist in the /v5.3.1/ directory.

They are in /v5.3.1/SWBD12/release.plist

/v5.3.1/SWBD21/release.plist

/v5.3.1/SWBD22/release.plist

and so on. There is like 25 of these subdirectories, and 25 different release.plist files. All the code appears to be in /v5.3.1/, but the release.plist files are in these subdirectories.

External Moderator
Posts: 4,780
Registered: ‎02-23-2004

Re: 5.3.1 FOS for switch modules 3014 and 4016

to make a longer story short, the release.plist file is not in the /5.3.1 folder.

log as telnet, start a capture from Hyperterminal to collect all ouptut and save it.

start the firmwaredownload command, here a example:

TH24BR4100FAB3:admin> firmwaredownload

Server Name or IP Address: 192.168.24.100

User Name: anonymous

File Name: /v5.3.1/release.plist

Network Protocol(1-auto-select, 2-FTP, 3-SCP) : FTP

password:anonymous

TH24BR4100FAB3:admin>

save or copy the exact output error and post here.

TechHelp24

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.