Fibre Channel (SAN)

Reply
Occasional Contributor
Posts: 6
Registered: ‎05-08-2013

200E and QLogic 8GB 20 port IBM BladeCentre switch module

Hi

I have inherited a rack with 4 IBM BC chassis of varying types (E and H). The BladeCentres are all connected to two IBM 2005-16B (Brocade 200e) switches via QLogic BC switch modules. 3 of the 4 BC modules are Qlogic 4GB modules and these guys can connect the SAN switch without issue, the ports show up in the QLogic console as E-ports, which is what I would have expected. The last BC (type H) has an 8GB QLogic Switch module and this one cannot connect at all to the SAN switches, the port shows up as a G port on the QLogic side and offline and nothing I do seems to get it back online. Speeds are set to auto-negotiate on both sides. I guess my initial question is : Is this situation supported? Should I be able to connect an 8GB Qlogic BC switch module to a 4GB SAN switch?  To the best of my knowledge, I have updated the firmware on both the QLogic side and the IBM/Brocade side to the latest firmware, v6.2.2f in the case of the SAN switch. That's the latest that the switch supports apparently.

Thanks in advance for any guidance.         

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: 200E and QLogic 8GB 20 port IBM BladeCentre switch module

Hi,

they should be able to connect at 4G. You could try to manually set the speed to 4G at both ends, and please check the config of the qlogic and brocade ports, there could be a missmatch between them. could you paste the output of the port configuration of both qlogic and brocade devices?

rgds

Occasional Contributor
Posts: 6
Registered: ‎05-08-2013

Re: 200E and QLogic 8GB 20 port IBM BladeCentre switch module

Thanks

Looks like my setup is not supported by default. However, by setting the QLogic switch to transparent mode, I can get the port online and see the expected paths to storage on the hosts. One implication of setting the transparent mode was that some of the hosts on the BC needed to be mapped back to online external ports on the QLogic switch, but once that was done, everything seemed ok. I'm new to this so not familiar with the implications of moving to transparent mode on the switch. If there are any other implications, I'll update this thread.

Valued Contributor
Posts: 761
Registered: ‎06-11-2010

Re: 200E and QLogic 8GB 20 port IBM BladeCentre switch module

Hi,

That is the only way to connect the qlogic switch to a brocade one. Configuring a switch in transparent mode implies that the qlogic switch no longer behaves as a switch (there is no name server, domain ID, etc) but this is not big deal since usually BladeCentre switchs are configured this way.

Kind regards,

Felipe

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.