Fibre Channel (SAN)

Reply
New Contributor
peter.imre
Posts: 2
Registered: ‎12-05-2011

1860 FC mode XCP XenServer kernel driver problems

Hi,

is there any background you know regarding using 1860 FC HBA in XCP - XenServer, all versions use 2.6.32 kernel with some changes, we tested also driver 3.0.3.0 which is default in XCP 1.6 alpha, also latest 3.1.0.0 (we added through DDK), symptoms are same card is detected, just port 0 is uninit state, port 1 is OK, seeing and can access targets, looks like some MSI-X init during boot of kernel is problem, because after unloading and loading module both ports are OK, slot is PCI-E 3.0 intel XEON E5-2600 platform (HP DL380p G8)?

Moderator
Antonio Bongiorno TechHelp24
Posts: 3,820
Registered: ‎02-23-2004

Re: 1860 FC mode XCP XenServer kernel driver problems

Peter,

accordingly the Release Notes and Download, Brocade HBA 1860 is not Supported for XenServer.

From Datasheet, is attached.

 

Driver and HCM supported operating systems

 

Windows Server 2003/2008/2008 R2; RHEL 4/5/6; SLES 9/10/11; Solaris 10 (x86 and SPARC); and VMware ESX 3.5, ESX/ESXi 4.0/4.1/5.0

TechHelp24
New Contributor
peter.imre
Posts: 2
Registered: ‎12-05-2011

Re: 1860 FC mode XCP XenServer kernel driver problems

Hi,

Brocade Adapters Installation and Reference Manual page 49, TABLE 8

Hypervisor support for Brocade adapters

there are XenServer 6.0, oracle VM 3.0 and also standard XEN, so I

supposed there is no problem.

Moderator
Antonio Bongiorno TechHelp24
Posts: 3,820
Registered: ‎02-23-2004

Re: 1860 FC mode XCP XenServer kernel driver problems

I'm another opinion..

Installation and Reference Manuals mantain all HBA, this note you mention on Table 8, is also General Info, and not specified the 1860.

Release Notes Update_1 July 2012 - is attached - don't report support Notes in the 1860 Table Section for XenServer.

I've forward this Thread to Brocade HBA Specialist.

TechHelp24
Moderator
Antonio Bongiorno TechHelp24
Posts: 3,820
Registered: ‎02-23-2004

Re: 1860 FC mode XCP XenServer kernel driver problems

see answer below from Server Connectivity - Systems Engineer

Antonio,

The 1860 requires our 3.0 or later driver, which is not currently inbox with XenServer, and therefore the 1860 does not run with XenServer today.  Once their 6.1 release comes out, then we can add XenServer to our 1860 datasheet because it will be supported.

This is simply an issue of timing.  All OS releases have cutoff dates for when drivers have to be submitted to be included.  We always submit our most current driver at the time of their cutoff date (and their cutoff dates are often about six months before their release date).  In this case, our 2.3 driver was the most current at the time.

Hope this helps.

TechHelp24
N/A
it62
Posts: 1
Registered: ‎12-12-2012

Re: 1860 FC mode XCP XenServer kernel driver problems

Hi

Can you confirm that the 1860 driver will be included in Xenserver 6.1?

I have 2 x dual port 1860 10Gbps NIC in my xenserver 6.02, xen detects a 1010/1020/1007/1741 device series and only one port of each card seems to work and work very slowly. What are my options, can I install a driver?, should I upgrade to Xen 6.1 or wait until xen includes it? I dont see the 1860 in Xen HCL

Thanks

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.