Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 6
Registered: ‎04-07-2014
Accepted Solution

port-channel configuration on Brocade ICX6610 (version 08)

Hello,

 

we're replacing Cisco 2960 switches with ICX6610 (basic L2 image running latest 08). What would be the Brocade equivalent of port-channel setup?

 

Here is a Cisco part:

 

!

interface Port-channel1
switchport access vlan 19
switchport trunk allowed vlan 14,16
switchport mode trunk

!

interface GigabitEthernet0/41
switchport access vlan 19
switchport trunk allowed vlan 14,16
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/42
switchport access vlan 19
switchport trunk allowed vlan 14,16
switchport mode trunk
channel-group 1 mode on

!

 

As far as I understood I have to use LAG on Brocade switches.  Would the config below work?

 

!

lag "LAG1" dynamic id 1

ports ethernet 1/1/41 to 1/1/42
primary-port 1/1/41
deploy

!

vlan 14 name INT1 by port
tagged ethe 1/1/41 to 1/1/42

!

vlan 16 name INT2 by port
tagged ethe 1/1/41 to 1/1/42

!

interface ethernet 1/1/41
dual-mode

!

 

Many thanks in advance!

Frequent Contributor
Posts: 144
Registered: ‎11-07-2013

Re: port-channel configuration on Brocade ICX6610 (version 08)

Hi nov1ce,

   My understanding is that you only need to tag the primary port of the LAG. Also 'dula mode 19' will set the port for untagged on VLAN 19.  So you where very close Smiley Happy 

 

ag "LAG1" dynamic id 1

ports ethernet 1/1/41 to 1/1/42
primary-port 1/1/41
deploy

!

vlan 14 name INT1 by port
tagged ethe 1/1/41 

!

vlan 16 name INT2 by port
tagged ethe 1/1/41 

!

interface ethernet 1/1/41
dual-mode 19

!

 

Thanks

Michael.

 

Thanks
Michael
Occasional Contributor
Posts: 6
Registered: ‎04-07-2014

Re: port-channel configuration on Brocade ICX6610 (version 08)

Thank you Michael!

 

Does it mean that if the primary port (ethernet 1/1/41) is down ethernet 1/1/42 will be tagged 'automatically' (as per LAG configuration)?

 

And the last question: our pair of 6610s is in the stack.  Is it OK for the LAG configuration to assign one (primary) port from the first unit and another port from the secondary unit?

 

Thank you.

Frequent Contributor
Posts: 144
Registered: ‎11-07-2013

Re: port-channel configuration on Brocade ICX6610 (version 08)

Yes the second (and if you have more ports in the LAG) would all be tagged by just tagged the primary port.

 

And Yep that is fine for  stack to have one or more from wach device in the LAG (think of the stack as virtual line card in a chassis).

 

Thanks

Michael.

Thanks
Michael

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.