Ethernet Switches & Routers

Reply
Occasional Visitor
systems13
Posts: 1
Registered: ‎01-30-2013

Voice/Data VLAN Config quirks

Hi everyone,

We're deploying some PoE ICX 6610's in our office environment, and we're migrating our network to a new configuration, all while maintaining the old network until we can officially implement the new network.  I'm running into some issues that may be related that would not otherwise be seen were we not in 'transition'.

I've looked at several configurations regarding voice/data over the same line, I've configured something similar/identical to those configs and there some oddities.

VLAN 2 - Cisco phones from old provider (moving away from) - phone connected to port eth 1/1/9

VLAN 10 - Data

VLAN 141 - Cisco phones from new provider - phone connected to port eth 1/1/11

New provider's router to T1 is connected to eth 1/1/12

DHCP server for Data network is connected to eth 1/1/46

10.1.4.254 is a Cisco switch that currently serves DHCP for the voice VLAN 2 (10.1.4.0/24)

vlan 1 name DEFAULT-VLAN by port

!

vlan 2 name Cisco_Voice by port

tagged ethe 1/1/9

router-interface ve 2

!

vlan 10 name Users by port

tagged ethe 1/1/9 ethe 1/1/11

untagged ethe 1/1/46

router-interface ve 10

!

vlan 141 name Voice by port

tagged ethe 1/1/11

untagged ethe 1/1/12

!

ip route 10.1.4.254 255.255.255.255 10.1.3.254

!

interface ethernet 1/1/1

ip address 10.1.3.231 255.255.252.0

no ip dhcp-client enable

!

interface ethernet 1/1/9

dual-mode 10

inline power

voice-vlan 2

!

interface ethernet 1/1/11

dual-mode 10

inline power

voice-vlan 141

!

interface ethernet 1/1/12

speed-duplex 100-full

!

interface ve 2

ip address 10.1.4.253 255.255.255.0

ip helper-address 1 10.1.4.254

!

interface ve 10

ip address 10.1.10.10 255.255.255.0

ip helper-address 1 10.1.50.156

!

---

With this particular configuration, plugging a phone in with give the phone a 10.1.10.x IP address from the DHCP server on 10.1.50.156.  What *should* be happening is Cisco phone on VLAN 2 should be getting an IP from the 10.1.4.254 switch on the 10.1.4.0/24 subnet, and the phone on VLAN 141 should be getting an IP from the T1.  It appears the dual-mode may be a culprit -- if I set dual-mode to the voice vlan (2, 141) in each respective interface, the VLAN 141 phone gets an IP from the T1 router but also any laptop that sits behind that phone (data passthrough) also gets an IP from VLAN 141 (10.92.x.x)  VLAN 2 phone never gets an IP address when dual-mode is set to 2.  The switch is layer 3 and can ping 10.1.4.254 without problem.

There seems to be an issue with dual-mode and it not working properly with the VLANs associated with those interfaces.  It's giving the wrong DHCP server for the respective voice VLANs.

Any insight into this?  I need a working 'test' environment before we make a move in the near future that has the VLAN 2 phone getting a 10.1.4.x IP and passing the data VLAN 10.1.10.x to a laptop behind it, and similarly with VLAN 141 getting a 10.92.x.x IP and passing data VLAN 10.1.10.x to a laptop behind it.

Thanks!

Occasional Contributor
stephen.boyle
Posts: 8
Registered: ‎04-08-2010

Re: Voice/Data VLAN Config quirks

You should looking to setting up LLDP to manage the VLAN associated to the phone. You'll still need to use dual-mode to specify the data network so when a computer is plugged in, it goes on VLAN 10. LLDP will recognize an IP phone when it is plugged into a port and tell the phone to tag the voice packet on the correct VLAN. The other advantage is the POE power management is much better. You might be running into an issue with the Cisco phone not communicating with the switch correctly to put the port on the voice VLAN. I'm not too familiar with Cisco VOIP, we usually use the DHCP scope option with Shoretel when we don't use LLDP. Hope this helps.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.