Ethernet Switches & Routers

Reply
pkn
Occasional Contributor
Posts: 6
Registered: ‎06-07-2012

Vlan configuration via SNMP

Hi there board,

 

I'm kinda at a loss configuring a switch using SNMP. I am able to remove a vlan from a a port using SNMP with the following command

 

pkn@sysop-2 ~/.snmp/mibs $ snmpset -m +FOUNDRY-SN-ROOT-MIB -v2c -cXXXXXX 10.X.X.X snVLanByPortMemberRowStatus.9.3 i 3
FOUNDRY-SN-SWITCH-GROUP-MIB::snVLanByPortMemberRowStatus.9.3 = INTEGER: delete(3)

 I used to be able to add the vlan again with the following command:

pkn@sysop-2 ~/.snmp/mibs $ snmpset -m +FOUNDRY-SN-ROOT-MIB -v2c -cXXXXXX 10.X.X.X snVLanByPortMemberRowStatus.9.3 i 4
Error in packet.
Reason: undoFailed
Failed object: FOUNDRY-SN-SWITCH-GROUP-MIB::snVLanByPortMemberRowStatus.9.3

 but as you can see this fails now with a reason "undoFailed"

 

The switch in question is the following:

telnet@icx-test(config-vlan-9)#show version
  Copyright (c) 1996-2012 Brocade Communications Systems, Inc. All rights reserved.
    UNIT 1: compiled on Apr 21 2014 at 03:27:28 labeled as ICX64S07400f
		(10011432 bytes) from Primary ICX64S07400f.bin
        SW: Version 07.4.00fT311 
  Boot-Monitor Image size = 776680, Version:07.4.01T310 (kxz07401)
  HW: Stackable ICX6430-24-HPOE
==========================================================================
UNIT 1: SL 1: ICX6430-24p POE 24-port Management Module
 	 Serial  #: BZM2507J0TJ
 	 License: BASE_SOFT_PACKAGE   (LID: dboHKFMlFvl)
 	 P-ENGINE  0: type E7FE, rev 01
==========================================================================
UNIT 1: SL 2: ICX6430-SFP 4port 4G Module
==========================================================================
  500 MHz ARM processor ARMv5TE, 400 MHz bus
32768 KB flash memory
  256 MB DRAM
STACKID 1  system uptime is 4 hours 24 minutes 35 seconds 
The system started at 11:48:18 GMT+01 Wed Jan 07 2015

 The system : started=warm start	 reloaded=by "reload"

 

Any help would be more than welcome.... like I said... kinda clueless at the moment

 

Peter

 

 

pkn
Occasional Contributor
Posts: 6
Registered: ‎06-07-2012

Re: Vlan configuration via SNMP

This issue is specific for the 07.4.00f release. The 07.4.00b release does not have this problem. It reacts as expected.

 

Looks like there is a bug introduced somewhere after the b release.

 

BTW

Selected the 07.4.00f release because it is the newest common firmware for my fws and icx64xx switches

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.