Ethernet Switches & Routers

Reply
Occasional Contributor
daniel6
Posts: 11
Registered: ‎10-16-2012

VE interface won't start (NetIron CES)

Hello,

I'm running (as part of a larger network) two NetIron CES 2024F switches.  They're working very well, except that for some reason interface ve 3 won't come up between the two.  Here's the relevant config from a:

vlan 3

tagged ethe 1/24

router-interface ve 3

ip-proto

  no dynamic

  static ethe 1/24

ipv6-proto

  no dynamic

  static ethe 1/24

!

interface ethernet 1/24

enable

no flow-control

!

interface ve 3

ip ospf area 0.0.0.0

ip address 80.82.127.57/30

ipv6 address 2a00:1ee0:0:21::c3/64

ipv6 enable

ipv6 ospf area 0.0.0.0

ipv6 nd suppress-ra

And the matching config from b:

vlan 3

tagged ethe 1/24

router-interface ve 3

ip-proto

  no dynamic

  static ethe 1/24

ipv6-proto

  no dynamic

  static ethe 1/24

!

interface ethernet 1/24

enable

no flow-control

!

interface ve 3

ip ospf area 0.0.0.0

ip address 80.82.127.58/30

ipv6 address 2a00:1ee0:0:21::c4/64

ipv6 enable

ipv6 ospf area 0.0.0.0

ipv6 nd suppress-ra

Traffic from other VLANs is flowing over the ethernet 1/24 interface, so the cable etc. is working fine.  Here's a show interface ve 3 output on a:

Ve3 is up, line protocol is up

  Hardware is Virtual Ethernet, address is 0024.3836.2a01 (bia 0024.3836.2a01)

  No port name

  Internet address is 80.82.127.57/30, IP MTU 1500 bytes, encapsulation ethernet

And from b:

Ve3 is down, line protocol is down

  Hardware is Virtual Ethernet, address is 748e.f83c.b8c1 (bia 748e.f83c.b8c1)

  No port name

  Internet address is 80.82.127.58/30, IP MTU 1500 bytes, encapsulation ethernet

Running enable on the ve 3 interface on b doesn't seem to make any difference, and it remains down.  How can I get this interface to come up?

Thanks in advance!

Occasional Contributor
bhamacher
Posts: 11
Registered: ‎12-14-2010

Re: VE interface won't start (NetIron CES)

Hi can you throw an unused port on router b into vlan 3 untagged?  I am just curious if this will bring ve 3 online.

Occasional Contributor
daniel6
Posts: 11
Registered: ‎10-16-2012

Re: VE interface won't start (NetIron CES)

Switch a doesn't have this and they're on matching software versions, but I can give it a go - doesn't feel like a permanent solution, and luckily I do have unused ports.

I'll try out of hours this evening (UK) and report back.

Occasional Contributor
bhamacher
Posts: 11
Registered: ‎12-14-2010

Re: VE interface won't start (NetIron CES)

You are correct.  This would not be a permanent solution.  What I am curious to see is if you add the new port untagged will the ve come up.  If the switch does not recognize port 24 as being active in VLAN 3 the VE interface will not come up.  Also just a heads up the untagged port you put in Vlan 3 will need to have a link of some sort just to bring the interface online.

Also would you mind sharing the rest of your configuration?  It may help shed some light on the issue if we can see everything that is going on with both switches.

Occasional Contributor
daniel6
Posts: 11
Registered: ‎10-16-2012

Re: VE interface won't start (NetIron CES)

I'll have to go and connect something up to an SFP in an unused port, then.  Might take me a day or two.

I tried to only include the relevant parts of the config to save pasting lots of waffle, and since these are live configs I didn't want to put too much out there!

Occasional Contributor
bhamacher
Posts: 11
Registered: ‎12-14-2010

Re: VE interface won't start (NetIron CES)

Sure I understand not wanting to post to much.  I guess I am just curious why you can't VE 3 to come online on switch B.  I assume you have other VE's that are working on your Switch B?  Do you have any other VE's that are only tied to port 24 on switch B?  Can you show me what a "sh vlan" looks like?

Occasional Contributor
daniel6
Posts: 11
Registered: ‎10-16-2012

Re: VE interface won't start (NetIron CES)

You're not the only one who's curious

Yep, several over VEs working without issue.  None that are only tied to port 24, some that are to port 24 and one other untagged, so I'm at least a bit hopeful that your "enable another port" plan might work out.  Doesn't really explain why it's working fine on switch a though, since that also only has port 24 in VE 3.

sh vlan output on a:

Configured PORT-VLAN entries: 13

Maximum PORT-VLAN entries: 512

Default PORT-VLAN id: 666

PORT-VLAN 3, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/24

PORT-VLAN 4, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 5, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

Untagged Ports : ethe 1/20

PORT-VLAN 6, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Untagged Ports : ethe 1/1

PORT-VLAN 7, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 8, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 10, Name , Priority Level -, Priority Force 0

Topo HW idx    : 4    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 ethe 1/6 to 1/10 ethe 1/23

PORT-VLAN 13, Name , Priority Level -, Priority Force 0

Topo HW idx    : 0    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : NONE

Tagged Ports   : ethe 1/1 ethe 1/23 to 1/24

PORT-VLAN 18, Name , Priority Level -, Priority Force 0

Topo HW idx    : 3    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/23

PORT-VLAN 200, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 202, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/8 ethe 1/24

PORT-VLAN 666, Name DEFAULT-VLAN, Priority Level -, Priority Force 0

Topo HW idx    : 0    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : NONE

Untagged Ports : ethe 1/11 to 1/19 ethe 1/21 to 1/22

PORT-VLAN 4095, Name CONTROL-VLAN, Priority Level -, Priority Force 0

Topo HW idx    : 1    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/1 ethe 1/20

Untagged Ports : ethe 1/2 to 1/10 ethe 1/23 to 1/24

and b:

Configured PORT-VLAN entries: 12

Maximum PORT-VLAN entries: 512

Default PORT-VLAN id: 666

PORT-VLAN 2, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Untagged Ports : ethe 1/1

PORT-VLAN 3, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/24

PORT-VLAN 4, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 5, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 7, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 8, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 13, Name , Priority Level -, Priority Force 0

Topo HW idx    : 0    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : NONE

Tagged Ports   : ethe 1/1 ethe 1/24

Untagged Ports : ethe 1/21

PORT-VLAN 16, Name , Priority Level -, Priority Force 0

Topo HW idx    : 3    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/23

PORT-VLAN 200, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 202, Name , Priority Level -, Priority Force 0

Topo HW idx    : 2    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/2 to 1/10 ethe 1/24

PORT-VLAN 666, Name DEFAULT-VLAN, Priority Level -, Priority Force 0

Topo HW idx    : 0    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : NONE

Untagged Ports : ethe 1/11 to 1/20 ethe 1/22

PORT-VLAN 4095, Name CONTROL-VLAN, Priority Level -, Priority Force 0

Topo HW idx    : 1    Topo SW idx: 257    Topo next vlan: 0

L2 protocols   : MSTP

Tagged Ports   : ethe 1/1

Untagged Ports : ethe 1/2 to 1/9 ethe 1/23 to 1/24

Occasional Contributor
bhamacher
Posts: 11
Registered: ‎12-14-2010

Re: VE interface won't start (NetIron CES)

Ok can you show me the output of "sh mstp". 

Occasional Contributor
daniel6
Posts: 11
Registered: ‎10-16-2012

Re: VE interface won't start (NetIron CES)

Unused port connected up, so tonight I should be able to try adding that untagged to VLAN 3 and seeing if it helps.

sh mstp from b:

MSTP Instance 0 (CIST) - VLAN Scope: None

----------------------------------------------------------------------------

Bridge           Bridge Bridge Bridge Bridge Root   Root  Root   Root

Identifier       MaxAge Hello  FwdDly Hop    MaxAge Hello FwdDly Hop

hex              sec    sec    sec    cnt    sec    sec   sec    cnt

8000748ef83cb8c0 20     2      15     20     20     2     0      18

Root             ExtPath   RegionalRoot     IntPath   Designated       Root

Bridge           Cost      Bridge           Cost      Bridge           Port

hex                        hex                        hex

8000002438362a00 0         8000002438362a00 20004     f0000025643515ab 1/2

Port  Pri PortPath  P2P Edge Role       State      Designa-  Designated

Num       Cost      Mac Port                       ted cost  bridge

1/1   128 20000     F   T    DESIGNATED FORWARDING 0         8000748ef83cb8c0

1/2   128 20000     F   F    ROOT       DISCARDING 0         f0000025643515ab

1/3   128 20000     F   F    ROOT       FORWARDING 4         f0000025643512f3

1/4   128 20000     F   F    DESIGNATED DISCARDING 0         8000748ef83cb8c0

1/5   128 20000     F   F    DESIGNATED DISCARDING 0         8000748ef83cb8c0

1/6   128 20000     F   F    DESIGNATED FORWARDING 0         8000748ef83cb8c0

1/7   128 20000     F   F    DESIGNATED FORWARDING 0         8000748ef83cb8c0

1/8   128 20000     F   F    DESIGNATED FORWARDING 0         8000748ef83cb8c0

1/9   128 20000     F   F    DESIGNATED FORWARDING 0         8000748ef83cb8c0

1/23  128 20000     F   F    DISABLED   DISABLED   0         0000000000000000

1/24  128 20000     F   F    ALTERNATE  DISCARDING 0         8000002438362a00

MSTP Instance 1 - VLANs: 10 to 12 15 17 19 100 to 199

----------------------------------------------------------------------------

Bridge           Max RegionalRoot     IntPath   Designated       Root  Root

Identifier       Hop Bridge           Cost      Bridge           Port  Hop

hex              cnt hex                        hex                    cnt

e001748ef83cb8c0 20  8001748ef83cb8c0 0         8001748ef83cb8c0 Root  20

MSTP Instance 2 - VLANs: 2 to 9 200 to 299

----------------------------------------------------------------------------

Bridge           Max RegionalRoot     IntPath   Designated       Root  Root

Identifier       Hop Bridge           Cost      Bridge           Port  Hop

hex              cnt hex                        hex                    cnt

8002748ef83cb8c0 20  6002002438362a00 20004     f0020025643512f3 1/3   18

Port  Pri PortPath  P2P Edge Role       State      Designa-  Designated

Num       Cost      Mac Port                       ted cost  bridge

1/1   128 20000     F   T    DESIGNATED FORWARDING 20004     8002748ef83cb8c0

1/2   128 20000     F   F    ALTERNATE  DISCARDING 4         f0020025643515ab

1/3   128 20000     F   F    ROOT       FORWARDING 4         f0020025643512f3

1/4   128 20000     F   F    DESIGNATED DISCARDING 20004     8002748ef83cb8c0

1/5   128 20000     F   F    DESIGNATED DISCARDING 20004     8002748ef83cb8c0

1/6   128 20000     F   F    ALTERNATE  DISCARDING 20000     80025c260aae5cc2

1/7   128 20000     F   F    DESIGNATED FORWARDING 20004     8002748ef83cb8c0

1/8   128 20000     F   F    DESIGNATED FORWARDING 20004     8002748ef83cb8c0

1/9   128 20000     F   F    DESIGNATED FORWARDING 20004     8002748ef83cb8c0

1/23  128 20000     F   F    DISABLED   DISABLED   0         0000000000000000

1/24  128 20000     F   F    ALTERNATE  DISCARDING 20004     8002748ef83cb8c0

MSTP Instance 3 - VLANs: 16

----------------------------------------------------------------------------

Bridge           Max RegionalRoot     IntPath   Designated       Root  Root

Identifier       Hop Bridge           Cost      Bridge           Port  Hop

hex              cnt hex                        hex                    cnt

6003748ef83cb8c0 20  8003748ef83cb8c0 0         8003748ef83cb8c0 Root  20

Port  Pri PortPath  P2P Edge Role       State      Designa-  Designated

Num       Cost      Mac Port                       ted cost  bridge

1/23  128 20000     F   F    DISABLED   DISABLED   0         0000000000000000

MSTP Instance 4 - VLANs: 18

----------------------------------------------------------------------------

Bridge           Max RegionalRoot     IntPath   Designated       Root  Root

Identifier       Hop Bridge           Cost      Bridge           Port  Hop

hex              cnt hex                        hex                    cnt

e004748ef83cb8c0 20  8004748ef83cb8c0 0         8004748ef83cb8c0 Root  20

Without VE 3 active to talk to switch a, it's sending traffic via the switch connected to them both on ethernet 1/8.  This I would like to stop, and I think getting ve3 up so they can talk to each other directly will do that.

Occasional Contributor
bhamacher
Posts: 11
Registered: ‎12-14-2010

Re: VE interface won't start (NetIron CES)

daniel6,

We have found the problem here.  VE 3 will not become active on switch b because if we look at the output below from your "sh mstp" ethernet 1/24 is in a discarding state.  The VE 3 has to have an active forwarding port in order to come online.  You may have to look at shifting your MSTP around to get this port active.  What does your design look like?  I maybe able to assist with this as well.

MSTP Instance 2 - VLANs: 2 to 9 200 to 299

-

1/24  128 20000     F   F    ALTERNATE  DISCARDING 20004     8002748ef83cb8c0

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.