Ethernet Switches & Routers

Reply
Regular Visitor
Posts: 1
Registered: ‎03-14-2017

Trunk from Cisco Catalyst 4948 to Brocade ICX-7450

Hello all,

 

I am a newbie trying to setup a small NW between a Catalyst 4948 adn Brocade ICX-7450.  I have a group of WKSs connect to Cisco 4948 and ICX-7450 and would like them to talk to each across the 2 switches. 

 

#== On Cisco 4948 i created a trunk port as below:

Cisco01# interface TenGigabitEthernet 1/49
Cisco01 (config-if)# description Connect to Brocade ICX 7450
Cisco01 (config-if)# switchport mode trunk
Cisco01 (config-if)# switchport trunk allowed vlan 2

 

#== On Brocade, i created VLAN 2 and configured as below:

Brocade01#show vlan
Brocade01#configure terminal
Brocade01(config)#vlan 2 name Fiber128
Brocade01(config)#vlan 2 by port
Brocade01(config-vlan-2)#tagged ethernet 1/2/1 to 1/2/3  
Brocade01(config-vlan-2)#untagged ethernet 1/1/2 to 1/1/48
Brocade01(config-vlan-2)#end
Brocade01#show vlan
Brocade01(config)#write memory
 
#== Create uplinks for Cisco switches
Brocade01#configure terminal
Brocade01(config)#interface ethernet 1/2/1    
Brocade01(config-if-e1000-1/1/23)#port-name Trunk to Cisco4948

 

The WKSs on both switches can not talk to each other.  Did i do wrong or missing something.  Please help.  TIA

 

Contributor
Posts: 74
Registered: ‎07-20-2015

Re: Trunk from Cisco Catalyst 4948 to Brocade ICX-7450

[ Edited ]

Welcome to the forum.  We will get you squared away quickly.

 

On Brocade, "port-name" is nothing more than a Cisco "description"

An UNTAGGED port is an ACCESS port

A TAGGED port is a TRUNK port

Should you use it... DUAL-MODE is a NATIVE-VLAN

 

This confuses me because you are on interface 1/1/23 naming it "Trunk to Cisco4949"; yet, it is clearly an UNTAGGED port.

 

Brocade01(config)#interface ethernet 1/2/1    
Brocade01(config-if-e1000-1/1/23)#port-name Trunk to Cisco4948

 

 

 

If you are connecting ethernet 1/1/23 to the Cisco switch it will NOT work!  This is the equivalent of a Cisco ACCESS port with a misleading description of "Trunk to Cisco4948"

 

 

 

The only ports on the Brocade that will carry Ethernet frames for VLAN 2 and populate the VLAN field on frames are ethernet 1/2/1 to 1/2/3

 

 

As configured, connect 1/2/1 or 1/2/3 to teh Cisco TenGigabitEthernet 1/49.  Without a doubt, you will also need mathching media types presumably 10GBase-SR or 10GBase-LR.  Sometimes, I find myself having to flip the send/receive if I go through an LIU (fiber patch-pannel).

You can use "show interfaces brief" on the Brocade or "show ip interfaces brief" on the Cisco device  to check the UP/DOWN status of each interface.

 

 

The workstations you mentioned MUST be connected to ACCESS ports on a Cisco OR UNTAGGED ports on the Brocade; since, they send/receive frames without the VLAN field populated (i.e. whatever interface it is connected to the frames become a memeber of that VLAN associated with that switchport).

 

 

***************************

Something like this:

 

Cisco01# interface TenGigabitEthernet 1/49
Cisco01 (config-if)# description Trunk to Brocade ICX 7450
Cisco01 (config-if)# switchport mode trunk
Cisco01 (config-if)# switchport trunk allowed vlan 2

 

Cisco01(config)# interface GigabitEthernet 1/10

Cisco01(config-if)# description CONNECT A WORKSTATION HERE
Cisco01(config-if)# switchport mode access
Cisco01(config-if)# switchport access vlan 2

 

 

CONNECT GigabitEthernet 1/49 to Brocade 1/2/1 (or realistically 1/2/2 or 1/2/3)

 


Brocade01(config)#vlan 2 name Fiber128 by port
Brocade01(config-vlan-2)#tagged ethernet 1/2/1 to 1/2/3  
Brocade01(config-vlan-2)#untagged ethernet 1/1/2 to 1/1/48
Brocade01(config-vlan-2)#end


Brocade01(config)#interface ethernet 1/2/1

Brocade01(config-if-e1000-1/2/1)#port-name This is a Trunk to Cisco4948
Brocade01(config)#interface ethernet 1/1/23
Brocade01(config-if-e1000-1/1/23)#port-name CONNECT A WORKSTATION HERE

 

Contributor
Posts: 74
Registered: ‎07-20-2015

Re: Trunk from Cisco Catalyst 4948 to Brocade ICX-7450

Welcome to the forum.  We will get you squared away quickly.

 

On Brocade, "port-name" is nothing more than a Cisco "description"

An UNTAGGED port is an ACCESS port

A TAGGED port is a TRUNK port

Should you use it... DUAL-MODE is a NATIVE-VLAN

 

This confuses me because you are on interface 1/1/23 naming it "Trunk to Cisco4949"; yet, it is clearly an UNTAGGED port.

 

Brocade01(config)#interface ethernet 1/2/1    
Brocade01(config-if-e1000-1/1/23)#port-name Trunk to Cisco4948

 

 

 

If you are connecting ethernet 1/1/23 to the Cisco switch it will NOT work!  This is the equivalent of a Cisco ACCESS port with a misleading description of "Trunk to Cisco4948"

 

 

 

The only ports on the Brocade that will carry Ethernet frames for VLAN 2 and populate the VLAN field on frames are ethernet 1/2/1 to 1/2/3

 

 

As configured, connect 1/2/1 or 1/2/3 to teh Cisco TenGigabitEthernet 1/49.  Without a doubt, you will also need mathching media types presumably 10GBase-SR or 10GBase-LR.  Sometimes, I find myself having to flip the send/receive if I go through an LIU (fiber patch-pannel).

You can use "show interfaces brief" on the Brocade or "show ip interfaces brief" on the Cisco device  to check the UP/DOWN status of each interface.

 

 

The workstations you mentioned MUST be connected to ACCESS ports on a Cisco OR UNTAGGED ports on the Brocade; since, they send/receive frames without the VLAN field populated (i.e. whatever interface it is connected to the frames become a memeber of that VLAN associated with that switchport).

 

 

***************************

Something like this:

 

Cisco01# interface TenGigabitEthernet 1/49
Cisco01 (config-if)# description Trunk to Brocade ICX 7450
Cisco01 (config-if)# switchport mode trunk
Cisco01 (config-if)# switchport trunk allowed vlan 2

 

Cisco01(config)# interface GigabitEthernet 1/10

Cisco01(config-if)# description CONNECT A WORKSTATION HERE
Cisco01(config-if)# switchport mode access
Cisco01(config-if)# switchport access vlan 2

 

 

CONNECT GigabitEthernet 1/49 to Brocade 1/2/1 (or realistically 1/2/2 or 1/2/3)

 


Brocade01(config)#vlan 2 name Fiber128 by port
Brocade01(config-vlan-2)#tagged ethernet 1/2/1 to 1/2/3  
Brocade01(config-vlan-2)#untagged ethernet 1/1/2 to 1/1/48
Brocade01(config-vlan-2)#end


Brocade01(config)#interface ethernet 1/2/1

Brocade01(config-if-e1000-1/2/1)#port-name This is a Trunk to Cisco4948
Brocade01(config)#interface ethernet 1/1/23
Brocade01(config-if-e1000-1/1/23)#port-name CONNECT A WORKSTATION HERE

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.