Ethernet Switches & Routers

Reply
New Contributor
Posts: 4
Registered: ‎06-19-2013

Solved: icx6610 etherchannel to cisco 2960g

Hi,

I'm evaluating brocade devices and thus new to this side of world. I'm trying to connect a stack of two icx6610 switches to various cisco devices. The layout is like

c2960g ----- icx-stack ------ c4503

I want to have etherchannels (lacp trunks) built in between. But little luck. We're using vlan1 per historic reasons.

I just can't get the vlan 1 to pass from 2960 to icx.

Here's the config I'm using

cisco side (2960)

interface Port-channel1

description uplink

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet0/6

description LACP 802.3ad link

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

!

interface GigabitEthernet0/7

.. like gi0/6...

and the brocade side

vlan 1 name TOIMISTO by port

tagged ethe 1/1/23 to 1/1/24 ethe 1/3/1 ethe 2/1/23 to 2/1/24 ethe 2/3/1

untagged ethe 1/1/10 ethe 2/1/10

router-interface ve 1

interface ethernet 1/1/23

link-aggregate configure key 10000

link-aggregate active

!

interface ethernet 2/1/23

link-aggregate configure key 10000

link-aggregate active

I've tried different lacp modes (active-active, active-passive) and short timeout with no luck.

What is the thing I'm missing?

Edit: Another vlan 100 goes from 2960 to 4503 just fine, so I assume this has something to do with the default vlan in brocade. I've issued command "default-vlan-id 900" to change the default vlan. But that won't help.

Solution: Add "dual-mode 1" to each interface which is supposed to carry the vlan 1

Message was edited by: Harri Waltari

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.