Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 5
Registered: ‎10-14-2015

REG:NETWORK VLAN CONFIGURATION EXAMPL

Dear Team ,

 

         i am plaaning for the nwteork configuration with multiple vlan and link aggreation for one of our customer ,Please give the refernce config are sconfiguration example for the below diagrma

 

vlan network ,vlan 100-172.16.1.1

                           valn 200 - 172.16.2.1

                           valn 300 - 172.16.3.1

                          vlan 400 - 172.16.4.1

and link aggreation

 

 

firewall ip switch interface192.168.1.2 255.255.2555.252

                     lan interface ip  192.168.1.1 255.255.255.252

 

Regards

Mithun

Contributor
Posts: 37
Registered: ‎02-27-2015

Re: REG:NETWORK VLAN CONFIGURATION EXAMPL

You can find the exact config that i'd prepared for you.

At firewall side you have to route packets to 192.168.1.2 for your sub networks which are  172.16.1.0/24, 172.16.2.0/24, 172.16.3.0/24 and 172.16.4.0/24  (I assumed they are 24 bit networks cause you didn't supplied any information about that)

 

Also i suggest you to read more and more. Brocade has a very clear syntax and documentation.

 

 

Targitas-CE#sh run
Current configuration:
!
ver 08.0.30cT213
!
stack unit 1
module 1 icx7450-24p-poe-port-management-module
module 2 icx7400-xgf-4port-40g-module
module 3 icx7400-qsfp-1port-40g-module
module 4 icx7400-qsfp-1port-40g-module
!
!
lag lag2Firewall dynamic id 1
ports ethernet 1/1/1 to 1/1/2
primary-port 1/1/1
deploy
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 100 by port
tagged ethe 1/2/1
router-interface ve 100
!
vlan 200 by port
tagged ethe 1/2/1
router-interface ve 200
!
vlan 300 by port
tagged ethe 1/2/1
router-interface ve 300
!
vlan 400 by port
tagged ethe 1/2/1
router-interface ve 400
!
!
!
!
!
hostname Targitas-CE
ip route 0.0.0.0/0 192.168.1.1
!
!
!
!
!
!
!
!
!
!
interface ethernet 1/1/1
route-only
ip address 192.168.1.2 255.255.255.252
!
interface ve 100
ip address 172.16.1.1 255.255.255.0
!
interface ve 200
ip address 172.16.2.1 255.255.255.0
!
interface ve 300
ip address 172.16.3.1 255.255.255.0
!
interface ve 400
ip address 172.16.4.1 255.255.255.0
!
!
!
!
!
!
!
!
!
end

--
Best Regards
Destan YILANCI
Occasional Contributor
Posts: 5
Registered: ‎10-14-2015

Re: REG:NETWORK VLAN CONFIGURATION EXAMPL

HI

Destan Yilaci,

 

 Thanks for the update ,i have tried to upload my full network diagram but i cant see any option to upload ,please give your mail id i will send my entire diagram, i need some more help in the config side ,thanks onceagin

 

Regards

mithun

Contributor
Posts: 37
Registered: ‎02-27-2015

Re: REG:NETWORK VLAN CONFIGURATION EXAMPL

Hi Mithun,

 

You can upload your topology to a free online web site and give us it's link so we can have a chance to analyze it.

It's better to write here for the common good instead of writing to a private e-mail.

There are a lot of people in here who is ready to help just because you're a Brocade user...

 

Also i wonder, what is the part that did not work for you?

--
Best Regards
Destan YILANCI
Occasional Contributor
Posts: 5
Registered: ‎10-14-2015

Re: REG:NETWORK VLAN CONFIGURATION EXAMPL

Dear Destan YILANCI ,

 

   Thanks for the support ,i have done all my configuration ,execpt lacp because I cant able to do the primary-port 1/1/1 allocation in the firmware Version 07.4.00T313 ,please help me in the issuse ,And please check my below config and please suggestion for any improment are any correction ,please give the  security wise tps

 

  Thnaks for the support

 

ver 07.4.00T313
!
stack unit 1
module 1 icx6450-24p-poe-port-management-module
module 2 icx6450-sfp-plus-4port-40g-module
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 100 name TEAM_100 by port
tagged ethe 1/1/3 to 1/1/22
untagged ethe 1/1/24
router-interface ve 100
!
vlan 200 name TEAM_200 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 200
!
vlan 300 name TEAM_300 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 300
!
vlan 400 name TEAM_400 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 400
!
vlan 500 name TEAM_500 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 500
!
vlan 600 name TEAM_600 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 600
!
vlan 700 name TEAM_700 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 700
!
vlan 800 name TEAM_800 by port
tagged ethe 1/1/3 to 1/1/22
router-interface ve 800
!
!
!
!
!
!
!
!
aaa authentication web-server default local
aaa authentication login default local
jumbo
ip dhcp-server enable
!
ip dhcp-server pool vlan_team100
dhcp-default-router 172.16.1.1
dns-server 8.8.8.8
excluded-address 172.16.1.2 172.16.1.25
lease 1 0 0
network 172.16.1.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team200
dhcp-default-router 172.16.2.1
dns-server 8.8.8.8
excluded-address 172.16.2.1 172.16.2.25
lease 1 0 0
network 172.16.2.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team300
dhcp-default-router 172.16.3.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.3.2 172.16.3.25
lease 1 0 0
network 172.16.3.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan400
dhcp-default-router 172.16.4.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.4.2 172.16.4.25
lease 1 0 0
network 172.16.4.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team500
dhcp-default-router 172.16.5.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.5.2 172.16.5.25
lease 1 0 0
network 172.16.5.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team600
dhcp-default-router 172.16.6.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.6.2 172.16.6.25
lease 1 0 0
network 172.16.6.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team700
dhcp-default-router 172.16.7.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.7.2 172.16.7.25
lease 1 0 0
network 172.16.7.0 255.255.255.128
deploy
!
!
ip dhcp-server pool vlan_team800
dhcp-default-router 172.16.8.1
dns-server 8.8.8.8 4.2.2.2
excluded-address 172.16.8.2 172.16.8.25
lease 1 0 0
network 172.16.8.0 255.255.255.128
deploy
!
ip dns domain-name skava.com
ip dns server-address 8.8.8.8 4.2.2.2
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!

!
!
interface ethernet 1/1/1
route-only
ip address 192.168.1.10 255.255.255.0
no ip dhcp-client enable
link-aggregate configure key 10000
!
interface ethernet 1/1/2
link-aggregate configure key 10000
!
interface ve 100
ip address 172.16.1.1 255.255.255.128
!
interface ve 200
ip address 172.16.2.1 255.255.255.128
!
interface ve 300
ip address 172.16.3.1 255.255.255.128
!
interface ve 400
ip address 172.16.4.1 255.255.255.128
!
interface ve 500
ip address 172.16.5.1 255.255.255.128
!
interface ve 600
ip address 172.16.6.1 255.255.255.128
!
interface ve 700
ip address 172.16.7.1 255.255.255.128
!
interface ve 800
ip address 172.16.8.1 255.255.255.128
!
!
!
!
!
!
!
!
!
end

 Regards,

M.Mithun

Contributor
Posts: 37
Registered: ‎02-27-2015

Re: REG:NETWORK VLAN CONFIGURATION EXAMPL

Hi,

 

Why don't you upgrade to the latest firmware which is 08.030d for now.

--
Best Regards
Destan YILANCI

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.