Ethernet Switches & Routers

Reply
Contributor
Posts: 26
Registered: ‎11-09-2009

Port-Channels Not Working...

Hello,

 

I have 2 ports on both a Cisco Nexus 50x0 and a Brocade VDX 6740 connected and they are passing LACPDU packets just fine as you can see below and the port channel is up.

 

So this is a one-to-one conection using 1 port channel, all is well.

 

!
interface TenGigabitEthernet 1/0/1
description NEXUS5020Connection
no fabric isl enable
no fabric trunk enable
channel-group 20 mode active type standard
lacp timeout long
no shutdown
!
interface TenGigabitEthernet 1/0/2
description NEXUS5020Connection
no fabric isl enable
no fabric trunk enable
channel-group 20 mode active type standard
lacp timeout long
no shutdown


LACP Aggregator: Po 20
Aggregator type: Standard
Ignore-split is enabled
Actor System ID - 0x8000,01-e0-52-00-00-01
Admin Key: 0020 - Oper Key 0020
Receive link count: 2 - Transmit link count: 2
Individual: 0 - Ready: 1
Partner System ID - 0x8000,00-05-9b-1e-12-bc
Partner Oper Key 0019
Member ports on rbridge-id 1:
Link: Te 1/0/1 (0x118008000) sync: 1
Link: Te 1/0/2 (0x118010001) sync: 1 *

 


sw0# sh lacp counter 20
Traffic statistics
Port LACPDUs Marker Pckt err
Sent Recv Sent Recv Sent Recv
Aggregator Po 20
Te 1/0/1 1532709 1529366 0 0 0 0
Te 1/0/2 1532709 1529366 0 0 0 0

Now, I have a NAS device connected to the Brocade VDX and between 2 controllers I split each controller on it's own port-channel as you see below. There are 4 ports total, 2 on PC21 and 2 on PC22.

 

sw0# sh port-channel detail
Static Aggregator: Po 21
Aggregator type: Standard
Member ports on rbridge-id 1
Te 1/0/3 *

Te 1/0/5 *


Static Aggregator: Po 22
Aggregator type: Standard
Member ports on rbridge-id 1
Te 1/0/4 *
Te 1/0/6

 

The settings for the ports on the VDX connected to the NAS are setup with no LACP because I simply want a static connection without LACP. LACP is disabled on the NAS connected to these 4 ports and I don't want LACP on these 4 specific ports.

 

interface TenGigabitEthernet 1/0/3
no fabric isl enable
no fabric trunk enable
channel-group 21 mode on type standard
no shutdown
!
interface TenGigabitEthernet 1/0/4
no fabric isl enable
no fabric trunk enable
channel-group 22 mode on type standard
no shutdown
!
interface TenGigabitEthernet 1/0/5
no fabric isl enable
no fabric trunk enable

channel-group 21 mode on type standard
no shutdown
!
interface TenGigabitEthernet 1/0/6
no fabric isl enable
no fabric trunk enable
channel-group 22 mode on type standard
no shutdown

 

 

So what I summize is that the conneciton between the 5020 and VDX is fine, the port-channels are up and traffic is being passed.

 

I'm curious if someone has some thoughts on why VLAN traffic isn not being passed on the ports connected to the NAS device.  

 


sw0# sh vlan brief
Total Number of VLANs configured : 6
VLAN Name State Ports
(F)-FCoE (u)-Untagged, (t)-Tagged
(R)-RSPAN (c)-Converged
======== =============== ========================== ============================ ====================
1 default ACTIVE Po 20(t) Po 21(t) Po 22( t)
130 VLAN0130 ACTIVE Po 20(t) Po 21(t) Po 22( t)
131 VLAN0131 ACTIVE Po 20(t) Po 21(t) Po 22( t)
132 VLAN0132 ACTIVE Po 20(t) Po 21(t) Po 22( t)
Te 1/0/7(u)
133 VLAN0133 ACTIVE Po 20(t) Po 21(t) Po 22( t)
1002(F) VLAN1002 INACTIVE(no member port)

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.