Ethernet Switches & Routers

Reply
New Contributor
Posts: 4
Registered: ‎03-04-2016

MLX tagged port vs untagged

Simple question.    

Two RHEL devices - one with 802.1Q tagged interface, one with just untagged eth1 interface.  

Both configured for 10.134.104.x/21 addresses space with ve205 as GW.

 

I know both interfaces are up/up.    I can see OSPF hellos on 8/3.

The host on 10/1 responds to traffic - the host on 8/3 does not.

 

config snippet:

 !
vlan 1 name DEFAULT-VLAN
no untagged ethe 8/3
!
vlan 205
untagged ethe 10/1
tagged ethe 8/3
router-interface ve 205
multicast active
!
interface ve 205
ip ospf area 0.0.0.0
ip ospf hello-interval 1
ip ospf md5-authentication key-id 20 key 2 <redacted>
ip address 10.134.111.254/21
!

end

 

 

I suspect I'm not getting tagged traffic on 8/3...

 

--Rich

Occasional Contributor
Posts: 14
Registered: ‎06-19-2013

Re: MLX tagged port vs untagged

Since your switch config is correct, the only logical conclusion is that your Linux interface config is incorrect. Could you post your ifconfig output for the relevant interface?

New Contributor
Posts: 4
Registered: ‎03-04-2016

Re: MLX tagged port vs untagged

cat ifcfg-eth1.205


DEVICE=eth1.205
BOOTPROTO=static
ONBOOT=yes
IPADDR=10.134.109.225
NETMASK=255.255.248.0
NETWORK=10.134.104.0
GATEWAY=10.134.111.254
USERCTL=no
PHYSDEV=eth1
VLAN=yes
NM_CONTROLLED=no

 

ifconfig -a:

 

eth1 Link encap:Ethernet HWaddr 00:60Smiley Very HappyD:44:3B:CE
UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:240 (240.0 b)
Interrupt:55

 

eth1.205 Link encap:Ethernet HWaddr 00:60Smiley Very HappyD:44:3B:CE
inet addr:10.134.109.225 Bcast:10.134.111.255 Mask:255.255.248.0
UP BROADCAST RUNNING MULTICAST MTU:9000 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:184 (184.0 b)

New Contributor
Posts: 4
Registered: ‎03-04-2016

Re: MLX tagged port vs untagged

It gets even stranger....

 

Moved the RHEL host from an 802.1Q tagged configuration to un untagged (just eth1).

Modified the MLXe-32 config as follows:

 

vlan 205
untagged ethe 8/3 ethe 8/5 ethe 10/1 to 10/8
router-interface ve 205
multicast active

 

And it still would not see the gateway...   BUT - just moving the cable from 8/3 to 8/5 - it works!

 

Move it back to 8/3...  it doesn't work!

 

I don't need this on a Friday.

--Rich

 

Occasional Contributor
Posts: 14
Registered: ‎06-19-2013

Re: MLX tagged port vs untagged

Interesting. Does your sh vlan 8/3 differ from 8/5? Any interface-level config directives that are different?

New Contributor
Posts: 4
Registered: ‎03-04-2016

Re: MLX tagged port vs untagged

Nope. 

 

Configured 8/5 as tagged - works.

 

I'm leaning towards a bad SFP in 8/3.     Will replace and test on Monday. 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.