Ethernet Switches & Routers

Reply
Occasional Contributor
adesantiago
Posts: 12
Registered: ‎06-20-2012

MLX - VRRP-E flapping access layer issues

Hi everybody!  I having an issue with 2 MLXE working with MCT and VRRP-E, they are receiving several access switches with 2 10 gb uplinks, every uplink connected to one of the MLXe and so on to create redundancy. I have configured balancing priority track for some vlans, so here one MLX is master for few vlans and back up for others,  The fact here is that I have a weird situation, it is like this:

- MLXa is shutdown, MLXb takes the master role, and everything is working ok.

- MLXa is turned on and then becomes master, everything is working ok.

- MLXb is shutdown, MLXa takes the master role, and everything is working ok.

- MLXb is turned on and takes the backup role for some vlans, and everything goes wrong.....

When I check the vrrp-e status everything is ok, working each one with the master role for their respective vlans, the trouble is that in the access layer some users or hosts in one vlan (as example vlan 8) can not ping their default gateway ( MLX) but others can do. So all the access network becomes a mess, there are users that can get the access but others like host and servers can reach the services.... I tried to clear arp on all the switches, but it has the same behavior....


Any idea?


Regards!!!

Occasional Contributor
sknobloc
Posts: 7
Registered: ‎05-27-2010

Re: MLX - VRRP-E flapping access layer issues

Hi adesantiago,

its hard to provide advice, if the configs and the infrastructure (cabling) are not available.

Make sure you have short-path-forwarding enabled on both VRRP-E endpoints.

Regards,

Stefan


Contributor
serhat.kahraman
Posts: 61
Registered: ‎12-08-2009

Re: MLX - VRRP-E flapping access layer issues

Hi,

There are many things to be considered.

but it seems like  a preemption issue.
I can suggest non-preempt-mode command.

as an example configuration for one vlan:

on MCT peer 1:

interface ve 54

ip address 10.10.54.2 255.255.255.0

ip vrrp-extended vrid 54

  backup priority 150

  non-preempt-mode

  advertise backup

  ip-address 10.10.54.1

  short-path-forwarding

  enable

on MCT peer 2:

interface ve 54

ip address 10.10.54.3 255.255.255.0

ip vrrp-extended vrid 54

  backup priority 110

  non-preempt-mode

  advertise backup

  ip-address 10.10.54.1

  short-path-forwarding

  enable

hope this helps,

Community Manager
Bill.Dominick
Posts: 102
Registered: ‎08-07-2009

Re: MLX - VRRP-E flapping access layer issues

Hi Adesantiago,

As was mentioned earlier it is somewhat difficult to provide advice without knowing more about your configuration/environment.

I've attached an MCT Implementation Guide for your review that may help.

Regards

Occasional Contributor
adesantiago
Posts: 12
Registered: ‎06-20-2012

Re: MLX - VRRP-E flapping access layer issues

Hi everyone! it seems that there is a flush mac address issue, the MLX by itself make a clear arp table, but we are not sure about this behavior, anyway here is one config of the switches:

Current configuration:

!

ver V5.4.0aT163

module 1 br-mlx-24-port-1gc-x

module 2 ni-mlx-8-port-10g-d

module 4 ni-mlx-8-port-10g-d

!

!

lag "Servicios" dynamic id 8

ports ethernet 4/2

primary-port 4/2

deploy

port-name "Servicios" ethernet 4/2

!

lag "Servidores" dynamic id 7

ports ethernet 4/1

primary-port 4/1

deploy

port-name "Servidores" ethernet 4/1

lag "Vblock" dynamic id 6

ports ethernet 2/5 ethernet 2/7 ethernet 4/5 ethernet 4/7

primary-port 2/5

deploy

port-name "Vblock" ethernet 2/5

!

lag "icl-acc" dynamic id 1

ports ethernet 2/8 ethernet 4/8

primary-port 2/8

deploy

port-name "ICL" ethernet 2/8

!

!

!

no spanning-tree

!

!

vlan 1 name

no untagged ethe 2/2 to 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

!

vlan 2 name

tagged ethe 1/23 to 1/24 ethe 2/3 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 2

rstp priority 0

!

vlan 3 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 3

rstp priority 1

!

vlan 4 name

tagged ethe 1/23 to 1/24 ethe 2/1 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 4

rstp priority 1

!

vlan 5 name

tagged ethe 1/23 to 1/24 ethe 2/1 to 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 5

rstp priority 1

!

vlan 6 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/8

router-interface ve 6

rstp priority 0

!

vlan 7 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 7

rstp priority 1

!

vlan 8 name

tagged ethe 1/23 to 1/24 ethe 2/1 to 2/4 ethe 2/8 ethe 4/2 ethe 4/8

router-interface ve 8

rstp priority 0

!

vlan 9 name

tagged ethe 1/23 to 1/24 ethe 2/1 ethe 2/3 ethe 2/8 ethe 4/8

router-interface ve 9

rstp priority 0

!

vlan 10 name

untagged ethe 1/1

tagged ethe 1/23 to 1/24 ethe 2/1 ethe 2/8 ethe 4/2 ethe 4/8

router-interface ve 10

rstp priority 1

!

vlan 11 name

tagged ethe 1/23 to 1/24 ethe 2/2 ethe 2/8 ethe 4/8

router-interface ve 11

rstp priority 1

!

vlan 12 name

tagged ethe 1/23 to 1/24 ethe 2/3 ethe 2/8 ethe 4/8

router-interface ve 12

rstp priority 1

!

vlan 13 name

tagged ethe 1/23 to 1/24 ethe 2/4 ethe 2/8 ethe 4/8

router-interface ve 13

rstp priority 1

!

vlan 14 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/2 ethe 4/8

router-interface ve 14

rstp priority 1

!

vlan 15 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/2 ethe 4/8

router-interface ve 15

rstp priority 1

!

vlan 19 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 19

rstp priority 0

!

vlan 20 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 20

rstp priority 1

!

vlan 30 name

tagged ethe 1/24 ethe 2/8 ethe 4/8

router-interface ve 30

!

vlan 44 name

tagged ethe 1/23 to 1/24 ethe 2/3 ethe 2/8 ethe 4/2 ethe 4/8

router-interface ve 44

rstp priority 1

!

vlan 50 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

rstp priority 1

!

vlan 51 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 51

rstp priority 0

!

vlan 52 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/5 ethe 4/7 to 4/8

rstp priority 1

!

vlan 54 name

tagged ethe 1/23 to 1/24 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 to 4/2 ethe 4/5 ethe 4/7 to 4/8

rstp priority 1

!

vlan 77 name

tagged ethe 1/23 to 1/24 ethe 2/1 to 2/4 ethe 2/8 ethe 4/8

router-interface ve 77

rstp priority 0

!

vlan 100 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/8

router-interface ve 100

rstp priority 0

!

vlan 101 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/8

router-interface ve 101

rstp priority 0

!

vlan 102 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/8

router-interface ve 102

rstp priority 0

!

vlan 110 name

tagged ethe 1/23 to 1/24 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 110

rstp priority 0

!

vlan 111 name

tagged ethe 1/23 to 1/24 ethe 2/2 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 111

rstp priority 1

!

vlan 200 name

tagged ethe 1/23 to 1/24 ethe 2/1 ethe 2/5 ethe 2/7 to 2/8 ethe 4/1 ethe 4/5 ethe 4/7 to 4/8

router-interface ve 200

rstp priority 0

!

vlan 201 name

tagged ethe 1/23 to 1/24 ethe 2/1 ethe 2/8 ethe 4/1 to 4/2 ethe 4/8

router-interface ve 201

rstp priority 0

!

vlan 202 name

tagged ethe 1/23 to 1/24 ethe 2/1 to 2/4 ethe 2/8 ethe 4/8

router-interface ve 202

rstp priority 0

!

vlan 1000 name

rstp priority 1

!

vlan 1001 name

rstp priority 1

!

vlan 1002 name

rstp priority 1

!

vlan 1003 name

rstp priority 1

!

vlan 1004 name

rstp priority 1

!

vlan 1005 name

rstp priority 1

!

vlan 4089 name Keepalive-VLAN

tagged ethe 2/6

rstp priority 1

!

vlan 4090 name Session

tagged ethe 2/8 ethe 4/8

router-interface ve 4090

!

!

system-max vlan 2048

system-max spanning-tree 128

system-max rstp 128

system-max virtual-interface 4095

!

!

no route-only

aaa authentication login default local

!

!

clock summer-time

clock timezone gmt GMT-06

!

!

!

!

ip route 0.0.0.0/0 172.16.

!

!

router vrrp-extended

!

!

!

!

!

!

!

interface management 1

enable

!

interface ethernet 1/1

enable

!

interface ethernet 1/2

enable

!

interface ethernet 1/3

enable

!

interface ethernet 1/4

enable

!

interface ethernet 1/5

enable

!

interface ethernet 1/6

enable

!

interface ethernet 1/7

enable

!

interface ethernet 1/8

enable

!

interface ethernet 1/9

enable

!

interface ethernet 1/10

enable

!

interface ethernet 1/11

enable

!

interface ethernet 1/12

enable

!

interface ethernet 1/13

enable

!

interface ethernet 1/14

enable

!

interface ethernet 1/15

enable

!

interface ethernet 1/16

enable

!

interface ethernet 1/17

enable

!

interface ethernet 1/18

enable

!

interface ethernet 1/19

enable

!

interface ethernet 1/20

enable

!

interface ethernet 1/21

enable

!

interface ethernet 1/22

enable

!

interface ethernet 1/23

enable

!

interface ethernet 1/24

port-name Extreme

enable

!

interface ethernet 2/1

enable

!

interface ethernet 2/2

enable

!

interface ethernet 2/3

enable

!

interface ethernet 2/4

enable

!

interface ethernet 2/5

enable

!

interface ethernet 2/6

port-name KeepAlive

enable

!

interface ethernet 2/8

enable

!

interface ethernet 4/1

enable

!

interface ethernet 4/2

enable

!

interface ve 2

port-name

ip address 172.16.2.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.2.254

  advertise backup

  activate

!

interface ve 3

port-name

ip address 172.16.3.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.3.254

  advertise backup

  activate

!

interface ve 4

port-name

ip address 172.16.4.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.4.254

  advertise backup

  activate

!

interface ve 5

port-name

ip address 172.16.5.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.5.254

  advertise backup

  activate

!

interface ve 6

port-name

ip address 172.16.6.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.6.254

  advertise backup

  activate

!

interface ve 7

port-name

ip address 192.168.7.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 192.168.7.254

  advertise backup

  activate

!

interface ve 8

port-name

ip address 172.16.8.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.8.254

  advertise backup

  activate

!

interface ve 9

port-name

ip address 172.16.9.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.9.254

  advertise backup

  activate

!

interface ve 10

port-name

ip address 172.16.10.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.10.254

  advertise backup

  activate

!

interface ve 11

port-name

ip address 172.16.11.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.11.254

  advertise backup

  activate

!

interface ve 12

port-name

ip address 172.16.12.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.12.254

  advertise backup

  activate

!

interface ve 13

port-name

ip address 172.16.13.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.13.254

  advertise backup

  activate

!

interface ve 14

port-name

ip address 172.16.14.249/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.14.1

  advertise backup

  activate

!

interface ve 15

port-name

ip address 172.16.15.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.15.254

  advertise backup

  activate

!

interface ve 19

port-name

ip address 172.16.19.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.19.254

  advertise backup

  activate

!

interface ve 20

port-name

ip address 172.16.20.2/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.20.254

  advertise backup

  activate

!

interface ve 30

!

interface ve 44

port-name

ip address 192.168.4.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 192.168.4.254

  advertise backup

  activate

!

interface ve 51

port-name

ip address 10.160.0.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.160.0.254

  advertise backup

  activate

!

interface ve 77

port-name

ip address 172.16.7.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.7.254

  advertise backup

  activate

!

interface ve 100

port-name

ip address 10.1.0.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.1.0.254

  advertise backup

  activate

!

interface ve 101

port-name

ip address 10.1.3.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.1.3.254

  advertise backup

  activate

!

interface ve 102

port-name

ip address 10.1.2.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.1.2.254

  advertise backup

  activate

!

interface ve 110

port-name

ip address 192.168.11.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 192.168.11.254

  advertise backup

  activate

!

interface ve 111

port-name

ip address 172.16.1.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.1.254

  advertise backup

  activate

!

interface ve 200

port-name

ip address 192.168.200.252/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 192.168.200.1

  advertise backup

  activate

!

interface ve 201

port-name

ip address 10.20.1.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.20.1.254

  advertise backup

  activate

!

interface ve 202

port-name

ip address 10.20.2.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.20.2.254

  advertise backup

  activate

!

interface ve 4090

ip address 10.1.1.1/24

!

!

!

!

cluster acc 1

rbridge-id 100

session-vlan 4090

keep-alive-vlan 4089

member-vlan 2 to 15

member-vlan 19 to 20

member-vlan 30

member-vlan 44

member-vlan 50 to 52

member-vlan 54

member-vlan 77

member-vlan 100 to 102

member-vlan 110 to 111

member-vlan 200 to 202

icl ICL ethernet 2/8

peer 10.1.1.2 rbridge-id 200 icl ICL

  client-interfaces delay 30

deploy

client

  rbridge-id 2

  client-interface ethernet 2/2

  deploy

client

  rbridge-id 3

  client-interface ethernet 2/3

  deploy

client

  rbridge-id 4

  client-interface ethernet 2/4

  deploy

client

  rbridge-id 1

  client-interface ethernet 2/1

  deploy

client

  rbridge-id 6

  client-interface ethernet 4/1

  deploy

client

  rbridge-id 30

  client-interface ethernet 1/23

  deploy

client

  rbridge-id 5

  client-interface ethernet 2/5

  deploy

client

  rbridge-id 7

  client-interface ethernet 4/2

  deploy

!

!

!

!

!

!

end

Here I'm attaching just the Cluster and VRRP-E of the other MLX:

interface ve 2

port-name

ip address 172.16.2.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 250

  ip-address 172.16.2.254

  advertise backup

  activate

!

interface ve 3

port-name

ip address 172.16.3.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.3.254

  advertise backup

  activate

!

interface ve 4

port-name

ip address 172.16.4.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.4.254

  advertise backup

  activate

!

interface ve 5

port-name

ip address 172.16.5.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.5.254

  advertise backup

  activate

!

interface ve 6

port-name

ip address 172.16.6.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.6.254

  advertise backup

  activate

!

interface ve 7

port-name

ip address 192.168.7.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 192.168.7.254

  advertise backup

  activate

!

interface ve 8

port-name

ip address 172.16.8.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.8.254

  advertise backup

  activate

!

interface ve 9

port-name

ip address 172.16.9.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.9.254

  advertise backup

  activate

!

interface ve 10

port-name

ip address 172.16.10.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.10.254

  advertise backup

  activate

!

interface ve 11

port-name

ip address 172.16.11.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.11.254

  advertise backup

  activate

!

interface ve 12

port-name

ip address 172.16.12.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.12.254

  advertise backup

  activate

!

interface ve 13

port-name

ip address 172.16.13.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.13.254

  advertise backup

  activate

!

interface ve 14

port-name

ip address 172.16.14.250/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.14.1

  advertise backup

  activate

!

interface ve 15

port-name

ip address 172.16.15.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.15.254

  advertise backup

  activate

!

interface ve 19

port-name

ip address 172.16.19.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.19.254

  advertise backup

  activate

!

interface ve 20

port-name

ip address 172.16.20.1/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.20.254

  advertise backup

  activate

!

interface ve 30

!

interface ve 44

port-name

ip address 192.168.4.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 192.168.4.254

  advertise backup

  activate

!

interface ve 51

port-name

ip address 10.160.0.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.160.0.254

  advertise backup

  activate

!

interface ve 77

port-name

ip address 172.16.7.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 172.16.7.254

  advertise backup

  activate

!

interface ve 100

port-name

ip address 10.1.0.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.1.0.254

  advertise backup

  activate

!

interface ve 101

port-name

ip address 10.1.3.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.1.3.254

  advertise backup

  activate

!

interface ve 102

port-name

ip address 10.1.2.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.1.2.254

  advertise backup

  activate

!

interface ve 110

port-name

ip address 192.168.11.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 250

  ip-address 192.168.11.254

  advertise backup

  activate

!

interface ve 111

port-name

ip address 172.16.1.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 172.16.1.254

  advertise backup

  activate

!

interface ve 200

port-name

ip address 192.168.200.253/24

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 192.168.200.1

  advertise backup

  activate

!

interface ve 201

port-name

ip address 10.20.1.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.20.1.254

  advertise backup

  activate

!

interface ve 202

port-name

ip address 10.20.2.253/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 180

  ip-address 10.20.2.254

  advertise backup

  activate

!

interface ve 4090

ip address 10.1.1.2/24

!

!

!

!

cluster acc 1

rbridge-id 200

session-vlan 4090

keep-alive-vlan 4089

member-vlan 2 to 15

member-vlan 19 to 20

member-vlan 30

member-vlan 44

member-vlan 50 to 52

member-vlan 54

member-vlan 77

member-vlan 100 to 102

member-vlan 110 to 111

member-vlan 200 to 202

icl ICL ethernet 2/8

peer 10.1.1.1 rbridge-id 100 icl ICL

  client-interfaces delay 30

deploy

client

  rbridge-id 2

  client-interface ethernet 2/2

  deploy

client

  rbridge-id 3

  client-interface ethernet 2/3

  deploy

client

  rbridge-id 4

  client-interface ethernet 2/4

  deploy

client

  rbridge-id 1

  client-interface ethernet 2/1

  deploy

client

  rbridge-id 7

  client-interface ethernet 4/2

  deploy

client

  rbridge-id 6

  client-interface ethernet 4/1

  deploy

client

  rbridge-id 30

  client-interface ethernet 1/24

  deploy

client

  rbridge-id 5

  client-interface ethernet 2/5

  deploy

!

Occasional Contributor
sknobloc
Posts: 7
Registered: ‎05-27-2010

Re: MLX - VRRP-E flapping access layer issues

Hi adesantiago,

the config looks good so far. However, I strongly advise, as Serhat did before, to use short-path-forwarding.

Related to you config this would translate to (just one ve shown):

interface ve 202

port-name

ip address 10.20.2.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 1

  backup priority 200

  ip-address 10.20.2.254

  advertise backup

  short-path-forwarding

  activate

!

Also ensure that there are no vrrp-e authentication errors.

It might be helpful to also assign each ve interface a different vrid - for example:

interface ve 202

port-name

ip address 10.20.2.252/24

ip helper-address 172.16.20.16

ip vrrp-extended auth-type simple-text-auth ********

ip vrrp-extended vrid 102

  backup priority 200

  ip-address 10.20.2.254

  advertise backup

  short-path-forwarding

  activate

!

Occasional Contributor
adesantiago
Posts: 12
Registered: ‎06-20-2012

Re: MLX - VRRP-E flapping access layer issues

Hey there! finally we found the issue.... there is a vrrp-e bug on 5.4 so we had to downgrade to 5.3, this bug show you that all with the vrrp-e priority and states are working ok! but guess what! either switch takes or see the virtual mac vrrp address, so this make the troubleshooting a mess because everything looks fine.

I hope this help to the community!

Thanks for your help!

New Contributor
dumlutimuralp
Posts: 3
Registered: ‎11-15-2011

Re: MLX - VRRP-E flapping access layer issues

Hi,

Have you received a DefectID from Brocade TAC ?

Cheers

Dumlu

Occasional Contributor
adesantiago
Posts: 12
Registered: ‎06-20-2012

Re: MLX - VRRP-E flapping access layer issues

Hi Dumlu, actually TAC is working on it, I have no received any response yet because this was going to check by development brocade team. This is a fact ... this is a new bug... As soon I have the ID I will post it.

See ya!

Occasional Contributor
lam373
Posts: 7
Registered: ‎02-16-2010

Re: MLX - VRRP-E flapping access layer issues

I've been searching the config for a way to enable short-path-forwarding, do you know the cli syntax?

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.