Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 14
Registered: ‎10-18-2011

Logical SE/SVI Connection between Brocade MLX & Cisco 4503

Hello,

I am installing a connection between Brocade MLX and Cisco 4503 using SE and SVI's. Below is the config for each. Am I missing anything?

*** Cisco 4503 (v15.01) Config ***
VLAN 35
name EOC_Gi1/2
!
interface GigabitEthernet1/1
description *** EOC 4/4 ***
switchport trunk allowed vlan all
spanning-tree link-type point-to-point
switchport nonegotiate
switchport mode trunk
!
interface vlan 35
ip address 10.30.254.2 255.255.255.0
!
interface loopback 0
ip address 10.254.254.101 255.255.255.255
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 0
redistribute connected subnet
redistribute static subnet
**** Brocade MLX (v3.8e) Config ****
vlan 35 name To_HGW
tagged ethe 4/4
router-interface ve 35
!
router ospf
area 0
default-information-originate always
timers throttle spf 1000 1000 1000
auto-cost reference-bandwidth 10000
redistribution connected
redistribution static
!
router pim
!
interface loopback 1
ip address 10.254.100.254/32
ip pim
!
interface ethernet 4/4
port-name To-Greenwood
enable
!
interface ve 35
port-name To-HGW
ip ospf area 0
ip address 10.30.254.1/24
!
end
Occasional Contributor
Posts: 11
Registered: ‎04-11-2010

Re: Logical SE/SVI Connection between Brocade MLX & Cisco 4503

Make sure MLX has all port 4/4 tagged in all necessary vlans which are also present on Cat4500.

You are missing PIM configuration on Cat4500.

What is spanning tree configuration on MLX? Port eth 4/4 should also have "no route-only" command if it is running L3 code.

Match SPF throttle and referece bandwidth numbers between two switches.

Last but not least (this is optional)

Configure and hardcode router ID on both side.

@Cat4500

router ospf 1

router-id xx.xx.xx.xx

@MLX

ip router-id xx.xx.xx.xx

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.