Ethernet Switches & Routers

Reply
N/A
Posts: 1
Registered: ‎03-02-2012

Issue BI-RX-4 OSPF to BGP

Hello dear friend,
I have installed in system firmware V2.7.3aT143. (it is latest ?).
Now i have one problem.
I have 3 eBGP upstream, with full BGP table. I announce our prefix 92.43.24.0/21. All BGP working well.
I have do a vlan for our local infrastructure. On this vl99 (sub 92.43.26.32/29) brocade have setup address 92.43.26.34. In other location i have installed a other router (Cisco) with IP address 92.43.26.38.
On brocade, on interface vl99 i have setup an OSPF, area 0, redistribute default information originate always 60. In BGP i have used redistribute ospf internal, external.
The problem is: When I am on other cisco  router that is connected to the Brocade vl99 and is set to redistribute connected and configured with an IP interface 92.43.25.157/30, sometimes not visible from the Internet.
I do order that it began to work:
clear ip ospf neighbor all
clear ip bgp neighbor all
When i box reload, route 92.43.25.156/30 is not available from the world.
It does not do this only route, but all that is transferred from other routers in OSPF.
Stops working internal routing between OSPF and BGP on Brocade.
But when i do a clear ip ospf neighbour all, and clear ip bgp neighbor all it is start working.
I have other problems that I can not remove.
For example.
How do I set the bgp no synchronization ?
When I connect to ssh using putty and lines of the space bar after a while I get a message : Protocol error - Bad string lenght, and i am disconected form console :-(.
Please can you help me.
HW: BigIron RX Router
BigIron RX-4 CHASSIS (Serial #: SA0306xxxxxxxxxxx ,  Part #: 31550-000B)
RX-BI-SFM1 Switch Fabric Module 1 (Serial #: SA24060xxxxxxxxxxx ,  Part #: 31548-000B)
FE 1: Type fe200,  Version 2
RX-BI-SFM1 Switch Fabric Module 2 (Serial #: SA2406xxxxxxxxxxx ,  Part #: 31548-000B)
FE 1: Type fe200,  Version 2
Thank you
Miroslav Havranec
config :
current configuration:
!
ver V2.7.3aT143
module 1 rx-bi-1g-24-port-copper
!
lag "LAG-XXXXXXX" dynamic
ports e 1/2 to 1/3
primary-port 1/2
deploy
!
no spanning-tree
!
vlan 99 name BACKBONE-AORTA
tagged ethe 1/1
router-interface ve 99
!
vlan 100 name UPLINK-NATIVE
untagged ethe 1/1
!
vlan 710 name XXXXXXXXX
untagged ethe 1/8
tagged ethe 1/1
!
vlan 711 name FREE1
tagged ethe 1/1
!
vlan 712 name FREE2
tagged ethe 1/1
!
vlan 1 name DEFAULT-VLAN
!
!
!
system-max ip-route 524288
!
aaa authentication web-server default local
aaa authentication login default local
clock timezone gmt GMT+01
sntp server 195.113.144.201
logging console
no telnet server
username admin password .....
username supernetwork password .....
no web-management http
hostname r1-a1.XXXXXXXX
!
ip as-path access-list AS-SET-XXXXX seq 5 permit ^$
!
ip prefix-list  PL_XXXXX seq 5 permit 81.25.16.0/21
ip prefix-list  PL_XXXXX seq 10 permit 109.234.40.0/21
!
ip prefix-list  PL_XXXXX seq 10 permit 92.43.24.0/21
!
ip prefix-list  PL_REGULAR_SUBS seq 5 deny 0.0.0.0/0
ip prefix-list  PL_REGULAR_SUBS seq 10 deny 0.0.0.0/8 le 32
ip prefix-list  PL_REGULAR_SUBS seq 15 deny 10.0.0.0/8 le 32
ip prefix-list  PL_REGULAR_SUBS seq 20 deny 127.0.0.0/8 le 32
ip prefix-list  PL_REGULAR_SUBS seq 25 deny 169.254.0.0/16 le 32
ip prefix-list  PL_REGULAR_SUBS seq 30 deny 172.16.0.0/12 le 32
ip prefix-list  PL_REGULAR_SUBS seq 35 deny 192.168.0.0/16 le 32
ip prefix-list  PL_REGULAR_SUBS seq 40 deny 224.0.0.0/4 le 32
ip prefix-list  PL_REGULAR_SUBS seq 45 deny 92.43.24.0/21 le 32
ip prefix-list  PL_REGULAR_SUBS seq 50 deny 0.0.0.0/0 ge 25
ip prefix-list  PL_REGULAR_SUBS seq 55 permit 0.0.0.0/0 le 24
!
ip prefix-list  PL_REGULAR_SUBS_DR seq 5 permit 0.0.0.0/0
ip prefix-list  PL_REGULAR_SUBS_DR seq 10 deny 0.0.0.0/0 ge 25
ip prefix-list  PL_REGULAR_SUBS_DR seq 15 deny 172.16.0.0/12 le 32
ip prefix-list  PL_REGULAR_SUBS_DR seq 20 deny 192.168.0.0/16 le 32
ip prefix-list  PL_REGULAR_SUBS_DR seq 25 deny 224.0.0.0/4 le 32
ip prefix-list  PL_REGULAR_SUBS_DR seq 30 deny 10.0.0.0/8 le 32
ip prefix-list  PL_REGULAR_SUBS_DR seq 35 permit 0.0.0.0/0 le 24
!
ip prefix-list  pfx_gsnet_announce_out seq 5 permit 92.43.24.0/21
ip prefix-list  pfx_gsnet_announce_out seq 10 permit 81.25.16.0/21
ip prefix-list  pfx_gsnet_announce_out seq 15 permit 109.234.40.0/21
ip prefix-list  pfx_gsnet_announce_out seq 20 permit 81.25.24.0/21
ip prefix-list  pfx_gsnet_announce_out seq 25 permit 91.221.148.0/23
ip route 92.43.24.0/21 null0
ip router-id 92.43.26.45
ip dns domain-name xxxxxxxxxxx
ip dns server-address 92.43.26.5 8.8.8.8
router ospf
area 0
default-information-originate always metric 60
permit redistribute 1 all
redistribution connected
!
!
!
!
!
!
interface loopback 1
ip address 92.43.26.45/32
!
interface ethernet 1/1
port-name UPLINK-xxxxxxxx
speed-duplex 1000-full
!
interface ethernet 1/2
ip address xxxxxxxxx
ip address xxxxxxxxx
ip mtu 1500
speed-duplex 1000-full
!
interface ethernet 1/4
port-name SUPERNETWORK-TRANZIT
ip address xxxxxxxxxx
speed-duplex 1000-full
!
interface ethernet 1/5
port-name IGNxxxxxxxxxxx
ip address xxxxxxxx
speed-duplex 1000-full
!
interface ethernet 1/6
port-name GTxxxxxxxxxxx
ip address xxxxxxxxxxxxx
!
interface ethernet 1/7
port-name CBSxxxxxxxxxxx
speed-duplex 1000-full
!
interface ethernet 1/8
port-name Cxxxxxxxxxxx
speed-duplex 1000-full
!
interface ve 99
ip ospf area 0
ip ospf cost 1
ip ospf dead-interval 40
ip ospf hello-interval 10
ip address 92.43.26.34/29
!
!
!
router bgp
local-as 47949
neighbor 88.8xxxxxxx remote-as 39xx
neighbor 88.8xxxxxxx description Sxxxxx
neighbor 88.8xxxxxxx advertisement-interval 30
neighbor 88.8xxxxxxx timers  keep-alive 60  hold-time 180
neighbor 88.8xxxxxxx remote-as 39xxx
neighbor 88.8xxxxxxx description xxxxx
neighbor 88.8xxxxxxx advertisement-interval 30
neighbor 88.8xxxxxxx timers  keep-alive 60  hold-time 180
neighbor 195.39.xxx remote-as 55XX
neighbor 195.39.xxxx description XXX
neighbor 195.39.xxxx shutdown
neighbor 195.39.xxxx advertisement-interval 30
neighbor 195.39.xxxx timers  keep-alive 60  hold-time 180
neighbor 217.31.xxxx remote-as 29xxx
neighbor 217.31.xxxx description xxxx
neighbor 217.31.xxxx shutdown
neighbor 217.31.xxxx advertisement-interval 30
neighbor 217.31.xxxx timers  keep-alive 60  hold-time 180
address-family ipv4 unicast
network 92.43.24.0/21
redistribute ospf match internal
redistribute ospf match external1
redistribute ospf match external2
neighbor xxxxxxxxxxx route-map in rm_supernetwork_transit_in
neighbor xxxxxxxxxxx  route-map out rm_supernetwork_transit_out
neighbor xxxxxxxxxxx  route-map in rm_supernetwork_cr_in
neighbor xxxxxxxxxxx  route-map out rm_supernetwork_cr_out
neighbor xxxxxxxxxxx  route-map in rm_gts_transit_in
neighbor xxxxxxxxxxx  route-map out rm_gts_transit_out
neighbor xxxxxxxxxxx  route-map in rm_ignum_transit_in
neighbor xxxxxxxxxxx  route-map out rm_ignum_transit_out
exit-address-family
address-family ipv4 multicast
exit-address-family
address-family ipv6 unicast
exit-address-family
address-family ipv6 multicast
exit-address-family
!
!
route-map  rm_gts_transit_in permit  5
match ip address prefix-list PL_REGULAR_SUBS_DR
set local-preference 110
!
route-map  rm_gts_transit_out permit  5
match ip address prefix-list pfx_gsnet_announce_out
set as-path prepend  47949
!
route-map  rm_ignum_transit_in permit  5
match ip address prefix-list PL_REGULAR_SUBS_DR
set local-preference 120
!
route-map  rm_ignum_transit_out permit  5
match ip address prefix-list pfx_gsnet_announce_out
set as-path prepend  47949
!
route-map  rm_supernetwork_cr_in permit  5
match ip address prefix-list PL_REGULAR_SUBS_DR
set local-preference 200
..............
Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Issue BI-RX-4 OSPF to BGP

Hi mirek1,

     No V2.7.3aT143 is not the latest code the RX, 2.800b is the latest code - released on the 30th of Nov 2011.

     This version also fixed the SSH bug.

     There is also some OSFP bugs listed in the release notes for 2.800b that may also fix your other issue.  I would suggest to upgrade.

Thanks

Michael.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.