Ethernet Switches & Routers

Reply
Occasional Visitor
Posts: 1
Registered: ‎04-27-2017

I can’t access the internet

I have Brocade ICX 7450 layer 3 Switch connected to cisco Router 811, from local PC in the switch I can’t access the internet, from the PC I can successfully ping the public IP address at the Router ? Any help will be highly appreciated;  the main provision on the Switch and Router are 

 

 

 

Router  configuration

interface FastEthernet0

 no ip address

 

interface FastEthernet1

 no ip address

 

interface FastEthernet2

 no ip address

 

interface FastEthernet3

switchport access vlan 100

router config

 

interface FastEthernet0

 no ip address

 

interface FastEthernet1

 no ip address

 

interface FastEthernet2

 no ip address

 

interface FastEthernet3

switchport access vlan 100

 no ip address

 

interface FastEthernet4

 ip address 51.211.165.75 255.255.255.0

 ip nat outside

 ip virtual-reassembly in

 duplex auto

 speed auto

 

interface Vlan1

 no ip address

 

interface Vlan100

 ip address 192.168.100.2 255.255.255.0

 ip nat inside

 ip virtual-reassembly in

 

ip forward-protocol nd

no ip http server

no ip http secure-server

 

ip nat pool data 51.211.165.75 51.211.165.75 netmask 255.255.255.0

ip nat inside source list 1 pool data overload

ip route 0.0.0.0 0.0.0.0 FastEthernet4

ip route 192.168.10.0 255.255.255.0 Vlan100

ip route 192.168.10.0 255.255.255.0 192.168.100.1

access-list 1 permit any

 

 

Switch configuration

vlan 1 name DEFAULT-VLAN by port

 

vlan 10 name data by port

 tagged ethe 1/1/1 to 1/1/47

 router-interface ve 10

 

vlan 20 name voice by port

 tagged ethe 1/1/1 to 1/1/47

 router-interface ve 20

 

vlan 100 by port

 untagged ethe 1/1/48

 

ip dhcp-server enable

 

ip dhcp-server pool data

 dhcp-default-router 192.168.10.1

 dns-server 84.235.6.55

 lease 1 0 0

 network 192.168.10.0 255.255.255.0

 deploy

 

ip dhcp-server pool voice

 dhcp-default-router 192.168.20.1

 lease 1 0 0

 network 192.168.20.0 255.255.255.0

 deploy

 

ip route 0.0.0.0/0 192.168.100.2

ip route 192.168.10.0/24 ve 10

 

no port bootp

 

interface ethernet 1/1/48

 route-only

 ip address 192.168.100.1 255.255.255.0

 inline power

Brocade Moderator
Posts: 96
Registered: ‎02-04-2015

Re: I can’t access the internet

Hello,

 

Since the PC can ping the Router's public IP, id say routing is working ok. I would check the natting and make sure there is nothing broken there. PAT Configuration looks ok though. Try to run some NAT debugging and check translations

 

Also, Try to use the interface for PAT instead of a pool,given the pool only consists 1 IP, and see if it makes any difference

 

ip nat inside source list 1 interface FastEthernet4 overload

 

There are also few config lines on both the router and switch which aren't required

 

On Router

 

ip route 192.168.10.0 255.255.255.0 Vlan100 (duplicate static route)

 

On Switch

 

ip route 192.168.10.0/24 ve 10 (directly connected network)

 

Hope this helps.

 

Regards,

Os

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider. If this provided you with a solution to this issue, please mark it with the button at the bottom "Accept as solution" .

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.