Ethernet Switches & Routers

Reply
Regular Visitor
Posts: 1
Registered: ‎02-03-2016

High LP CPU utilization on MLXe-16

Hello!

I have MLXe-16 box with 16 modules:

M2 (lower):BR-MLX-MR2-M Management Module                   Active
F1: NI-X-HSF Switch Fabric Module                           Active
F2: NI-X-HSF Switch Fabric Module                           Active
F3: NI-X-HSF Switch Fabric Module                           Active
F4:
S1: BR-MLX-10Gx24-DM 24-port 10GbE Module                   CARD_STATE_UP                24       0024.38a1.c900
S2: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.c930
S3: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.c960
S4: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.c990
S5: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.c9c0
S6: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.c9f0
S7: BR-MLX-10Gx20 20-port 1/10GbE Module                    CARD_STATE_UP                20       0024.38a1.ca20
S8: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.ca50
S9: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.ca80
S10: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cab0
S11: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cae0
S12: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cb10
S13: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cb40
S14: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cb70
S15: NI-MLX-10Gx8-D 8-port 10GbE (D) Module                  CARD_STATE_UP                8        0024.38a1.cba0
S16: BR-MLX-40Gx4-M 4-port 40GbE Module                      CARD_STATE_UP                4        0024.38a1.cbd0

Each port is working in 'no route-only' mode.
Sometimes I experience strange problem with high LP CPU utilization:

telnet@lsr1-gdr.ki#show cpu-utilization lp

11:37:21 GMT+02 Mon Feb 29 2016

SLOT  #:          LP CPU UTILIZATION in  %:
               in 1 second:  in 5 seconds:  in 60 seconds: in 300 seconds:
     1:        1             1              1               2
     2:        1             1              1               1
     3:        1             1              1               1
     4:        1             1              1               1
     5:        1             1              1               1
     6:        91            91             91              91
     7:        8             8              8               23
     8:        91            91             91              91
     9:        1             1              2               14
    10:        1             1              1               1
    11:        24            21             15              27
    12:        4             4              4               4
    13:        1             1              1               1
    14:        1             1              1               1
    15:        1             1              1               1
    16:        1             1              1               1

rconsole on slot 6 and checking tasks shows:

LP-6#show tasks
  Task Name       Pri  State  PC        Stack       Size  CPU Usage(%)  task vid
  --------------  ---  -----  --------  --------  ------  ------------  --------
  con              27  wait   0005e09c  040c5dc8   32768             0  0
  mon              31  wait   0005e09c  041b8f10    8192             0  0
  flash            20  wait   0005e09c  041c7f40    8192             0  0
  dbg              30  wait   0005e09c  041bfec0   16384             0  0
  main              3  wait   0005e09c  245bef40  286720             8  101
  LP-I2C            3  wait   0005e09c  287d5ee0    4096             0  101
  LP-TM-Mon         3  wait   0005e09c  2a846e38    4096             0  101
  LP-Assist         3  wait   0005e09c  2bfa4f00   32768             0  101
  LP-FCopy          3  wait   0005e09c  2bfa9f00   16384             0  101
  LP-VPLS-Offld     3  wait   0005e09c  2bfaef00   16384             0  101
  LP-OF-Offld       3  wait   0005e09c  2bfb3f00   16384             0  101
  LP-TM-Offld       3  wait   0005e09c  2bfb8f00   16384             0  101
  LP-Stats          3  wait   0005e09c  2bfbdf60   16384             0  101
  LP-IPC            3  wait   0005e09c  2bffef00  262144             0  101
  LP-TX-Pak         3  wait   0005e09c  2c007f00   32768             0  101
  LP-RX-Pak         3  wait   0005e09c  2c028f40  131072            90  101
  LP-SYS-Mon        3  wait   0005e09c  2c02df28   16384             0  101
  LP-RTD-Mon        3  wait   0005e09c  2c032f08   16384             0  101
  LP-Console        3  ready  210efa0c  2c053f48  131072             0  101

 

Further googling around LP-RX-Pak gave nothing Smiley Sad
Any suggestions are kindly appreciated!
Thanks in advance!

Occasional Contributor
Posts: 7
Registered: ‎03-30-2011

Re: High LP CPU utilization on MLXe-16

The first thing I always do when one of the linecards is experiencing a high CPU load is looking at the traffic, this via

debug packet capture

via rconsole on the linecard in question. 

 

In general I then find the root-cause of the issue, for example a broadcast loop.

New Contributor
Posts: 3
Registered: ‎12-02-2012

Re: High LP CPU utilization on MLXe-16

Hi,

 

Try to disable icmp redirect in global config

 

no ip icmp redirect

 

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.