Ethernet Switches & Routers

Reply
Occasional Contributor
Posts: 5
Registered: ‎09-12-2013

Fiber Troubleshooting Turboiron24x to FastIron FCX648s

[ Edited ]

I have recently deployed 8 switches in two switch stacks to four network closets. These switches all feed into a Turboiron24x, through 10g uplinks. Three of the four closets are working fine. The fourth closet is possibly furthest away from the Turboiron but it is very hard to say for sure, if it is further it is not by much, the configuration on this switch is identical to the others.

 

I cannot get this switch to hold a 10g connection. I am able to use a 1gb connection with no issues although I have only tested for a few hours at a time. I have connected the 10gb connection and had it work for a few hours with no problems (ping both ways, fdp both ways) then suddenly the activity lights would stop blinking on both ends of the connection. The switches cannot ping each other, but the turboiron still lists the Fastiron as an FDP neighbor, but the fastiron can't see any neighbors. "show interface brief" tells me the connection is up and running at 10g on both ends, to verify that it wasn't just updating slowly, I unplugged the connection "show interface brief" the connection is now down! Plug it back in connection comes right back up under interface list but still no activity light.

 

I tried various gbic's in different pairings (10g-xfp to 10g-xfp, 10g-xfp to 10g-sfp, 10g-sfp to 10g-sfp) The 10g-xfp (fastiron) to 10g-sfp (turboiron) is what I am using on the other switches. I have tried all 6 of the fiber strand pairs available in my closet (matched on the other end) no difference. I have tried all the ports on the Turboiron. I have verified that the fiber works with a 1gb connection on all strand pairs both on the fastiron and a Cisco Catalyst. I took the switch to a closet with a working connection, the switch works as it should. I brought a switch from a working closet to the non-working closet....No luck.

 

I figure the issue must lie somewhere in the fiber, but I wanted to get a second opinion before I gave up.

 

 * update I now have activty lights on the TurboIron end of the Connection but nothing on the FastIron end.

 

 

TurboIron

telnet@DR.MDF.TURBOIRON#sh run
Current configuration:
!
ver 08.0.00aT203
!
global-stp
!
spanning-tree single
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree
!
vlan 4 name Servers by port
tagged ethe 1 to 6
router-interface ve 4
spanning-tree
!
vlan 6 name Printers by port
tagged ethe 1 to 6
router-interface ve 6
spanning-tree
!
vlan 8 name Student_Workstations by port
tagged ethe 1 to 6
router-interface ve 8
spanning-tree
!
vlan 10 name Staff_Workstations by port
tagged ethe 1 to 6
router-interface ve 10
spanning-tree
!
vlan 99 name EMS by port
tagged ethe 1 to 6
router-interface ve 99
spanning-tree
!
vlan 100 name Wireless_A by port
tagged ethe 1 to 6
router-interface ve 100
spanning-tree
!
vlan 200 name Wireless_B by port
tagged ethe 1 to 6
router-interface ve 200
spanning-tree
!
vlan 254 name WAN by port
tagged ethe 28
router-interface ve 254
no spanning-tree
!
spanning-tree single 802-1w
!
boot sys fl sec
enable super-user-password .....
hostname DR.MDF.TURBOIRON
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
cdp run
fdp run

!
!
interface ethernet 1
dual-mode
!
interface ethernet 2
dual-mode
!
interface ethernet 3
dual-mode
!
interface ethernet 4
dual-mode
!
interface ethernet 5
dual-mode
!
interface ethernet 6
dual-mode
!
interface ve 1
ip address 172.28.0.1 255.255.255.0
!
interface ve 4
ip address 172.28.4.1 255.255.255.0
!
interface ve 6
ip address 172.28.6.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 8
ip address 172.28.8.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 10
ip address 172.28.10.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 99
ip address 172.28.99.1 255.255.255.0
!
interface ve 100
ip address 172.28.100.1 255.255.255.0
ip helper-address 2 172.28.0.100
!
interface ve 200
ip address 172.28.200.1 255.255.255.0
ip helper-address 3 172.28.0.200
!
interface ve 254
ip address xxx.xxx.xxx.xxx 255.255.255.252

telnet@DR.MDF.TURBOIRON#

 

FastIron(Working)

telnet@DR.MDF.SW1#sh run
Current configuration:
!
ver 07.0.01bT7f3
!
stack unit 1
module 1 fcx-48-poe-port-management-module
module 2 fcx-cx4-2-port-16g-module
module 3 fcx-xfp-2-port-10g-module
!
global-stp
!
spanning-tree single
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree
!
vlan 4 name Servers by port
tagged ethe 1/3/1
router-interface ve 4
spanning-tree
!
vlan 6 name Printers by port
tagged ethe 1/3/1
router-interface ve 6
spanning-tree
!
vlan 8 name Student_Workstations by port
tagged ethe 1/3/1
router-interface ve 8
spanning-tree
!
vlan 10 name Staff_Workstations by port
tagged ethe 1/3/1
router-interface ve 10
spanning-tree
!
vlan 99 name EMS by port
tagged ethe 1/3/1
router-interface ve 99
spanning-tree
!
vlan 100 name Wireless_A by port
tagged ethe 1/3/1
router-interface ve 100
spanning-tree
!
vlan 200 name Wireless_B by port
tagged ethe 1/3/1
router-interface ve 200
spanning-tree
!
!
spanning-tree single 802-1w
!
boot sys fl sec
enable super-user-password .....
hostname DR.MDF.SW1
ip route 0.0.0.0 0.0.0.0 172.28.0.1
!
cdp run
fdp run
interface ethernet 1/3/1
dual-mode
!
interface ve 1
ip address 172.28.0.10 255.255.255.0
!
interface ve 4
ip address 172.28.4.1 255.255.255.0
!
interface ve 6
ip address 172.28.6.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 8
ip address 172.28.8.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 10
ip address 172.28.10.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 99
ip address 172.28.99.1 255.255.255.0
!
interface ve 100
ip address 172.28.100.1 255.255.255.0
ip helper-address 2 172.28.0.100
!
interface ve 200
ip address 172.28.200.1 255.255.255.0
ip helper-address 3 172.28.0.200
!
end

telnet@DR.MDF.SW1#

 

Fastiron (not working)

DR.IDFD.SW1#sh run
Current configuration:
!
ver 07.0.01bT7f3
!
stack unit 1
module 1 fcx-48-poe-port-management-module
module 2 fcx-cx4-2-port-16g-module
module 3 fcx-xfp-2-port-10g-module
!
global-stp
!
spanning-tree single
!
vlan 1 name DEFAULT-VLAN by port
router-interface ve 1
spanning-tree
!
vlan 4 name Servers by port
tagged ethe 1/3/1
router-interface ve 4
spanning-tree
!
vlan 6 name Printers by port
tagged ethe 1/3/1
router-interface ve 6
spanning-tree
!
vlan 8 name Student_Workstations by port
tagged ethe 1/3/1
router-interface ve 8
spanning-tree
!
vlan 10 name Staff_Workstations by port
tagged ethe 1/3/1
router-interface ve 10
spanning-tree
!
vlan 99 name EMS by port
tagged ethe 1/3/1
router-interface ve 99
spanning-tree
!
vlan 100 name Wireless_A by port
tagged ethe 1/3/1
router-interface ve 100
spanning-tree
!
vlan 200 name Wireless_B by port
tagged ethe 1/3/1
router-interface ve 200
spanning-tree
!
spanning-tree single 802-1w
!
boot sys fl sec
enable super-user-password .....
hostname DR.IDFD.SW1
ip route 0.0.0.0 0.0.0.0 172.28.0.1
!
cdp run
fdp run
interface ethernet 1/3/1
dual-mode
!
interface ve 1
ip address 172.28.0.40 255.255.255.0
!
interface ve 4
ip address 172.28.4.1 255.255.255.0
!
interface ve 6
ip address 172.28.6.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 8
ip address 172.28.8.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 10
ip address 172.28.10.1 255.255.255.0
ip helper-address 1 172.28.4.254
!
interface ve 99
ip address 172.28.99.1 255.255.255.0
!
interface ve 100
ip address 172.28.100.1 255.255.255.0
ip helper-address 2 172.28.0.100
!
interface ve 200
ip address 172.28.200.1 255.255.255.0
ip helper-address 3 172.28.0.200
!
end
DR.IDFD.SW1#

 

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.