Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎07-31-2014

Converting Cisco Switches to ICX6450 switches and configure QoS for Cisco phones - examples?

I have a client that is replacing their Cisco swithces with ICX6430 and ICX6450 switches. They are using Cisco phones have have QoS deployed on the Cisco switches and I need to translate that into the Brocade switches. I am looking for examples or any kind of documentiation that might start me in the right direction. I am very familiar with the Ciso IOS but new to the Brocade technology. 

Contributor
Posts: 27
Registered: ‎07-25-2013

Re: Converting Cisco Switches to ICX6450 switches and configure QoS for Cisco phones - examples?

http://www.brocade.com/downloads/documents/product_manuals/B_FastIron/FastIron_07400a_ConfigGuide.pdf

chapter 51 in configuration guide.

 

if you post the cisco config maybe someone can help translate it to bro code

New Contributor
Posts: 2
Registered: ‎07-31-2014

Re: Converting Cisco Switches to ICX6450 switches and configure QoS for Cisco phones - examples?

Thanks for the reply.

I have been reading that document trying to work through the QoS. One of the things that is mentioned in the document is that it says you can use queue 1 for the priority queue but it does not say how. I see the 3 options of setting the mechanism of strict, WRR and mixed and by setting it either WRR or Mixed you can change the BW by percentage per queue. I don't find clarity in how you can get the traffic to flow from the phone into the port and then be placed in the appropriate input queue and then move to the correct egress queue when leaving the switch. 

 

Here is part of one of the switches config with QoS - It appears that they are using just two vlans - Vlan 1 for data and vlan 12 for voice.

 

 

mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos min-reserve 5 170
mls qos min-reserve 6 85
mls qos min-reserve 7 51
mls qos min-reserve 8 34
mls qos
ip subnet-zero
!
no ip igmp snooping vlan 1
ip igmp snooping vlan 12 immediate-leave

 

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport voice vlan 12
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
spanning-tree portfast

 

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
ip address 10.2.2.252 255.255.255.0
no ip route-cache
!
interface Vlan12
ip address 192.168.12.254 255.255.255.0
no ip route-cache
!
ip default-gateway 10.2.2.254
ip classless
ip http server

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.