Ethernet Switches & Routers

Reply
New Contributor
Posts: 2
Registered: ‎02-16-2011

Cisco etherchannel to MLX LAG

I'm trying to create a two port trunk between an MLX (part of a 2 MLX MCP) and a Cisco 6509

I've got a port-channel setup on the 6509 and a static LAG on the MLX.

both devices see the ports as being connected, but the port-channel on the 6509 shows down, and the static LAG on the MLX shows blocking.

here are the corresponding sections of config:

on Cisco 6509:

interface Port-channel10
description etherchannel to MLX
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

interface GigabitEthernet1/41
description etherchannel to MLX-1
no ip address
switchport
switchport trunk encapsulation dot1q
  switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/42
description etherchannel to MLX-1
no ip address
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 10 mode desirable

on MLX:

lag "6509A" static id 3
ports ethernet 1/1 to 1/2
primary-port 1/1
deploy

vlan 44 name VLAN44
tagged ethe 1/1 to 1/2
loop-detection

interface ethernet 1/1
enable

ultimiately, what I'd like to end up with is this:

2 6509 (Core-A and Core-B) not load-balanced

2 MLX with set as cluster pair

1 link from each MLX as trunk pair to each 6509.

Any idea on how this should be set up?

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Cisco etherchannel to MLX LAG

Hi Stephen,

     Please see Chapter 26 on the MLX config guide called 'bout Multi-Chassis Trunk (MCT)' datedSeptember 20, 2010.

     If you look at the ToR example adn replace the two clients with the 6509's then you should have all the config for the MLX side. Note you need to be running version 5.1 on the MLX's.

Thanks

Michael.

Brocadian
Posts: 2
Registered: ‎04-04-2011

Re: Cisco etherchannel to MLX LAG

Stephen,

     You might want to try changing the channel mode type from  "channel-group 10 mode desirable" to "channel-group 10 mode on"

desirable is for Cisco's proprietary PAgP channeling

on is for static channeling which is what you have set your MLX’s for.

Regards,

Don Quinn

Technical Support Engineer 3

Global Services - Implementation Management

Office:  720-558-3779

http://community.brocade.com/community/forums/psp_program

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Cisco etherchannel to MLX LAG

Did you get this working.  Anything you need?

Thank

Michael.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.