Ethernet Fabric (VDX, CNA)

Reply
Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

VLANs not passing over Port-Channel

I'm having a very strange issue on my Brocade 8470 CNA's in my Bladecenter H. The issue is that I can't get VLAN traffic to traverse the ExTengigabitEthernet ports.

 

The ExTengigabitEthernet ports are split up into two port-channels. Both are currently in swithcport mode access and everything is running on the default VLAN. I would like to move away from using the default VLAN with various VLANs for different traffic types. I assumed putting the port-channel into swithcport mode trunk and adding the required VLANs to the ports would work, but that just breaks everything.

 

The InTengigabitEthernet ports seem to be working fine with VLANs, the vMotion VLAN 200 is running fine. It's just an issue with my ExTengigabitEthernet ports.

Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

Re: VLANs not passing over Port-Channel

Below is my current configuration

---------------------------------------------------

 

 

!
protocol spanning-tree rstp
!
cee-map default
 priority-group-table 1 weight 40 pfc
 priority-group-table 2 weight 60
 priority-table 2 2 2 1 2 2 2 2
!
fcoe-map default
 fcoe-vlan 1002
!
interface Vlan 1
 shutdown
!
interface Vlan 100
 description "Data"
 no shutdown
!
interface Vlan 200
 description "vMotion"
 no shutdown
!
interface Vlan 500
 description "DMZ LAN"
 no shutdown
!
interface InTengigabitEthernet 0/1
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/2
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/3
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/4
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/5
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/6
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/7
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/8
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/9
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/10
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/11
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/12
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/13
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface InTengigabitEthernet 0/14
 fcoeport
 switchport
 switchport mode converged
 switchport converged allowed vlan add 100
 switchport converged allowed vlan add 200
 switchport converged allowed vlan add 500
 no shutdown
!
interface ExTengigabitEthernet 0/15
 channel-group 21 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/16
 channel-group 21 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/17
 channel-group 21 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/18
 channel-group 21 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/19
 channel-group 11 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/20
 channel-group 11 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/21
 channel-group 11 mode active type standard
 no shutdown
 lacp timeout long
!
interface ExTengigabitEthernet 0/22
 channel-group 11 mode active type standard
 no shutdown
 lacp timeout long
!
interface Port-channel 11
 switchport
 switchport mode access
 no shutdown
!
interface Port-channel 21
 switchport
 switchport mode access
 no shutdown
!
protocol lldp
 advertise dcbx-fcoe-app-tlv
 advertise dcbx-fcoe-logical-link-tlv
!
line console 0
 login
line vty 0 31
 login
!
end
Brocade Moderator
Posts: 188
Registered: ‎06-30-2010

Re: VLANs not passing over Port-Channel

Hi,

 

 

This should be straighforward and should be acheived by for instance configuring port channel as follows

 

interface Port-channel 11
switchport
switchport mode trunk
switchport trunk allowed vlan add 100,200,500
no shutdown

 

You must also ensure that the connected host is also configured for 802.1q tagged traffic.

 

Hope this helps

 

Mick


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

Re: VLANs not passing over Port-Channel

Thanks for the response Mick,

 

I tried putting the port channels in trunk mode and have added the allowed vlans previously. That seems to break connectivity to everything until the switch is rebooted.

 

I will try adjusting the configuration, saving it, and rebooting to see if that helps at all. Is there any way to pull any logs off of the Brocades once I adjust this configuration (forgive my ignorance here, i've only been around Cisco and Dell switches)?

 

The two port-channels groups on the Brocade switch connect to my Dell N4032f switch which is also configured for two LAG groups. The Dell side has been configured to switchport mode trunk and the necessary vlans passing. I'm farily certian the Dell side has been configured correctly as I am able to pass vlans from Dell to Dell without issue.

 

I will try the above and report back.

Occasional Contributor
Posts: 16
Registered: ‎09-24-2015

Re: VLANs not passing over Port-Channel

Try to add the following on Dell side port-channel interface

 

switchport nonegotiate

Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

Re: VLANs not passing over Port-Channel

That is not a valid command on the N series switches.

 

switchport nonnegotiate

 

These are the switchport commands available:

 

 

switch(config-if-Po11)#switchport ?

access                   Configure the access mode PVID.
dot1q                    Configure the QinQ Ethertype for the interface.
general                  Configure general mode VLAN membership.
mode                     Configure the VLAN membership mode.
port-security            Enable port MAC locking/security.
private-vlan             Configure private VLAN settings.
trunk                    Configure trunk mode VLAN membership.
voice                    Configure auto-VoIP parameters.

 

And the port-channel config on the Dell:

 

!
interface port-channel 11
switchport mode trunk
exit
!

 

 

 

 

As soon as I change the port-channel from access to trunk on the Brocade side i lose communication to the blades.

 

! 
interface Port-channel 11 
switchport 
switchport mode trunk
switchport trunk allowed vlan all 
no shutdown 
!

 

This is really stumping me as trunking vlans is pretty straightforward. The only other thing I can think of is that it is an issue with the port-channel and trunking (between the Dell and Brocade).

 

Brocade Moderator
Posts: 188
Registered: ‎06-30-2010

Re: VLANs not passing over Port-Channel

Hi,

 

I am not that familiar with Dell N series switches but I would have expected corresponding VLAN mapping on the Dell side switch configuration such as:

 

switchport trunk allowed vlan all

 

I am sure that your problem is the trunking between these devices, I still believe this is likely to be configuration problem although the configuration on the Brocade side looks correct to configure trunk to carry all VLANs with dot1q tag.  Think you just need to get the Dell side to match

 

Regards

Mick

 

 


If my response has solved your query please click the "Accept as Solution" button.

Any and all information provided by me is not reviewed, approved or endorsed by Brocade and is provided solely as a convenience for Brocade customers.

All systems and all networks are different and unique. If you have a service affecting network problem, please open a TAC service request for service through Brocade, or through your OEM equipment provider.
Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

Re: VLANs not passing over Port-Channel

[ Edited ]

I'm fairly certain that if you don't specificy a vlan on the Dell side, it will default to all.

 

I will specifically set it to all and see if there is any change.

 

 

 

Edit:

Changing it to "all" on the dell side just hides that line of code, it is the default trunking configuration.

Occasional Contributor
Posts: 16
Registered: ‎09-24-2015

Re: VLANs not passing over Port-Channel

Might not be the case. This is what I have on my working brocade port-channel configuration. I do not have Dell but vLAG between Brocade and Cisco 6500 

 

!
interface Port-channel 11
switchport
switchport mode trunk
switchport trunk allowed vlan all

no switchport trunk tag native-vlan
no shutdown

!

Occasional Contributor
Posts: 7
Registered: ‎01-10-2017

Re: VLANs not passing over Port-Channel

[ Edited ]

Thanks for the suggestion lama, that doesn't seem to be an option on my Brocade 8470's though. There are no other options after trunk other than allowed.

 

That did get me thinking though, how do the brocades handle the default vlan traffic? In my Brocade config vlan 1 is set to shutdown (it has been this way since these switches were installed, before I got here). Is vlan 1 used as the default vlan for traffic?

 

 

The Dell switch does not tag any traffic that resides on vlan 1, i'm wondering if maybe the Brocade will still tag it as vlan traffic and that is where the miscommunication is?

 

I've also eliminated the port-group on both sides (I just set up one trunk link and shut down the rest) and still faced the same issue. So I don't believe it is an issue with the port-group or the trunking commands.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.