Ethernet Fabric (VDX, CNA)

VDX to FCX Port Channel Configuration Example

by danderson on ‎01-24-2013 05:49 AM (505 Views)

Summary:

This document outlines how to setup the Link Aggregation between the Brocade FCX and the VDX series of switches.  On the FCX equipment you will setup Link Aggregation on the Interfaces.  On the VDX equipment you will setup Port Channels.

VDX Details:

Use the same Port-Channel numbers on both VDX switches to make them participate in a Virtual Link Aggregation (VLAG).  This example is setting up Port-Channel #10 on two VDX switches.  Po10 is being configured to run on interface 1/0/5 and 2/0/5. The Po10 interface has to be setup as speed 1000 also to match the FCX side.

!=======================================================

! VDX Commands Required:

!=======================================================

VDX6710_1# show run int po 10

interface Port-channel 10

vlag ignore-split

speed 1000

description Test

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

VDX6710_1# show run int gi 1/0/5

interface GigabitEthernet 1/0/5

description Brocade_VCX648s_Uplink

channel-group 10 mode active type standard

lacp timeout long

no shutdown

!

VDX6710_2#

VDX6710_2# show run int po 10

interface Port-channel 10

vlag ignore-split

speed 1000

description Test

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

!

VDX6710_2# show run int gi 2/0/5

interface GigabitEthernet 2/0/5

description Brocade_VCX648s_Uplink

channel-group 10 mode active type standard

lacp timeout long

no shutdown

!

VDX6710_2#


FCX Details:

On the FCX switch, you must have two ports configured to be part of the Link-Aggregate (LAG).  If you only configured one port the LAG will go to a “Blocking” state.

You must also hard code the speed to 1000-Full-Master to match the “Speed1000” setting on the VDX side. Do not need to set the link-aggregate “Key” value on the FCX side.

!=======================================================

! FCX Commands Required:

!=======================================================

FXC648S#show run int eth 1/1/1

interface ethernet 1/1/1

speed-duplex 1000-full-master

no spanning-tree

link-aggregate active

!

FXC648S#show run int eth 1/1/2

interface ethernet 1/1/2

speed-duplex 1000-full-master

no spanning-tree

link-aggregate active

!

FXC648S#

brocade_port-channel.jpg

The diamond with the T inside indicates the interface is a VLAN Trunk (or VLAN Tagged interface).