Ethernet Fabric (VDX, CNA)

Reply
New Contributor
Posts: 4
Registered: ‎06-05-2015

Please help with port channel connectivity

For two days and nights now, I've been banging my head trying to find out why I cannot ping between a Cisco 2960x and a pair of VDX 6720s.

The 6720s are connected as VCS fabric. Port 24 on each is connected to the 2960x via LACP.

If I peak in the MAC table for the 2960x port channel interface that is connected to the VDXs, I can see the MACs for the 3 servers on VLAN 1.

Now looking into the MAC table on the VDX port channel facing the 2960x, I find nothing on the native VLAN 1. I cannot ping either way. The hosts connected to the VDXs can talk, as can the rest of the network connected to the Cisco infrastructure.

If I remove the patch cables from a server connected to the VDX and connect it to a switch in the Cisco infrastructure, it communicates fine with the rest of the LAN, but no longer can talk to any other hosts on the VDXs.

 

Here is some of my config

 

VDX-1# sh run int te 1/0/24
interface TenGigabitEthernet 1/0/24
no fabric isl enable
no fabric trunk enable
channel-group 24 mode active type standard
lacp timeout long
no shutdown

VDX-1# sh run in po 24
interface Port-channel 24
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
no shutdown

VDX-1# sh lldp nei
Local Intf   Dead Interval  Remaining Life  Remote Intf                   Chassis ID        Tx           Rx
Te 1/0/17    180            155             0050.5654.6278                vmnic4            16218        7963
Te 1/0/18    180            148             0050.5654.6c84                vmnic4            16219        7963
Te 1/0/19    180            165             0050.5654.6aa0                vmnic4            16223        7964
Te 1/0/20    180            138             0000.0000.0000                vmnic4            16222        7963
Te 1/0/24    120            115             Te1/0/2                       2c3e.cf9c.5980    1826         2171--------------This is our Cisco 2960x


VDX-2# sh run int te 2/0/24
interface TenGigabitEthernet 2/0/24
no fabric isl enable
no fabric trunk enable
channel-group 24 mode active type standard
lacp timeout long
no shutdown

VDX-2# sh run int po 24
interface Port-channel 24
vlag ignore-split
switchport
switchport mode trunk
switchport trunk allowed vlan all
switchport trunk tag native-vlan
no shutdown

sh lldp nei
Local Intf   Dead Interval  Remaining Life  Remote Intf                   Chassis ID        Tx           Rx
Te 2/0/9     180            166             0050.5652.1a80                vmnic0            16201        2998
Te 2/0/10    180            159             0050.5651.d128                vmnic0            16205        2998
Te 2/0/11    180            177             0050.5652.1af8                vmnic0            16201        2998
Te 2/0/17    180            166             0050.5654.6a7c                vmnic6            16201        7965
Te 2/0/18    180            159             0050.5654.6a9c                vmnic6            16201        7965
Te 2/0/19    180            177             0050.5654.8758                vmnic6            16205        7965
Te 2/0/20    180            150             0000.0000.0000                vmnic6            16205        7965
Te 2/0/24    120            103             Te1/0/1                       2c3e.cf9c.5980    16131        16074

VDX-2# sh fab all
VCS Id: 10
Config Mode: Local-Only

Rbridge-id           WWN             IP Address         Name
----------------------------------------------------------------------------
   1       10:00:00:27:F8:F9:C9:E1   192.168.136.232   >"VDX-1"
   2       10:00:00:27:F8:F9:3C:B9   192.168.136.233    "VDX-2"*

The Fabric has 2 Rbridge(s)

VDX-2# sh fab islports
Name:       VDX-2
Type:       95.2
State:      Online
Role:       Fabric Subordinate
VCS Id:     10
Config Mode:Local-Only
Rbridge-id: 2
WWN:        10:00:00:27:f8:f9:3c:b9
FCF MAC:    00:27:f8:f9:3c:b9

Index   Interface      State   Operational State
===================================================================
  0     Te 2/0/1          Up    ISL (Trunk port, Primary is Te 2/0/2 )
  1     Te 2/0/2          Up    ISL 10:00:00:27:f8:f9:c9:e1 "VDX-1" (upstream)(Trunk Primary)
  2     Te 2/0/3          Down
  3     Te 2/0/4          Down
  4     Te 2/0/5          Down
  5     Te 2/0/6          Down
  6     Te 2/0/7          Down
  7     Te 2/0/8          Down
  8     Te 2/0/9          Down
  9     Te 2/0/10         Down
10     Te 2/0/11         Down
11     Te 2/0/12         Down
12     Te 2/0/13         Down
13     Te 2/0/14         Down
14     Te 2/0/15         Down
15     Te 2/0/16         Down
16     Te 2/0/17         Down
17     Te 2/0/18         Down
18     Te 2/0/19         Down
19     Te 2/0/20         Down
20     Te 2/0/21         Down
21     Te 2/0/22         Down
22     Te 2/0/23         Down
23     Te 2/0/24         Down  Down (Admin)

Cisco 2960x port group

2960x-48P#sh run in po 24
Building configuration...

Current configuration : 112 bytes
!
interface Port-channel24
switchport mode trunk
switchport nonegotiate
sh run in te end

2960x-48P#sh run in te 1/0/1
Building configuration...

Current configuration : 129 bytes
!
interface TenGigabitEthernet1/0/1
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 24 mode active
end

2960x-48P#sh run int te 1/0/2
Building configuration...

Current configuration : 129 bytes
!
interface TenGigabitEthernet1/0/2
switchport mode trunk
switchport nonegotiate
no cdp enable
channel-group 24 mode activesh int po 24



2960x-48P#sh int po 24
Port-channel24 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 2c3e.cf9c.59b4 (bia 2c3e.cf9c.59b4)
  MTU 1500 bytes, BW 20000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 10Gb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Te1/0/1 Te1/0/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 9000 bits/sec, 5 packets/sec
  5 minute output rate 17000 bits/sec, 26 packets/sec
     183543 packets input, 72018295 bytes, 0 no buffer
     Received 182011 broadcasts (152457 multicasts)
     0 runts, 2664 giants, 0 throttles
     2664 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 152457 multicast, 0 pause input
     0 input packets with dribble condition detected

 

And here is what is in the MAC table for port-channel 24 on the VDXs:

VDX-2# sh mac-ad int po 24
VlanId   Mac-address       Type     State        Ports
136      001d.7e7c.a3cb    Dynamic  Active       Po 24
136      001e.c9eb.4088    Dynamic  Active       Po 24
136      0027.f8f9.3cb9    Dynamic  Active       Po 24
136      00c0.b7d5.b02f    Dynamic  Active       Po 24
136      2c3e.cf9c.59b4    Dynamic  Active       Po 24-------port channel interface of 2960x
136      3c3a.7368.f444    Dynamic  Active       Po 24-------Avaya switch routing interface
136      a4ba.db44.110b    Dynamic  Active       Po 24-------Dell iDRAC card
186      2c3e.cf9c.59b4    Dynamic  Active       Po 24-------port channel interface of 2960x
200      2c3e.cf9c.59b4    Dynamic  Active       Po 24-------port channel interface of 2960x

Brocadian
Posts: 8
Registered: ‎02-10-2011

Re: Please help with port channel connectivity

[ Edited ]

Hello el_mono_cochino,

 

Reviewing your ouput I've noticed you are in fabric cluster mode. Typically when I've seen initial configuration problems with port-channels it's been a configuration mis-match between the port-channel members or a vLAG formation problem.

 

If you have not solved this problem yet would you mind providing:

 1) The running configurations for the Po & interface on VDX-2.

 2) show port-channel detail from both VDXs.

 3) show interface te 1/0/24

 4) show interface te 2/0/24

 

Thanks,

Michael

PEQ
New Member
Posts: 1
Registered: ‎08-26-2015

Re: Please help with port channel connectivity

Traffic from Cisco on trunk native vlan 1 is untagged.

Remove "switchport trunk tag native-vlan" from Brocade side.

 

 

Contributor
Posts: 47
Registered: ‎08-03-2015

Re: Please help with port channel connectivity

Set speed manually on both the sides.

______________________
Umair Khan Patel
https://in.linkedin.com/in/patelumairkhan
Brocadian
Posts: 1
Registered: ‎10-29-2015

Re: Please help with port channel connectivity

Hi 

 

Try add the command on Cisco side

no spanning-tree etherchannel bpdu-guard

 

Thanks

 

Alex

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.