Ethernet Fabric (VDX, CNA)

Reply
New Contributor
Posts: 3
Registered: ‎03-06-2013

Connect VDX 6720 to Cisco 3750 Stack

Hello,

I have 2 VDX 6720 connected together as a VCS fabric (I apologize in advance, I am a Cisco guy trying to use Brocade).  I am trying to connect it to my Cisco 3750 stack which holds all the gateways for my network to the one VDX switch to start.  I created all the VLAN's i need on both VDX switches (and they show active).  I then attempted to configure one port as a trunk on the VDX side to a trunk port on the 3750 side.  I connected a third device to an access port on the 6720 and attempted a ping the default gateway for the located on the 3750.  No luck.  I have been working with Brocade support to figure this out but they don't have experience with connecting to a Cisco 3750.  Here is some configs I have tried.

6720 Trunk Setup

interface TenGigabitEthernet 1/0/18

fabric isl enable

fabric trunk enable

switchport

switchport mode trunk

switchport trunk allowed vlan add 207

no switchport trunk tag native-vlan

no shutdown

3750 Trunk Setup

interface TenGigabitEthernet5/1/2

description 10 Gigabit Link to B67204N42 Port 1/0/17

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 207

switchport mode trunk

srr-queue bandwidth share 1 25 50 25

srr-queue bandwidth shape 3 0 0 0

priority-queue out

end

Any ideas?  any additional info needed ?

Super Contributor
Posts: 1,087
Registered: ‎12-13-2009

Re: Connect VDX 6720 to Cisco 3750 Stack

remove the two frabic commands from the port.

the fabric trunk and isl are for links berween vdx swithes.

Thanks

Michael

Super Contributor
Posts: 445
Registered: ‎04-08-2009

Re: Connect VDX 6720 to Cisco 3750 Stack

Moved to Ethernet Fabrics...

Regards,

Mike Eversole
Brocade Community Manager
New Contributor
Posts: 3
Registered: ‎03-06-2013

Re: Connect VDX 6720 to Cisco 3750 Stack

I changed them to no and tried again.  Here is what I got now.

3750

interface TenGigabitEthernet5/1/2

description 10 Gigabit Link to B67204N42 Port 1/0/17

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 203,207,998,999

switchport mode trunk

srr-queue bandwidth share 1 25 50 25

srr-queue bandwidth shape 3 0 0 0

priority-queue out

end

6720 Trunk

interface TenGigabitEthernet 1/0/18

no fabric isl enable

no fabric trunk enable

switchport

switchport mode trunk

switchport trunk allowed vlan add 203,207,998-999

no switchport trunk tag native-vlan

no shutdown

6720 Client

interface TenGigabitEthernet 1/0/1

description spinimble01 Controller A iSCSI TG1

no fabric isl enable

no fabric trunk enable

switchport

switchport mode access

switchport access vlan 207

no shutdown

I still try to ping the gateway from the client on the 6720 and still no luck. 

New Contributor
Posts: 3
Registered: ‎03-06-2013

Re: Connect VDX 6720 to Cisco 3750 Stack

It looks like this answer helped but we found the root cause to be bad SFP connector.  However, using the info you gave me I was also able to dig into the community and find the other items that helped me get them setup I needed.  Plus I got a better understanding of NOS for VDX.

Used this to understand vLag compared to EtherChannel in Cisco

http://community.brocade.com/thread/6787?start=0&tstart=0

Used this to see a good and bad trunk configuration in a Cisco 3560 

http://community.brocade.com/thread/7326?start=0&tstart=0

Used the MLX settings on page 12 based on another article I read that said MLX is similar to non-brocade devices.

http://www.brocade.com/downloads/documents/deployment_guides/brocade-vdx-deployment-guide-addendum.pdf


I could be all wrong on the items above but it worked for me so maybe it will work for others.  Anyway, I marked it answered.


Thanks.

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.