Ethernet Fabric (VDX, CNA)

Reply
Occasional Contributor
Posts: 7
Registered: ‎03-14-2010

BR-8000 FCOE+QLogic QLE8142 CNA Card Question

Dear Support:

                   I want to config Brocade BR-8000 FCOE switch, I use Qlogic qle8142 cna card connected to BR-8000's tg0/4 and tg 0/5 port,but FCOE fuction not work,Can you help me slove this problem, Thank.

Question 1: Refer to "Brocade8000_GA-SG-161-01.pdf" , I config follow Br-8000 sample code. When I try to config command "priority-table 2 2 2 1 1 2 2 2" in cee-map,but has error message. How can I do?

Question 2:show ip int brief,vlan 1,10,20,100's status is "administratively down",How to bring up? and How to config interface ip?

************************Cee-map Error************************

fcoe8000(conf-ceemap)#priority-table 2 2 2 1 1 2 2 2
% Error:
  * Only a single CoS can be mapped to a PGID with PFC enabled.
  * Strict Priority PGID with PFC enabled must have numerically increasing
    CoS assigned to higher scheduler priorities.
  * DWRR PGID must have numerically lower CoS assigned than any Strict
    Priority PGID with PFC enabled.

************************show ip int brief**********************************

TenGigabitEthernet 0/0    unassigned      up                     down
TenGigabitEthernet 0/1    unassigned      up                     down
TenGigabitEthernet 0/2    unassigned      up                     down
TenGigabitEthernet 0/3    unassigned      up                     down
TenGigabitEthernet 0/4    unassigned      up                     up

TenGigabitEthernet 0/5    unassigned      up                     up
Vlan 1                    unassigned      administratively down  down
Vlan 10                   unassigned      administratively down  down
Vlan 20                   unassigned      administratively down  down
Vlan 100                  unassigned      administratively down  down

*************************BR-8000 Config***********************
fcoe8000#sh run
!
protocol spanning-tree rstp
  bridge-priority 61440
!
vlan classifier rule 1 proto fip encap ethv2
vlan classifier rule 2 proto fcoe encap ethv2
vlan classifier group 1 add rule 1
vlan classifier group 1 add rule 2
!
cee-map srvgroup
priority-group-table 1 weight 40 pfc
priority-group-table 2 weight 60
!
interface Vlan 1
!
interface Vlan 10
description server group1
!
interface Vlan 20
description server gorup2
!
interface Vlan 100
fcf forward
description FCoE VLAN
interface TenGigabitEthernet 0/0
switchport
switchport mode trunk
switchport trunk allowed vlan add 10
switchport trunk allowed vlan add 20
no shutdown
!
interface TenGigabitEthernet 0/1
switchport
switchport mode trunk
switchport trunk allowed vlan add 10
switchport trunk allowed vlan add 20
no shutdown
!
interface TenGigabitEthernet 0/2
switchport
switchport mode access
switchport access vlan 10
vlan classifier activate group 1 vlan 100
no shutdown
cee srvgroup
interface TenGigabitEthernet 0/3
switchport
switchport mode access
switchport access vlan 10
vlan classifier activate group 1 vlan 100
no shutdown
cee srvgroup
!
interface TenGigabitEthernet 0/4
switchport
switchport mode converged
vlan classifier activate group 1 vlan 100
no shutdown
cee srvgroup
!
interface TenGigabitEthernet 0/5
switchport
switchport mode converged
vlan classifier activate group 1 vlan 100
no shutdown
cee srvgroup
!
protocol lldp
advertise dcbx-fcoe-app-tlv
advertise dcbx-fcoe-logical-link-tlv
!
line console 0
login
line vty 0 31
login
!
end

Contributor
Posts: 39
Registered: ‎10-26-2010

Re: BR-8000 FCOE+QLogic QLE8142 CNA Card Question

I think the example you followed is bad.  I believe you need to just specify the "1" only once for the fourth entry.  Like this:

fcoe8000(conf-ceemap)# priority-table 2 2 2 1 2 2 2 2

Join the Community

Get quick and easy access to valuable resource designed to help you manage your Brocade Network.