Design & Build

Data Center Solution-Deployment Guide: Configure Brocade VDX in 'Standalone Mode' with Cisco STP

by on ‎09-16-2013 12:01 PM - edited on ‎04-09-2014 03:35 PM by pmadduru (3,177 Views)

Synopsis: This publication provides deployment examples for various types of STP used in Brocade VDX Switches with Cisco Catalyst switches. Brocade VDX Switches are often deployed in the Access layer at the Top-of-Rack in Standalone mode using STP. In many data centers, they connect to existing Cisco Catalyst switches in the Aggregation layer.

 

Contents

Preface

Overview

This document provides deployment guidance to how to connect up Brocade VDX Switches on 'Standalone Mode' to existing Cisco’s Catalyst Switches' infrastructure running STP (Spanning Tree Protocol).

When VDX Switches are connected up to existing customer's infrastructure running STP, VDX Switches on 'Standalone Mode' running NOS 3.0.x or onward support active participation in STP by sending STP BPDUs' (Bridge Packet Data Units) frames and processing received STP BPDUs' frames. However, NOS 3.0.x VCS Fabric does not support STP (which means NOS 3.0.x VCS Fabric does not send STP BPDUs frames, nor does it process received STP BPDUs frames), but it floods received STP BPDU frames into ports in the same VLAN, and therefore, the VCS fabric is seen as a wire connection from existing customer infrastructure’s point of view. There are some use cases for NOS 3.0.x VCS Fabric to be connected up to existing customer infrastructure running STP, so future publication about this is planned.

 

NOS 4.0.x VCS Fabric supports active participation in STP by sending STP BPDUs' frames and process received STP BPDU's frames while preserving full benefit of Brocade Ether Fabrics, and future publication about this is planned.

 

The document is not intended for the deployment scenarios connecting up VCS Fabric to existing customer's infrastructure running STP, but it is intended for the deployment scenarios connecting up VDX Switches on 'Standalone Mode' running NOS 3.0.x or onward to existing customer's infrastructure running STP.

 

Purpose of This Document

This deployment guide describes to how to perform the site survey to determine which STP is configured and how it is running on an existing network consisting of Cisco Catalyst Switches. Then, it describes to how to deploy Brocade VDX Switches into the existing datacenter network. 

 

The following Brocade and Cisco platforms are used in this deployment guide.

  • Brocade VDX 6730 Switch<
  • Cisco Catalyst 6500 and 3750 Switches

Audience

This document is intended for network design and operation staffs who want to add a Brocade VDX switches with STP to an existing data center network with Cisco Catalyst Switches.

 

Objectives

This deployment guide provides guidance and recommendations for how to deploy Brocade VDX Switches into an existing datacenter network with Cisco Catalyst 6500 and 3750 Switches for STP Interoperability.

 

Conclusion

When a newly deployed Brocade VDX Switch participates in an existing network’s STP topology, traffic between stations of hosts and servers in the existing network is not disrupted in the example network topology. However, this is highly dependent on network topology and traffic patterns, and therefore, any variation could result in different results.

 

Related Documents

The following documents are valuable resources for the designer. In addition, any Brocade release notes that have been published for Brocade VDX Switches should be reviewed.

 

References

 

About Brocade

Brocade® (NASDAQ: BRCD) networking solutions help the world’s leading organizations transition smoothly to a world where applications and information reside anywhere. This vision is designed to deliver key business benefits such as unmatched simplicity, non-stop networking, application optimization, and investment protection.

Innovative Ethernet and storage networking solutions for data center, campus, and service provider networks help reduce complexity and cost while enabling virtualization and cloud computing to increase business agility.

To help ensure a complete solution, Brocade partners with world-class IT companies and provides comprehensive education, support, and professional services offerings. (www.brocade.com)

 

Key Contributors

The content in this guide was developed by the following key contributors.

  • Lead Architect:          Chris Yoon, Strategic Solutions Lab
  • Technical Author:    Brook Reams, Strategic Solutions Lab

 

Document History

Date                  Version        Description

2013-09-16        1.0                Initial Release

 

Site Survey of an Existing Network

This section discusses the procedure for performing the site survey to determine which STP is configured and how it is running on an example existing network consisting of Cisco Catalyst 6500 and 3750 Switches.

 

Network Diagram

The figure below shows the example existing network diagram consisting of Cisco Catalyst 6500 and 3750 Switches.

 

ExampleExistingNetworkDiagram.jpg

  Example Existing Network Diagram

 

The existing network consists of 2 Cisco Catalyst 6500 Switches, and 2 Cisco Catalyst 3750 Switches. The Cisco Catalyst 6500 Switches are running IOS 122-33.SXI, and the Cisco Catalyst 3750 Switches are running IOS 15.0(1)SE or 12.2(46)SE. For the traffic sent through the network, flows are established using the Spirent Test Center (STC) tool. The 300 Mbps traffic flows are sent on each STC port and distributed using full mesh, and the packet size of the flows is 128 bytes. All interconnections between the Switches in the network are 10GEs or 1GEs, and all the ports are enabled as Layer 2 trunk using 802.1Q (dot1q), and allowing all the VLANs.

 

Site Survey Step-by-Step Procedure

This section discusses the step-by-step site survey procedure for the example existing network’s STP.

 

Step1

Determine which mode of STP is configured on the Cisco Catalyst Switches using

show run | in spanning-tree’ command.

Step 2

Determine Root Bridge of the Spanning Tree topology.

Step 3

Draw the Spanning Tree topology using the output of ‘show spanning-tree’ command.

 

Step 1:  Determine STP Mode of Cisco Switches

Determine which mode of STP is configured on the Cisco Catalyst Switches using ‘show run | in spanning-tree’ command.

 

1.a For the example existing network, the output of ‘show run | in spanning-tree’ shows ‘spanning-tree mode pvst’, it has been determined that PVST+ is configured.

If Rapid PVST+ is configured in the example existing network, the output of ‘show run | in spanning-tree’ will show ‘spanning-tree mode rapid-pvst’. If MSTP is configured in the example existing network, the output of ‘show run | in spanning-tree’ will show ‘spanning-tree mode mst’.

 

------------------------------

Cat6500-A#sh run | in spanning-tree

spanning-tree mode pvst

spanning-tree vlan 1,501 priority 0

Cat6500-B#sh run | in spanning-tree

spanning-tree mode pvst

spanning-tree vlan 502 priority 0

Cat3750-C#sh run | in spanning-tree

spanning-tree mode pvst

spanning-tree extend system-id

Cat3750-D#sh run | in spanning-tree

spanning-tree mode pvst

spanning-tree extend system-id

------------------------------

 

1.bspanning-tree vlan 1,501 priority 0’ means STP bridge priority is configured as ‘0’ for the specific VLAN 1,501 for the Cat6500-A to be elected as the Root Bridge in PVST+.  ‘spanning-tree vlan 502 priority 0’ means STP bridge priority is configured as ‘0’ for the specific VLAN 502,504 for the Cat6500-B to be elected as the Root Bridge in PVST+.

 

Step 2:  Determine Root Bridge of the Spanning Tree topology.

The output of ‘show spanning-tree’ below shows Cat6500-A and Cat6500-B are elected as the Root Bridge for the VLAN 1, 501 and the VLAN 502 each because of its STP bridge priority 0.

 

------------------------------

Cat6500-A#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f801

            This bridge is the root

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    0   

Address    0017.0fec.f801

            Hello Time  2 sec Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Desg FWD 2        128.131  P2p

Te3/3 Desg FWD 2        128.259  P2p

VLAN0501 

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f9f5

This bridge is the root

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    0   

Address    0017.0fec.f9f5

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Desg FWD 2        128.131  P2p

Te3/3 Desg FWD 2        128.259  P2p

VLAN0502 

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0019.0762.99f6

Cost        2

Port        131 (TenGigabitEthernet2/3)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

  Bridge ID  Priority    32768

Address    0017.0fec.f9f6

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Root FWD 2        128.131  P2p

Te3/3 Desg FWD 2        128.259  P2p

Cat6500-B#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f801

Cost        2

Port        131 (TenGigabitEthernet2/3)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    32768

Address    0019.0762.9801

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Root FWD 2        128.131  P2p

VLAN0501 

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f9f5

Cost        2

Port        131 (TenGigabitEthernet2/3)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    32768

Address    0019.0762.99f5

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Root FWD 2        128.131  P2p

VLAN0502 

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0019.0762.99f6

This bridge is the root

Hello Time  2 sec  Max Age 20 sec Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

  Bridge ID  Priority    0   

Address    0019.0762.99f6

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14 Desg FWD 4        128.14  P2p

Gi1/17 Desg FWD 4        128.17  P2p

Te2/3 Desg FWD 2        128.131  P2p 

Cat3750-C#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f801

Cost        4

            Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    32769 (priority 32768 sys-id-ext 1)

Address    001b.d406.bb80

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time  300 sec

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15 Desg FWD 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16  P2p

VLAN0501

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f9f5

Cost        4

Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    33269 (priority 32768 sys-id-ext 501)

Address    001b.d406.bb80

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time  300 sec

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15 Desg FWD 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16  P2p

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0019.0762.99f6

Cost        6

Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B,the Root Bridge.

  Bridge ID  Priority    33270 (priority 32768 sys-id-ext 502)

Address    001b.d406.bb80

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time  300 sec

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15            Altn BLK 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16  P2p

Cat3750-D#sh spanning-tree       

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f801

            Cost 6

Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    32769 (priority 32768 sys-id-ext 1)

Address    001e.f711.0400

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15 Altn BLK 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16  P2p

VLAN0501

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0017.0fec.f9f5

Cost        6

Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority    33269 (priority 32768 sys-id-ext 501)

Address    001e.f711.0400

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15 Altn BLK 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16 P2p

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

Address    0019.0762.99f6

Cost        4

Port        14 (GigabitEthernet1/0/14)

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B,the Root Bridge.

  Bridge ID  Priority    33270 (priority 32768 sys-id-ext 502)

Address    001e.f711.0400

Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14 Root FWD 4        128.14  P2p

Gi1/0/15 Desg FWD 4        128.15  P2p

Gi1/0/16 Desg FWD 4        128.16  P2p

------------------------------

Step 3:  Determine STP Topology

Draw the Spanning Tree topology using the output of ‘show spanning-tree’ command. The following is PVST+ Spanning Tree topology’s drawing in the example existing network.

Spanning Tree Topology for VLAN 1, 501

From the output of the Spanning Tree show commands, the PVST+ Spanning Tree topology below is drawn, and the Root Bridge is Cat6500-A.

 

12847_SpanningTreeTopologyVLAN 1, 501.jpg

      Spanning Tree Topology for VLAN 1, 501

 

 

Spanning Tree Topology for VLAN 502

From the output of the Spanning Tree show commands, the PVST+ Spanning Tree topology below is drawn, and the Root Bridge is Cat6500-B.

 

SpanningTreeTopologyVLAN502.jpg

  Spanning Tree Topology for VLAN 502

 

 

VDX Deployment into an Existing Network

Once the network administrator has determined which STP is configured and has the Spanning Tree Topology for the existing network, he or she is ready to deploy VDXs into the existing network.

 

Network Diagram Including Newly Deployed VDXs

The figure below shows an example network diagram consisting of Cisco Catalyst Switches and newly deployed VDX Switches.

 

NetworkDiagramShowingNewlyDeployedBrocadeVDXSwitches.jpg

Network Diagram Showing Newly Deployed Brocade VDX Switches

 

The VDX6730 Switches are running NOS 3.0.1a on the standalone mode, and the Cisco Catalyst 6500 Switches are running IOS 122-33.SXI. For the traffic sent through the network, flows are established using the Spirent Test Center (STC) tool. The 300 Mbps traffic flows are sent on each STC port and distributed using full mesh, and the packet size of the flows is 128 bytes. All interconnections between the VDX6730 Switches and the Catalyst Switches in the network are 10GEs, and all the ports are enabled as Layer 2 trunk using 802.1Q (dot1q), and allowing all the VLANs.

 

 

VDX Deployment Step-by-Step Procedure

The following are detailed steps about how to deploy 2 VDX6730 Switches in the Standalone mode into the existing network with Cisco Catalyst Switches with minimum traffic disruption by  STP.

 

Step1

Put all the ports of a newly deployed VDX Switch into ‘shutdown’ state prior to connecting the VDX to the existing network.

Step 2

Connect cables from the newly deployed VDX Switch to the existing network.

Step 3

Verify uplink interfaces of the newly deployed VDX Switch to the existing network are up and running.

Step 4

Verify the edge ports of the newly deployed VDX switch are up and running.

Step 5

For the newly deployed VDX, configure the mode of STP determined in the Site Survey Procedure.

Step 6

Enable the uplink interfaces of the newly deployed VDX to the existing network which allows the VDX to participate in the existing network’s Spanning tree topology.

Step 7

For another newly deployed VDX Switch, take the same steps 5-6 to configure the mode of STP determined in the Site Survey Procedure, and allow it to participate in the existing network’s Spanning Tree topology.

Step 8

Verify Spanning Tree Topology.

Step 9

Enable the edge ports of the newly deployed VDXs.

 

Step 1: Shutdown VDX Switch Ports

Put all the ports of a newly deployed VDX Switch into ‘shutdown’ state prior to connecting the VDX to the existing network.

Prior to connecting VDX6730-A and VDX6730-B to the existing network, put all the ports of those VDXs into ‘shutdown’ state. This will ensures the VDX Switch ports do not participate in the Catalyst Switch Spanning Tree topology when the VDX switches are connected to Cisco Catalyst Switches in Step 2.

 

Step 2: Connect Cables to VDX Switch

Connect cables from the newly deployed VDX Switch to the existing network.

Connect cables from VDX6730-A and VDX6730-B to Cat6500-A and Cat6500-B as shown in the diagram above.

 

Step 3:  Verify Uplink Interfaces on VDX Switch

Verify uplink interfaces of the newly deployed VDX Switch to the existing network are up and running.

Note: STP is not enabled yet, and therefore, to avoid loop-free topology, you should verify the uplink interface state with only one interface of the VDX in the UP state as shown in this step.

 

Put one uplink interface (that is, a physical interface or a port-channel interface) of the newly deployed VDX that is connected to the existing network into ‘no shutdown, and verify if the port state is up and running. Then put the port into ‘shutdown’ again.

 

The following is the procedure taken with the example network:

3.a Configure port-channel 1 between VDX6730-A and Cat6500-A, and put the member ports of port-channel 1, TenGigabitEthernet 0/5 and 0/7 of VDX6730-A into ‘no shutdown.

 


------------------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

channel-group 1 mode active type standard

!--- The LAG uses standard LACP, and LACP negotiating state is at active mode.

lacp timeout long

!--- The LACP PDU is sent for every 30 seconds, and the LACP timeout value (when no packet is received from the peer) is 90 seconds.
no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/7

interface TenGigabitEthernet 0/7

channel-group 1 mode active type standard

lacp timeout long

no shutdown

Cat6500-A#sh run interface Port-channel 1

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

!--- As in Cisco Catalyst Switches, by default a port is enabled (no shutdown), ‘no shutdown’ command is not seen in an interface configuration.

Cat6500-A#sh run interface TenGigabitEthernet 2/1

interface TenGigabitEthernet2/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

!--- The LAG uses standard LACP, and LACP negotiating state is at active mode.

Cat6500-A#sh run int TenGigabitEthernet 2/4

interface TenGigabitEthernet2/4

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

channel-group 1 mode active

------------------------------

For how to design LAG on Brocade VDX Switches, please use the following reference.

 

References

 

3.b Verify the state of the port-channel 1 is up and running.

The following verifies the port-channel 1 is up and running between VDX6730-A and Cat6500-A:

 

------------------------------

VDX6730-A# show port-channel detail

LACP Aggregator: Po 1

Aggregator type: Standard

  Actor System ID - 0x8000,00-05-33-d3-e2-ae

  Admin Key: 0001 - Oper Key 0001

  Receive link count: 2 - Transmit link count: 2

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-17-0f-ec-f8-00

  Partner Oper Key 0001

Member ports:

  Link: Te 0/5 (0x18028004) sync: 1 

  Link: Te 0/7 (0x18038006) sync: 1  *

LACP Aggregator: Po 2

Aggregator type: Standard

  Actor System ID - 0x8000,00-05-33-d3-e2-ae

  Admin Key: 0002 - Oper Key 0002

  Receive link count: 2 - Transmit link count: 2

  Individual: 0 - Ready: 1

  Partner System ID - 0x8000,00-19-07-62-98-00

  Partner Oper Key 0002

Member ports:

  Link: Te 0/6 (0x18030005) sync: 1 

  Link: Te 0/8 (0x18040007) sync: 1  *

Cat6500-A#sh etherchannel 1 detail                 

Group state = L2

Ports: 2  Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:  LACP

Minimum Links: 0

Ports in the group:

-------------------

Port: Te2/1

------------

Port state    = Up Mstr In-Bndl

Channel group = 1 Mode = Active        Gcchange = -

Port-channel  = Po1  GC  = -          Pseudo port-channel = Po1

Port index    = 1 Load = 0x55          Protocol = LACP

Flags:  S - Device is sending Slow LACPDUs.    F - Device is sending fast LACPDUs.

                  A - Device is in active mode.  P - Device is in passive mode.

Local information:

LACP port    Admin Oper  Port    Port

Port      Flags State  Priority Key      Key     Number  State

Te2/1    SA      bndl 32768 0x1      0x1  0x202  0x3D

! --- SA indicates the Port-channel's LACP timeout is long, and its LACP negotiating state is at active mode.

Partner's information:

          Partner Partner LACP Partner  Partner    Partner Partner      Partner

Port      Flags State  Port Priority  Admin Key  Oper Key  Port Number  Port State

Te2/1    SA   bndl 32768 0x0        0x1  0x5          0x3D

Age of the port in the current state: 3d:06h:37m:51s

Port: Te2/4

------------

Port state    = Up Mstr In-Bndl

Channel group = 1          Mode = Active        Gcchange = -

Port-channel  = Po1      GC  = -          Pseudo port-channel = Po1

Port index    = 0          Load = 0xAA          Protocol =  LACP

Flags:  S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

        A - Device is in active mode.    P - Device is in passive mode.

Local information:

LACP port    Admin    Oper Port        Port

Port      Flags  State Priority      Key Key  Number      State

Te2/4    SA      bndl 32768 0x1      0x1 0x205      0x3D

! --- SA indicates the Port-channel's LACP timeout is long, and its LACP negotiating state is at active mode.

Partner's information:

          Partner Partner  LACP Partner  Partner Partner    Partner      Partner

Port      Flags State    Port Priority Admin Key  Oper Key  Port Number  Port State

Te2/4    SA  bndl 32768 0x0 0x1      0x7 0x3D

Age of the port in the current state: 3d:06h:37m:51s

Port-channels in the group:

----------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel  = 47d:21h:57m:59s

Logical slot/port  = 14/1 Number of ports = 2

HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol = LACP

Fast-switchover    = disabled

Ports in the Port-channel:

Index  Load  Port EC state        No of bits

------+------+------+------------------+-----------

  1    55 Te2/1 Active    4

  0    AA Te2/4 Active    4

Time since last port bundled: 3d:06h:37m:53s Te2/4

Time since last port Un-bundled: 4d:23h:16m:14s Te2/4

Last applied Hash Distribution Algorithm: Fixed

------------------------------

3.c Once it is verified that the state of the port-channel (LAG) state is up and running, put the port channel and its member ports into ‘shutdown’ again.

------------------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

channel-group 1 mode active type standard

lacp timeout long

shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/7

interface TenGigabitEthernet 0/7

channel-group 1 mode active type standard

lacp timeout long

shutdown

------------------------------

3.d Follow steps 1-3 for the port-channel 2 between VDX6730-A and Cat6500-B to verify the state of the port-channel is up and running.

3.e Follow steps 1-4 for TenGigabitEthernet 0/5 and 0/6 of VDX6730-B to verify the state of those interfaces’ state is up and running.

This example discusses with a port-channel interface, but it is applied to a physical interface of 1GE or 10GE in the same way. Therefore, you can configure 1GE or 10GE and verify its port state the same way.

 

Step 4: Verify VDX Edge Ports Are Up

Verify the edge ports of the newly deployed VDX switch are up and running.  An edge port is the one directly connected to end stations of servers or hosts. In this example network, TenGigabitEthernet 0/9 of VDX6730-A and VDX6730-B are edge ports and they are connected to STC (Spirent Test Center) ports simulating traffic. You can configure and verify TenGigabitEthernet 0/9 of the VDX6730-A which has connection to STC that is simulating end stations of servers or hosts.

 

 

The following is the procedure taken with the example network:

 

4.a Configure TenGigabitEthernet 0/9 of VDX6730-A, and put it into ‘no shutdown’.

 

 

------------------------------

VDX6730-A# show running-config interface TenGigabitEthernet 0/9

interface TenGigabitEthernet 0/9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

-----------------------------

 

4.b Verify the interface state is up and running.

 

-----------------------------

VDX6730-A# show interface tengigabitethernet 0/9

TenGigabitEthernet 0/9 is up, line protocol is up (connected)

Hardware is Ethernet, address is 0005.33d3.e2db

    Current address is 0005.33d3.e2db

Pluggable media present

Interface index (ifindex) is 402948104

MTU 2500 bytes

LineSpeed Actual    : 10000 Mbit

LineSpeed Configured : Auto, Duplex: Full

Flowcontrol rx: off, tx: off

Priority Tag disable

IPv6 RA Guard disable

Last clearing of show interface counters: 00:00:02

Queueing strategy: fifo

Receive Statistics:

    0 packets, 0 bytes

    Unicasts: 0, Multicasts: 0, Broadcasts: 0

    64-byte pkts: 0, Over 64-byte pkts: 0, Over 127-byte pkts: 0

    Over 255-byte pkts: 0, Over 511-byte pkts: 0, Over 1023-byte pkts: 0

    Over 1518-byte pkts(Jumbo): 0

    Runts: 0, Jabbers: 0, CRC: 0, Overruns: 0

    Errors: 0, Discards: 0

Transmit Statistics:

    0 packets, 0 bytes

    Unicasts: 0, Multicasts: 0, Broadcasts: 0

    Underruns: 0

    Errors: 0, Discards: 0

Rate info (interval 299 seconds):

    Input 0.000000 Mbits/sec, 0 packets/sec, 0.00% of line-rate

    Output 0.000000 Mbits/sec, 0 packets/sec, 0.00% of line-rate

Time since last interface status change: 4d22h58m

------------------------------

 

4.c Once it is verified that the interface state is up and running, put it into ‘shutdown’ again.

------------------------------

VDX6730-A# show running-config interface TenGigabitEthernet 0/9

interface TenGigabitEthernet 0/9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

shutdown

-----------------------------

 

4.d Take the same above steps 1-3 for TenGigabitEthernet 0/9 of VDX6730-B to verify the interface state.

 

Step 5:  Configure STP Mode on VDX Switch

For the newly deployed VDX, configure the mode of STP as found in the Site Survey Procedure. The following is the procedure taken with the example network:

5.a In this example network, it has been determined that PVST+ is configured and running in the existing network,  enable PVST+ with ‘protocol spanning-tree pvst’ command under protocol spanning-tree for VDX6730-A.

----------------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree pvst

----------------------------

5.a To interoperate with Cisco Switches in PVST+, for VDX6730-A Switch, enable ‘spanning-tree bpdu-mac 0100.0ccc.cccd’ command under port-channel 1 and port-channel 2 that are connected to Cisco Switches.

---------------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

--------------------------------

5.b Currently, for VDX6730-A’s uplink interfaces (that is, port-channel 1 and 2) to the existing network are in the state of ‘shutdown’, VDX6730-A does not participate in the existing network’s Spanning tree topology. Therefore, the output of ‘show spanning-tree brief’ shows those ports are in ‘Disabled (DIS)’ state (STS) as shown below.

------------------------------

VDX6730-A# show running-config protocol spanning-tree

protocol spanning-tree pvst

!

VDX6730-A#

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

shutdown

!

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

shutdown

VDX6730-A# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9      DIS  DIS 20000000  128  P2P              No 

Po 1          DIS DIS  20000000  128 P2P              No 

Po 2          DIS DIS  20000000  128 P2P              No 

!--- It shows the ports are in ‘Disabled (DIS)’ state in the Spanning Tree Topology as they are in the state of ‘shutdown’.

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 33269

                  Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          DIS DIS  20000000  128 P2P              No 

Po 2          DIS DIS  20000000  128 P2P              No 

!--- It shows the ports are in ‘Disabled (DIS)’ state in the Spanning Tree Topology as they are in the state of ‘shutdown’.

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          DIS DIS  20000000  128 P2P              No

Po 2          DIS DIS  20000000  128 P2P              No 

!--- It shows the ports are in ‘Disabled (DIS)’ state in the Spanning Tree Topology as they are in the state of ‘shutdown’.

--------------------------------------

 

Step 6:  Enable Uplink Interfaces on VDX Switch

Enable the uplink interfaces of the newly deployed VDX to the existing network which allows the VDX to participate in the existing network’s Spanning tree topology.

 

Note: When the newly deployed VDX participates in the existing network’s Spanning Tree topology, traffic between stations of hosts and servers in the existing network is not disrupted in the example network topology. However, this is highly dependent on network topology and traffic patterns, and therefore, any variation could result in different results.

 

 

The following is the procedure taken with the example network:

 

6.a Put all the up-link interfaces to the existing network, port-channel 1 and port-channel 2 of VDX6730-A, into ‘no shutdown’.

----------------------------------

VDX6730-A# show running-config interface Port-channel 1

interface Port-channel 1

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/5

interface TenGigabitEthernet 0/5

channel-group 1 mode active type standard

lacp timeout long

no shutdown

VDX6730-A# show running-config interface TenGigabitEthernet 0/7

interface TenGigabitEthernet 0/7

channel-group 1 mode active type standard

lacp timeout long

no shutdown

VDX6730-A# show running-config interface Port-channel 2

interface Port-channel 2

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

spanning-tree bpdu-mac 0100.0ccc.cccd

no shutdown

VDX6730-A# show run int Tengigabitethernet 0/6

interface TenGigabitEthernet 0/6

channel-group 2 mode active type standard

lacp timeout long

no shutdown

VDX6730-A# show run int Tengigabitethernet 0/8

interface TenGigabitEthernet 0/8

channel-group 2 mode active type standard

lacp timeout long

no shutdown

-------------------------------------

6.b Therefore, the VDX6730-A now participates in the existing network’s STP topology. The state of the port-channel 1 and 2 starts in Blocking state, and later changes Listening, Learning, and Forwarding states as shown below. 

-----------------------------------

VDX6730-A# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f801

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT LIS  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Listening state and Po2 (Port-channel 2) is in Blocking state.

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f9f5

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT  LIS 2000      128  P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Listening state and Po2 (Port-channel 2) is in Blocking state.

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0019.0762.99f6

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128  P2P              No 

Po 1          ALT BLK  2000      128 P2P              No 

Po 2          RTPT LIS  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Blocking state and Po2 (Port-channel 2) is in Listening state.

VDX6730-A# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f801

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT LRN  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Learning state and Po2 (Port-channel 2) is in Blocking state.

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f9f5

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT LRN  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Learning state and Po2 (Port-channel 2) is in Blocking state.

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0019.0762.99f6

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          ALT BLK  2000      128 P2P              No 

Po 2          RTPT LRN  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Learning state and Po2 (Port-channel 2) is in Blocking state.

VDX6730-A# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f801

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT FWD  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Forwarding state and Po2 (Port-channel 2) is in Blocking state.

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f9f5

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33269

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT FWD  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Forwarding state and Po2 (Port-channel 2) is in Blocking state.

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                  Address 0019.0762.99f6

                  Hello Time 2, Max Age 20, Forward Delay 15

      Bridge ID    Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          ALT BLK  2000      128 P2P              No 

Po 2          RTPT FWD  2000      128 P2P              No 

!--- Po1 (Port-channel 1) is in Blocking state and Po2 (Port-channel 2) is in Blocking state.

-----------------------------------------

 

Step 7:  Repeat Steps 5-6 for Next VDX Switch

For another newly deployed VDX Switch (that is, VDX6730-B), follow steps 5-6 to configure the mode of STP determined in the Site Survey Procedure, and allow it to participate in the existing network’s STP topology.

 

Step 8:  Verify Spanning Tree Topology.

The following is the procedure taken with the example network:

8.a Verify PVST+ Spanning Tree topology is correct with ‘show spanning-tree brief’ command and ‘show spanning-tree’ command for the VDX6730 Switches and the Cisco Catalyst Switches each.

 

8.b  Verify if the Root Bridge for VLAN 1, 501 is Cat6500-A, and the Root Bridge for VLAN 502 is Cat6500-B with ‘show spanning-tree brief’ command and ‘show spanning-tree’ on the VDX6730 Switches and Cisco Catalyst Switches each.

 

The following is PVST+ Spanning Tree topology’s drawing in the example network.

 

 

Spanning Tree Topology for VLAN 1,501

From the output of the Spanning Tree show commands, the PVST+ Spanning Tree topology below is drawn. It verifies that the PVST+ Spanning Tree topology is correct and that the Root Bridge is Cat6500-A.

 

SpanningTreeTopologyLAN 1,501.jpg

  Spanning Tree Topology for VLAN 1, 501

 

---------------------------------------------------------------

VDX6730-A# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f801

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

      Bridge ID    Priority 32769

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT FWD  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No 

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                  Address 0017.0fec.f9f5

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

      Bridge ID    Priority 33269

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          RTPT FWD  2000      128 P2P              No 

Po 2          ALT BLK  2000      128 P2P              No

VDX6730-B# show spanning-tree brief

VLAN 1

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0017.0fec.f801

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

      Bridge ID    Priority 32769

Address 0005.33f3.dcc7

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000      128 P2P              No

Te 0/6        ALT BLK  2000      128 P2P              No 

Te 0/9        DIS DIS  20000000  128 P2P              No 

VLAN 501

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

                  Address 0017.0fec.f9f5

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

    Bridge ID Priority 33269

Address 0005.33f3.dcc7

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        RTPT FWD  2000      128 P2P              No 

Te 0/6        ALT BLK  2000      128 P2P              No 

Te 0/9        DIS DIS  20000000  128 P2P              No

Cat6500-A#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0017.0fec.f801

            This bridge is the root

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority 0   

            Address    0017.0fec.f801

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14              Desg FWD 4        128.14  P2p

Gi1/17              Desg FWD 4        128.17  P2p

Te2/2              Desg FWD 2        128.130  P2p

Te2/3              Desg FWD 2        128.131  P2p

Te3/3              Desg FWD 2        128.259  P2p

Po1                Desg FWD 1        128.1665 P2p

VLAN0501 

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0017.0fec.f9f5

            This bridge is the root

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority 0   

            Address    0017.0fec.f9f5

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14              Desg FWD 4        128.14  P2p

Gi1/17              Desg FWD 4        128.17  P2p

Te2/2              Desg FWD 2        128.130  P2p

Te2/3              Desg FWD 2        128.131  P2p

Te3/3              Desg FWD 2        128.259  P2p

Po1                Desg FWD 1        128.1665 P2p

Cat3750-D#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0017.0fec.f801

            Cost        6

            Port        14 (GigabitEthernet1/0/14)

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f801 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority 32769  (priority 32768 sys-id-ext 1)

            Address    001e.f711.0400

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14            Root FWD 4        128.14  P2p

Gi1/0/15            Altn BLK 4        128.15 P2p

Gi1/0/16            Desg FWD 4        128.16  P2p

VLAN0501

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0017.0fec.f9f5

            Cost        6

            Port        14 (GigabitEthernet1/0/14)

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0017.0fec.f9f5 is the MAC address of the Cat6500-A, the Root Bridge.

  Bridge ID  Priority 33269  (priority 32768 sys-id-ext 501)

            Address    001e.f711.0400

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- -----------------------------

Gi1/0/14            Root FWD 4        128.14  P2p

Gi1/0/15            Altn BLK 4        128.15  P2p

Gi1/0/16            Desg FWD 4        128.16  P2p

----------------------------------

 

Spanning Tree Topology for VLAN 502

From the output of the Spanning Tree show commands, the PVST+ Spanning Tree topology below is drawn. It verifies that the PVST+ Spanning Tree topology is correct and that the Root Bridge is Cat6500-B.

 

SpanningTreeTopologyVLAN502 .jpg

  Spanning Tree Topology for VLAN 502

 

 

---------------------------------------------------------

VDX6730-A# show spanning-tree vlan 502 brief

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0019.0762.99f6

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

      Bridge ID    Priority 33270

Address 0005.33d3.e2ce

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/9        DIS DIS  20000000  128 P2P              No 

Po 1          ALT BLK  2000      128 P2P              No 

Po 2          RTPT FWD  2000      128 P2P              No 

VDX6730-B# show spanning-tree vlan 502 brief

VLAN 502

Spanning-tree Mode: Per-VLAN Spanning Tree Protocol

      Root ID      Priority 0

Address 0019.0762.99f6

                  Hello Time 2, Max Age 20, Forward Delay 15

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

      Bridge ID    Priority 33270

Address 0005.33f3.dcc7

                  Hello Time 2, Max Age 20, Forward Delay 15

Interface    Role Sts  Cost      Prio Link-type        Edge

---------------------------------------------------------------------

Te 0/5        ALT BLK  2000      128 P2P              No 

Te 0/6        RTPT FWD  2000      128  P2P              No 

Te 0/9        DIS DIS  20000000  128 P2P              No 

Cat6500-B#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0019.0762.99f6

            This bridge is the root

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

  Bridge ID  Priority 0   

            Address    0019.0762.99f6

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time 300

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/14              Desg FWD 4        128.14 P2p

Gi1/17              Desg FWD 4        128.17  P2p

Te2/2              Desg FWD 2        128.130  P2p

Te2/3              Desg FWD 2        128.131  P2p

Po2                Desg FWD 1        128.1665 P2p

Cat3750-C#sh spanning-tree vlan 502

VLAN0502

  Spanning tree enabled protocol ieee

  Root ID    Priority 0

            Address    0019.0762.99f6

            Cost        6

            Port        14 (GigabitEthernet1/0/14)

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

!--- 0019.0762.99f6 is the MAC address of the Cat6500-B, the Root Bridge.

  Bridge ID  Priority 33270  (priority 32768 sys-id-ext 502)

            Address    001b.d406.bb80

            Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

            Aging Time  300 sec

Interface          Role Sts Cost      Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Gi1/0/14            Root FWD 4        128.14  P2p

Gi1/0/15            Altn BLK 4        128.15  P2p

Gi1/0/16            Desg FWD 4        128.16  P2p

-----------------------------------

 

Step 9:  Enable the edge ports of the newly deployed VDXs.

 

In this example network, put TenGigabitEthernet 0/9 of VDX6730-A and VDX6730-B each, edge ports, into ‘no shutdown’, and therefore, servers or hosts connected to the edge ports get ready to send or receive traffic.

 

When edge ports directly connected to end stations of servers or hosts participate in the Spanning Tree topology, they cannot create Active Spanning Tree topology change, and therefore, traffic between stations of servers or hosts in the existing network should not be disrupted.

 

When the edge ports of VDX6730-A and VDX6730-B participated in the Spanning Tree topology by ‘no shutdown’, traffic between stations of servers or hosts in the existing network was not disrupted.

 

--------------------------

VDX6730-A# show running-config interface TenGigabitEthernet 0/9

interface TenGigabitEthernet 0/9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

VDX6730-B# show running-config interface TenGigabitEthernet 0/9

interface TenGigabitEthernet 0/9

switchport

switchport mode trunk

switchport trunk allowed vlan all

switchport trunk tag native-vlan

no shutdown

------------------------------

Comments
by eyoon
on ‎09-17-2013 11:04 PM

I am the author of this document. Please let me know if you think of anything that can be added to make the document more useful, or if you have any feedback or questions about the document.